c4gp 1.6hdi tubo solenoid vacuum question

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

kingjafad
Donor 2023
Posts: 59
Joined: 22 Dec 2022, 14:03
x 4

c4gp 1.6hdi tubo solenoid vacuum question

Post by kingjafad »

Hi Folks,
on my 2010 C4GP 1.6hdi (auto) I have a P0299 code (turbo pressure lower than reference flow) - It is actually reading turbo pressure but there is no vacuum to the turbo 'lever' (turbo end of pipe 7 in picture below). The 'lever' does actually move freely by pushing it and seems to hold the vacuum (pulling the pipe off and putting finger over it/pushing lever down). So that led me to the turbo pressure solenoid. I had it on the ramp yesterday and spotted 3 pipes on solenoid, 2 are connected but one is connected dangling loose (pipe 6). Its only about 10 inches long or so, perhaps shorter. At the time i couldnt see where it should go to at the time and i cant get the car back on the lift until next week.
So i just want to ask if anyone knows if this is the likely cause.
Air Circuit.PNG
(picture pinched from one of Marc's very helpful posts a couple of years ago - thanks Marc.)
I am talking about pipe number 6, going to black plastic box number 3 in this diagram.
Anyone know the name of plastic box 3 and if pipe 6 is a vacuum output or input to that box please?
When it was on the lift i only saw the plastic box 3 pipe 5, and i couldnt see or feel the connection that should go to pipe 6

Cheers in advance guys.
RichardW
Forum Treasurer
Posts: 11113
Joined: 07 Aug 2002, 17:12
x 1061

Re: c4gp 1.6hdi tubo solenoid vacuum question

Post by RichardW »

3 is a vacuum reservoir, so 6 is the vac 'supply' - it def won't work without this!
Richard W
kingjafad
Donor 2023
Posts: 59
Joined: 22 Dec 2022, 14:03
x 4

Re: c4gp 1.6hdi tubo solenoid vacuum question

Post by kingjafad »

Thanks Richard, that is exactly the 'easy' fix i was hoping for. Now that i know for certain there is a another connector somewhere on the reservoir I can persevere/get a good torch and mirror to push it back on ;)
Cheers.
RichardW
Forum Treasurer
Posts: 11113
Joined: 07 Aug 2002, 17:12
x 1061

Re: c4gp 1.6hdi tubo solenoid vacuum question

Post by RichardW »

Possibly it is broken off, and the spigot is inside the pipe?
Richard W
kingjafad
Donor 2023
Posts: 59
Joined: 22 Dec 2022, 14:03
x 4

Re: c4gp 1.6hdi tubo solenoid vacuum question

Post by kingjafad »

RichardW wrote: 22 Apr 2024, 20:35 Possibly it is broken off, and the spigot is inside the pipe?
Yup, it certainly was. Got it on the ramp this afternoon and sorted it with a scrappy reservoir. All seems good now. Thanks Richard.