3008 (new) aircond blower fan intermittent then dead

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

measaura
Posts: 21
Joined: 10 Dec 2019, 07:32
x 2

3008 (new) aircond blower fan intermittent then dead

Post by measaura »

Hi great people here.

TLDR: New AC blower motor died in very hot day. No voltage at motor.

I have issues with my Aircond blower. Last month it starts behaving weird especially in hot afternoon after I leave the car in the sun. Initially, the blower will die after few minutes running. Then I found out if I put the speed not at the max (like 75%) the fan will run just fine. It works fine until last 2 weeks, where it really dead and not running anymore. I checked the blower voltage, looks good and responding to the controller change. Dismantled the blower and found out the motor brush is almost gone. Replaced the motor with a new one, and all AC functions normally, until yesterday.

Yesterday afternoon hits 45 degrees Celsius (shown on the display. Was 48 last couple of days, maybe due to the equinox) and the blower works fine (on Auto mode) for about 5 minutes. Suddenly the blower stops running but the compressor and everything else is still working (I realise the engine RPM is still higher than without AC, then I switch off the AC, the RPM drops). After fetching my daughter from school, went home and start doing some troubleshooting. I dismantled the blower to see if there's any problem with the brush but nothing wrong there. Checked the continuity, all okay. Plugged all cables back into the motor, start the car and checked the voltage at the motor terminals, found 0 volts there. No matter what I do at the control panel, I can't get the motor running. Then I read some posts suggesting to reset the BSI. I take out the +ve terminal from the battery, wait for a minute, then reconnect it. Heard some clicks, then I start the car. To my surprise, the motor runs fine! Then I reassembled and everything works fine last night and this morning.

This afternoon, the temperature was about 43 degrees Celsius. When I start the car, the blower runs for a few seconds and then stutter and died. I tried to reset but it's not working.

Can anybody help me to find the relay or other possible fuses, other than the 40A F11 in the engine bay? Could it be the speed controller module (which is very unlikely)?

P/S: Just changed the car battery to DIN66L from DIN55L 3 days ago due to battery totally dead. Not sure if it's related.
VIN: VF3**************[VIN obfuscated, can be read by forum staff]
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37278
Joined: 15 Sep 2015, 19:38
x 5706

Re: 3008 (new) aircond blower fan intermittent then dead

Post by GiveMeABreak »

You'll probably find it's the heater motor control module. This is a resistor module that powers the motor up in stages as needed. They can fail and need replacing. Often when they fail it means the fan is on high speed or nothing - but this isn't always the case. In these high temperatures it may just be overheating. I suggest you try replacing the module and don't get a cheap unbranded version - get a branded make like BEHR, Febi Bilstein or Valeo where possible or an original.
Please Don't PM Me For Technical Help

Marc
User avatar
Paul-R
Donor 2023
Posts: 6928
Joined: 07 May 2009, 16:24
x 1376

Re: 3008 (new) aircond blower fan intermittent then dead

Post by Paul-R »

The OP says that there is no voltage so, assuming that the power feed is the same as on the C5 and the control unit is on the earthy side of the motor, he/she needs to find out why?
As I get older I think a lot about the hereafter - I go into a room and then wonder what I'm here after.

Inside every old person is a young person wondering what the hell happened.

"Trying is the first step towards failure" ~ Homer J Simpson​
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37278
Joined: 15 Sep 2015, 19:38
x 5706

Re: 3008 (new) aircond blower fan intermittent then dead

Post by GiveMeABreak »

He said there's no voltage at the motor, not at the heater motor control module which obviously controls supply to the motor.
Please Don't PM Me For Technical Help

Marc
User avatar
Paul-R
Donor 2023
Posts: 6928
Joined: 07 May 2009, 16:24
x 1376

Re: 3008 (new) aircond blower fan intermittent then dead

Post by Paul-R »

Yes, but as I said "assuming that the power feed is the same as on the C5 and the control unit is on the earthy side of the motor" then the the motor is fed with power all the time and it's the earthy side of motor that then gets modulated by the control unit. It's related to what I posted the other week; why have we stopped suggesting putting a link in place of the control unit to check that the motor is working?
As I get older I think a lot about the hereafter - I go into a room and then wonder what I'm here after.

Inside every old person is a young person wondering what the hell happened.

"Trying is the first step towards failure" ~ Homer J Simpson​
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37278
Joined: 15 Sep 2015, 19:38
x 5706

Re: 3008 (new) aircond blower fan intermittent then dead

Post by GiveMeABreak »

Its a different system to the C5 and the HMCM on these is fitted directly onto the underside of the Blower motor assembly, and I think you've just offered up your suggestion Paul.
Please Don't PM Me For Technical Help

Marc
measaura
Posts: 21
Joined: 10 Dec 2019, 07:32
x 2

Re: 3008 (new) aircond blower fan intermittent then dead

Post by measaura »

Thank you all for the replies.

The blower control module is different from the one that I had in my Xantia / early C5. It doesn't have those big MOSFETs on the heatsink, and the heatsink is quite small compared to the one in my Xantia. Voltage is measured when the motor is connected to the module. If the motor is not connected, there will only be floating voltage around 13+V without any variation, even when the speed is changed at the panel.

As of now, the module is still working fine, after I remove the battery for a minute, reconnect, then unplug the module for a few minutes, and reconnect everything. I still haven't got any issues till today, but the weather is also getting better at around 38 - 43 degrees, with rain in the evening. Anyway, I'm still suspecting the module to go kaput anytime soon as the car has been about 10 years old, and I suspect the previous owner never got it changed.

I will update if the problem reoccurring. As for now, I will consider this case is closed.

- Dinas -
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37278
Joined: 15 Sep 2015, 19:38
x 5706

Re: 3008 (new) aircond blower fan intermittent then dead

Post by GiveMeABreak »

Thanks for the update.
Please Don't PM Me For Technical Help

Marc
measaura
Posts: 21
Joined: 10 Dec 2019, 07:32
x 2

Re: 3008 (new) aircond blower fan intermittent then dead

Post by measaura »

Hi all,

Just an update, it happens again last week. What I did to reset it is unplugging the power cable to the motor, and connect it again. As of now, I'm controlling the speed manually and not to let it go to the max. speed. Planning sort that out later by replacing the speed control module.

Now the car is in the workshop for engine overhaul due to cylinder 2 misfiring error (no compression at all) happened during my way back home on the highway last Monday. Luckily manage to drive another 60+ kms back home running on 3 cylinders. Since the car is in the workshop, I did some query with Diagbox and found few other issues with TPMS and side right front parking sensor. Maybe I'll open another thread for those issues.