C5 X7 Tourer failed LED high brake light.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
bigblackfalco
Posts: 157
Joined: 21 Feb 2010, 14:56
x 5

Re: C5 X7 Tourer failed LED high brake light.

Post by bigblackfalco »

Well I delved today!!
Good fun getting it all apart.
It wasn't the wire broken or connectors, so prised the sealed LED unit apart. The main connector track was corroded, so tried jumper wires straight on to the PCB terminals.
The best i could get was a very dim output on 3 out of the 4 LEDs, so decided it was beyond my scope.
Found a new unit on ebay for under £50 delivered.

I also dismantled the broken washer hose components. I will replace with a complete length of clear 4 mm plastic flexi pipe and reassemble when the new LED unit arrives in the post.
58 plate (2009) C5 Tourer 2.0 HDi VTR+
bubbleberry
Posts: 25
Joined: 07 Dec 2022, 13:59
x 3

Re: C5 X7 Tourer failed LED high brake light.

Post by bubbleberry »

Hi folks, I have a high stop light that’s gone. I’m not great with electrics, but will get it tested. Is there a plug and play replace the for the led or what’s would you advise as a low cost repair ? Also have one reverse light our - all other lights in the cluster are fine, if a phone has any advice. I have so many issues with this car, and not a lot of money so I’m trying my best, and am reading as much as possible in the forum, but appreciate any advice.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 36241
Joined: 15 Sep 2015, 19:38
x 5463

Re: C5 X7 Tourer failed LED high brake light.

Post by GiveMeABreak »

The LEDs can't be replaced, it's a new unit to be honest.
Please Don't PM Me For Technical Help

Marc
bubbleberry
Posts: 25
Joined: 07 Dec 2022, 13:59
x 3

Re: C5 X7 Tourer failed LED high brake light.

Post by bubbleberry »

Hi Marc, thanks again for you help. Not sure how I missed this one, much appreciated.
Online
User avatar
MattBLancs
Donor 2024
Posts: 2358
Joined: 25 Apr 2022, 09:03
x 1265

Re: C5 X7 Tourer failed LED high brake light.

Post by MattBLancs »

bigblackfalco wrote: 02 Jun 2018, 14:40 I also dismantled the broken washer hose components. I will replace with a complete length of clear 4 mm plastic flexi pipe and reassemble when the new LED unit arrives in the post.
Split on the bit between bodywork and bootlid?

If so, snap! Mine too. If you pull the rubber boot off at bodywork end (nylon clips behind the rubber, quite awkward!) And remove the whole flipping spoiler assembly then you can replace only a short length (IE the bit that flexes) there's a straight coupling on the bodywork end, think another on spoiler too. Had to cut the existing semi rigid plastic hose off the tail.


Watch out with the clips on top edge of spoiler. Unlike the white plastic clips (which break on removal!) The clips DO NOT enjoy a nice firm thump into place, instead breaking off. Didn't spot these and broke mine on reassembly, much to my dismay.