C3 1.6hdi 2012 additive pump testing.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

MyC3
Posts: 10
Joined: 15 Jan 2022, 15:50

C3 1.6hdi 2012 additive pump testing.

Post by MyC3 »

There is an ecu message that the additive pump is not working.
I removed the pump with it's associated circuit board.
Applying 9 Volts directly to the pump motor results in the motor rotating.
So the fault must be either the circuit board, the wiring to the unit or possibly some other fault.
There are 3 pins on the plug/socket.
What should I be able to measure on these pins?
Could there be a problem with the fuel tank cap which is not sending a signal to the unit.
Thanks for any help
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28052
Joined: 15 Sep 2015, 19:38
x 3385

Re: C3 1.6hdi 2012 additive pump testing.

Post by GiveMeABreak »

We'd need the actual fault codes, so put them up with your VIN and we'll see what we can.

There are specific faults codes that relate to the additive system and the fuel filler cap has a specific code if it was that being the problem.
wheeler
Posts: 5665
Joined: 21 Sep 2002, 19:07
x 396

Re: C3 1.6hdi 2012 additive pump testing.

Post by wheeler »

If this is the combined tank/pump with the 3 pin plug normally at the tank you should have an ignition controlled live, an earth & a LIN connection.
Ideally you want diagbox for live data from cap sensor etc.
MyC3
Posts: 10
Joined: 15 Jan 2022, 15:50

Re: C3 1.6hdi 2012 additive pump testing.

Post by MyC3 »

I have changed the additive pump and print and the error has gone.
My next problem is that the Code P0693 and P0493 show up on a diagnostic instrument ( Not Diagbox)
I have changed the unit that is connected to the fan motor ( I see it as 1529 on a print I have of the cooling circuit diagram) Called perhaps fan motor control or relay unit.
Despite the change I still see these fault codes appearing.
I have tested the radiator fan by connecting pins 1 and 2 together on unit 1529 which therefore applies 12V+ directly to the motor. It runs fine as far as I can see.

With the plug4VNR ( I think it is called) removed on the 1529 I measure Pin 1 3.5 V Pin 2 3.5 V Pin 3 12V Pi 4 10.8V.
The car will not rev beyond 3500 in neutral and lacks power so it must be in a safe mode of operation.

Supplementary info. The Stop and Start system doesnt work . It hasnt since changing the engine.
The car engine is not the original engine. It is of the same type though and I have driven 20 K miles since changing the engine.
There is another code that appears U1218 . something about CAN and BSI.
The three faults are all permanent faults.

VF7**************[VIN obfuscated, can be read by forum staff] is the original number of this car.
MyC3
Posts: 10
Joined: 15 Jan 2022, 15:50

Re: C3 1.6hdi 2012 additive pump testing.

Post by MyC3 »

This should be re posted under new topic title but I couldnt see how to do that. I couldnt find out how to create a new post at all. Can users only have one topic posted at a time?
Hell Razor5543
Donor 2021
Posts: 12392
Joined: 01 Apr 2012, 09:47
x 1650

Re: C3 1.6hdi 2012 additive pump testing.

Post by Hell Razor5543 »

Users can have as many as they need posts open and active. As this 'new' post would be Citroen related you would go into the "Citroen" section and click on the "New Topic" button to start a new post.
MyC3
Posts: 10
Joined: 15 Jan 2022, 15:50

Re: C3 1.6hdi 2012 additive pump testing.

Post by MyC3 »

Thanks I will try that .