All the dashboard warning lights on 07 C4 GRAND PICASSO will not turn off

All the sticky threads from the Citroen and Activa forums have been relocated here at least on a temporary basis.

Moderators: RichardW, myglaren

Pattypickle
Posts: 2
Joined: 27 Dec 2021, 17:30

All the dashboard warning lights on 07 C4 GRAND PICASSO will not turn off

Post by Pattypickle »

Can anyone give me advice on how to turn off all the dashboard warning lights on an 07 C4 GRAND PICASSO please. I’ve read it might be a fuse box, where is that located?

Any other ideas, I cannot start car, reverse or or take off handbrake to bring it anywhere to get sorted.

No idea if RAC even come out in such circumstances do they?

Literally had the car only a week … it’s just passed it’s MOT

Tried turning it off, pressing the 000 button but that only removed the wrench sign, nothing else

Thanks in advance all
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26532
Joined: 15 Sep 2015, 19:38
x 3104

Re: All the dashboard warning lights on 07 C4 GRAND PICASSO will not turn off

Post by GiveMeABreak »

The warning lights are on for a reason - you can't just turn them off without first fixing the problem.

If you bought it from a garage a week ago, take it back or get them to take it back as it's not fit for purpose if it won't start. If it was a private sale, there's not much you can do. Did the garage that you had the MOT done at do any work on the vehicle?

At this stage there's not much we can do to help without further information. Don't start unplugging fuses and the like until you know what the issue is. If you have 'Home Start' or similar on your breakdown policy, that will mean they will attempt a repair at your house - or if not, most will take it to a local garage for repair.

Either way you need to have it diagnosed to find out what the problem is.
Pattypickle
Posts: 2
Joined: 27 Dec 2021, 17:30

Re: All the dashboard warning lights on 07 C4 GRAND PICASSO will not turn off

Post by Pattypickle »

Car started straight away today , no warning lights so I guess it’s a faulty wire somewhere (posting in case others have this issue). Obviously we will take to a garage now we can drive it.