Xantia - bosch pump not fueling injectors

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Xantia - bosch pump not fueling injectors

Post by Jaf »

Hi. I'm getting no fuel at all to the injectors. What I've read on here is that the pump very rarely does this! I've taken it off to have a look tomorrow at the stop solenoid.

Background... couple of months ago car cut out with dash lights and smoke. A coolant pipe exploded. Thought then there wasn't any fuel but as the HG had gone (hugely pressurised coolant), took head off. Cracked head. I have only just fitted second hand engine. Obviously changed fuel pump over because of the electrics. It's possible that I was wrong before about the fuelling but I did crank engine with loose injector pipe and had no fuel. Same as now. Bit of coincidence if head cracked and fuel pump went at the same time though.

I have checked the return pipe, and the leak off pipes. I haven't used clear fuel pipe to look for air but the primer bulb firms up easily. Fuel pump was new-old-stock a couple of years ago. I did get a fuel pump with the second hand engine so I can de-armour it. It would be the 4th pump for this car!!

What do you think?

Thanks!
aerodynamica
Donor 2021
Posts: 1093
Joined: 26 Dec 2007, 19:10
x 58

Re: Xantia - bosch pump not fueling injectors

Post by aerodynamica »

Have you tried taking the centre out of the stop solenoid just so see if that's the cause?
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Can I check on the best way to test the solenoid? I've wired the connection to the positive of a battery and then with another bit of wire touched it to earth of battery and solenoid. Getting a bit of a spark but no click. Tried it on old solenoid first, then pump but now tried it on 3rd pump. Nothing. No audible click and with 1 solenoid I can see the pin inside so there's no movement.

Must be doing something wrong!
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Er scratch that. Turns out I can't hear solenoid click and it you don't put the plastic pin in there's nothing to see. The pin does pop out to try and be lost though, watch out.

All my solenoids are working. Suppose check the wiring to check it's getting a voltage?
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Wiring to the solenoid has 1 permanent 12v feed and 1 switched through the ignition. Anyone know if that's correct?

Can I do a basic fuel pump test on the bench? I'm thinking of feeding diesel in, switching the solenoid on and turning the pump by hand. Would I be able to turn the pump fast enough?
Online
User avatar
myglaren
Forum Admin Team
Posts: 21148
Joined: 02 Mar 2008, 14:30
x 1951

Re: Xantia - bosch pump not fueling injectors

Post by myglaren »

Jim has a brilliant strip down and refurbish of a diesel pump, unfortunately the Lucas on so not applicable to yours.
One thing I do vividly recall is that he did not use diesel to test it, very dangerous it seems.
I think that he used LHM but can't be sure.

I will try and find it and link to it - there may be items useful to you.
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Thanks, I don't know why but I'm rubbish at searching on here. I get thousands of wrong searches instead of what I'm looking for.
Online
User avatar
myglaren
Forum Admin Team
Posts: 21148
Joined: 02 Mar 2008, 14:30
x 1951

Re: Xantia - bosch pump not fueling injectors

Post by myglaren »

It is detailed on Jim's site. In order not to attract spammers I will PM the address to you.
User avatar
KennyW
Donor 2022
Posts: 2267
Joined: 17 Jan 2006, 22:22
x 80

Re: Xantia - bosch pump not fueling injectors

Post by KennyW »

Use LHM fluid to test the pump, I did that on my old Xantia when I did a rebuild.

The fluid was sent quite a distance in my old garage at least 6 feet.

Kenny
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Finally got the car running again! Put the pump back on, turned the engine over to bleed the injector pipes. She was trying to catch so tightened pipes up and off she went! A bit of smoke but the second start up was great. That's all for a while, ordering new belts etc before running the secondhand engine.

(I did try to bench test the pump but I'm not sure I was turning it over fast enough, only dibbles came out. I put it back on just to see.)
User avatar
white exec
Moderating Team
Posts: 7489
Joined: 21 Dec 2015, 13:46
x 1467

Re: Xantia - bosch pump not fueling injectors

Post by white exec »

Result! Well done, Jaf.
User avatar
citroenguy
Donor 2021
Posts: 107
Joined: 21 Sep 2017, 18:05
x 30

Re: Xantia - bosch pump not fueling injectors

Post by citroenguy »

Lovely that you got the Xantia going again!

When i took out my pump for refurb i was warned that it must be replaced in the same position (oval holes).
Otherwise you need to set the pump timing.
Kind of hard with a second hand engine
Jaf
Posts: 473
Joined: 09 Dec 2010, 20:17
x 18

Re: Xantia - bosch pump not fueling injectors

Post by Jaf »

Thanks Chris.

Citroenguy, you're right of course. But I've found that marking the pump and engine works. Just transfer the marks to the new pump or engine. Good enough to get the engine running, then adjust by ear.