Renault Scenic 3 no engine ECU

This is the Forum for all your Renault Technical Questions, Problems or Advice.

Moderator: RichardW

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Renault Scenic 3 no engine ECU

Post by Daz3nt »

Hi all, Long time since I've been on here, Long story short, A bus went into the back of me (not loads of damage) I drove away from the accident without any issues. My car went into the body repair shop where it sat for nearly 2 months because of the coronavirus thing. The battery was flat and the garage tried to jump start it but failed to start. I've plugged a computer in and theres no communication with the engine ECU. I bought an ECU kit which included Engine ECU, Engine compartment Fuse box, UCH (body control module), card reader and steering lock.

I changed all these and it still failed to start, it don't even crank. I plugged the computer back in and still fails to communicate with the engine ecu (or injection) as it says on the computer. I'm also getting error DF048 PROTECTION CODE BETWEEN UCH AND EPS. I've checked all the fuses in the engine bay and none are blown.

The car is a Renault Scenic 3 - 2011 with a 1.5 DCI 110hp engine. Hope someone can help me.

Darren.

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

Managed to fix it. There's a relay soldered to the board of the engine compartment fuse box, there's 12v going to the relay, relay is switching on and off as normal but only outputting between 1v - 4v. So when the relay closes it doesn't make a good connection. I have 2 options, option 1 - wire an external relay as pictured this way the internal relay wouldn't be doing anything and the external relay will work exactly the same as the internal (faulty relay). Option 2 - set up an Arduino to turn the relay on and off say 10 times a second without a load on the contacts for half hour and maybe opening and closing will clean the contacts. I suspect since it's been standing for 2 months the contact on the relay might have corroded. I think I'm going to try switching the relay on and off constantly for half hour first and see if that will fix it and with daily use it shouldn't happen again but if it does then go to option 2.
Attachments
Screenshot_20200522_052343_com.android.gallery3d.jpg

James1966
Posts: 4
Joined: 25 Mar 2021, 13:19

Re: Renault Scenic 3 no engine ECU

Post by James1966 »

Hi I wonder could you advise me,,I seem to have a similar problem as you had,,,Iva a grand scenic 1.5 dci 2011,,,the car opens and locks fine with the card key I then insert the key into the reader the dash lights up and the steering unlocks however the spanner light stays on and when I push the start button I just hear a click from the blue relay located in the glove box fuse board,I’ve also noticed there is no glow plug light and no engine warning light on the dash,,this fault has been intermittent until recently and now it is permanent,,plugged it into a Autel maxi check and the fault codes are DF062 injection multiplexed information missing and DF067 injection multiplexed emission missing also DF160 steering column lock protection thermal protection,,,before the fault became permanent sometimes the car would start as normal with no issues and drove like new and sometimes it wouldn’t but if I left it overnight or even just a few hours it would start as normal,,,a real head scratcher lol,,I ordered a ecu kit which included ECU,UCH,steering lock and card key I installed these to avail just getting the same fault as above however I never received a under bonnet fuse board I’m not sure if these are coded to the car,your idea of repairing yours with an external relay or indeed jumping the relay to clean the contracts seems a great idea which I’m tempted to try either as I’ve tried everything else,I’d appreciate any advice on how you found your fault and is the under bonnet fuse board coded to my car or anything else that might help me get to the bottom of my fault,,,,many thanks in advance

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

Sounds exactly like the same problem I had with mine. Turned out there was a broken wire between the ecu and engine. I stripped the loom and saw the classic white powdery oxidation on one wire. Pulled the wire and it snapped without any force. I ended up cutting the wire on the ecu side and the other end of the loom and soldered a new cable in between. Touch wood it's been fine ever since. 🙏🌲

I'm no mechanic but being a computer engineer who specialises in component level repairs, it wasn't to much of an issue.

James1966
Posts: 4
Joined: 25 Mar 2021, 13:19

Re: Renault Scenic 3 no engine ECU

Post by James1966 »

Hi Daz3nt thanks so much for your reply,,,could you maybe point me in the right direction regarding which part of the loom you found the broken wire ,,, I kinda suspected it could be a broken wire but where to start lol,,,many thanks

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

ImageQuickly doodled this on my phone but should give you a good idea where my problem was.
Attachments
IMG_20210325_185340.jpg
IMG_20210325_185340.jpg (30.46 KiB) Viewed 129 times

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

Red line being roughly where the loom was.

Darren.

James1966
Posts: 4
Joined: 25 Mar 2021, 13:19

Re: Renault Scenic 3 no engine ECU

Post by James1966 »

Once again thanks so much Darren I’m gonna take your advice and strip that part of the loom hopefully the problem lurks there,,,I’ll up date the form when I’ve carried this out,,,many thanks Jim

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

Good luck. I'll keep my fingers crossed.

James1966
Posts: 4
Joined: 25 Mar 2021, 13:19

Re: Renault Scenic 3 no engine ECU

Post by James1966 »

Hi Darren I just want to thank you for the time you took to advise me regarding my problem with my scenic 1.5 dci 2011,,,you were absolutely right pointing me in the direction of the front loom,, I stripped back the loom and there was indeed a broken wire I repaired it and the car is now fixed thank you so much,,,I hope this post will help others with a similar problem,,,,

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

That's great, glad could I help.

Dary
Posts: 3
Joined: 02 May 2021, 00:37

Re: Renault Scenic 3 no engine ECU

Post by Dary »

Hi. I have same problem with my Vivaro 2012 2.0 cdti, I buy another ecu kit from a 2012 2.0 Cdti replaced . But I still have No ecu connection. The van was on garage for one month and 2 weeks, I paid 300 pounds without them repair it, they said they checked All fuses are good, relay, wires too. But on mine I have error code DF067 injection multiplexed emission missing

Daz3nt
Posts: 34
Joined: 03 Dec 2012, 19:46
x 1

Re: Renault Scenic 3 no engine ECU

Post by Daz3nt »

does it look like the wiring loom have been stripped? anything like the garages around me, they probably didn't check for broken wires.

Dary
Posts: 3
Joined: 02 May 2021, 00:37

Re: Renault Scenic 3 no engine ECU

Post by Dary »

Hi. They said, they stripped and can't find anything. I have replaced the ecu kit for another one from 2012 2.0 vivaro. And still same.