C4 2006 1.6hdi starting issue runs 30 sec's and stops.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Rochy101
Posts: 62
Joined: 09 Feb 2014, 19:29

C4 2006 1.6hdi starting issue runs 30 sec's and stops.

Post by Rochy101 »

Morning fellow Citroen owners.
For the last few weeks These issues have problemed me with the car and doing my nut in.
1 The car was struggling on the road like it was being starved of fuel, Changed fuel filter went ok for two days
2 removed the Egr valve cleaned the chrome hose out as was clogged and all went well .
3 starting the car in the morning runs for 30 seconds and cuts out and then 1-2 mins to restart. Chuggs out smoke and all good for the rest of the day if you leave it more than 4 hrs same issue. I have changed all the fuel pipes too to the injectors and fuel filter too and was wondering could it be the " Fuel filter heater" . Please help wife nagging .
Currently driving
2005 C5 Estate 1.6hdi aka "Duggy" rhd
2006 C5 Estate 1.6hdi aka "Cissy" rhd
1990 Ax 1.1 aka "Baggy" Lhd
Peter.N.
Moderating Team
Posts: 11536
Joined: 02 Apr 2005, 16:11
x 1191

Re: C4 2006 1.6hdi starting issue runs 30 sec's and stops.

Post by Peter.N. »

The fuel heater used to fail on the XUD engine but I didn't know the 1.6 had one. Certainly sounds like air in the fuel supply. Does this one have a pump in the tank or does the pump on the engine draw it up? I would imagine the latter. You could install a section of clear pipe between the filter and HP pump so you can observe any bubbles, ot you could fit a hand primer.

Peter
picassodad
Posts: 251
Joined: 04 Oct 2018, 14:26
x 14

Re: C4 2006 1.6hdi starting issue runs 30 sec's and stops.

Post by picassodad »

If its a pump in the tank, does that stop working?? it also has a filter and "trap door" but should be quite easy to remove from the tank, unlike a picasso!!

so pump in tank? brown double relay??
Rochy101
Posts: 62
Joined: 09 Feb 2014, 19:29

Re: C4 2006 1.6hdi starting issue runs 30 sec's and stops.

Post by Rochy101 »

Peter.N. wrote: 16 Feb 2019, 11:15 The fuel heater used to fail on the XUD engine but I didn't know the 1.6 had one. Certainly sounds like air in the fuel supply. Does this one have a pump in the tank or does the pump on the engine draw it up? I would imagine the latter. You could install a section of clear pipe between the filter and HP pump so you can observe any bubbles, ot you could fit a hand primer.

Peter

Hi Peter, Thanks for the reply . I have changed the fuel line to the injectors and fuel filter engine side. It seems to me that the air is entering of something failing . If i hand pump the fuel first ting in the morning there is no issue , so I imaging when it sits its drawing air which is returning back . It starts as it has enough in the injectors to start then drops off as insufficient fuel as its returned or air blocked.
Currently driving
2005 C5 Estate 1.6hdi aka "Duggy" rhd
2006 C5 Estate 1.6hdi aka "Cissy" rhd
1990 Ax 1.1 aka "Baggy" Lhd
Peter.N.
Moderating Team
Posts: 11536
Joined: 02 Apr 2005, 16:11
x 1191

Re: C4 2006 1.6hdi starting issue runs 30 sec's and stops.

Post by Peter.N. »

The fuel filter is often the source of a leak, I see you have changed the filter, I would suggest removing it and checking cleaning the sealing ring.

Peter