Citrojim's Saxo and Cycling Tales

Tell us your ongoing tales and experiences with your French car here. Post pictures of your car here as well.

Moderators: RichardW, myglaren

citroenxm
Posts: 7827
Joined: 31 Dec 2004, 00:10
x 28

Post by citroenxm »

Yes Jim, the 1.25 engine was Mazdas... the rest Frauds..

Oh, and DO NOT under estimate the Mazda MPS models... as it implies. Mazda Performance Saloon. I think the 6 was first, and shes a 250bhp machine!!

See entry above RE: Latest DERVs fitted.. :lol: :wink:

Paul
Last edited by citroenxm on 24 Apr 2011, 21:09, edited 1 time in total.

Deanxm
Posts: 3322
Joined: 18 Dec 2008, 18:57
x 41

Post by Deanxm »

ford allowed them to make a car that was by pure coincidence .2 seconds slower 0-60 than the Focus RS (i know what a coincidence) but 10k+ cheaper.

Considering how plastic the RS is thats damn good!

D

User avatar
CitroJim
A very naughty boy
Posts: 41632
Joined: 30 Apr 2005, 23:33
x 1079

Post by CitroJim »

citroenxm wrote:The Square 121,
Seen them, I know of at least one that was imported into the UK. There were two variants as far as I recall and one looked very, very similar to the MKIII Fiesta... It really was almost a clone...

Right down to how they rusted :lol: :lol:

citroenxm
Posts: 7827
Joined: 31 Dec 2004, 00:10
x 28

Post by citroenxm »

Ah well, when the 1.25 engine came to Fraud, the Fiesta DID have the Mazda 121 CLONE badge, but we were into late 1990's then.. I missed that one :oops: LOL..

Heres the Fiesta 121...

Heres the Kia Pride, mazda 121, Ford Fiesteva version..

Paul

XantiaMan
Posts: 1603
Joined: 12 Aug 2007, 18:47
x 11

Post by XantiaMan »

citroenxm wrote:Yes Jim, the 1.25 engine was Mazdas... the rest Frauds..

Oh, and DO NOT under estimate the Mazda MPS models... as it implies. Mazda Performance Saloon. I think the 6 was first, and shes a 250bhp machine!!


Paul
I remember when this engine came out - It was a Ford engine developed by Yamaha, there was much song and dance about it at the time, there was a 1.4 and 1.6 variant as well as the 1.7 in the Puma.

Suppose its a bit like people assuming the 3 litre V6 in the Mondeo engine, its not, its a Ford USA lump.

citroenxm
Posts: 7827
Joined: 31 Dec 2004, 00:10
x 28

Post by citroenxm »

Makes me laugh.. With a fraud u dont know whos engine u got.. The galaxy v6 is vw engine. The probe v6 is mazdas engine. And yes the mundaenios v6 is yet another one from the usa....

At least with citroen u know you have a 100% french car and not bits n bobs borrowed from all over the bloody place...

Paul

XantiaMan
Posts: 1603
Joined: 12 Aug 2007, 18:47
x 11

Post by XantiaMan »

citroenxm wrote:Makes me laugh.. With a fraud u dont know whos engine u got.. The galaxy v6 is vw engine. The probe v6 is mazdas engine. And yes the mundaenios v6 is yet another one from the usa....

At least with Citroën u know you have a 100% french car and not bits n bobs borrowed from all over the bloody place...

Paul
Nothing wrong with the practice of engine sharing, it saves money, i'm sure Ford are more profitable than PSA..

citroenxm
Posts: 7827
Joined: 31 Dec 2004, 00:10
x 28

Post by citroenxm »

i only said it makes me laugh... but of course not... the engine is the most costly part to develop with these modern emmision rules.....so why do it if you can aviod it..

im sure ford is more profitable but then it is 3 times a bigger company..
Last edited by citroenxm on 25 Apr 2011, 08:05, edited 1 time in total.

User avatar
CitroJim
A very naughty boy
Posts: 41632
Joined: 30 Apr 2005, 23:33
x 1079

Post by CitroJim »

XantiaMan wrote:its a Ford USA lump.
So it's made of all cast iron and has pushrod operated overhead valves then :wink: :lol:

Goes well, all things considered...

XantiaMan
Posts: 1603
Joined: 12 Aug 2007, 18:47
x 11

Post by XantiaMan »

CitroJim wrote:
XantiaMan wrote:its a Ford USA lump.
So it's made of all cast iron and has pushrod operated overhead valves then :wink: :lol:

Goes well, all things considered...
Come on Jim :roll: Its an all aluminium 60° V6, still used today in the Jag XF.

citroenxm
Posts: 7827
Joined: 31 Dec 2004, 00:10
x 28

Post by citroenxm »

Wow...a modern yank engine... I thought too they still used push rods in usa and hadnt moved to ohc.... :lol: :lol: :lol: :lol: :lol:

Deanxm
Posts: 3322
Joined: 18 Dec 2008, 18:57
x 41

Post by Deanxm »

Certain states over there have far more stringent anti pol regs than we do, OBD1 and 2 came from america as did the twin cat/O2 idea of emmissions control self diagnostics, Rover V8 was..................unfortunatly :lol:

The thing that gets me about Ford was the whole Volvo incident where Fords euro chief openly rediculed Volvo for saying it was going to develope a whole new performance engine from the ground up in 3 years.....................which they did, which was miles better than anything Ford themselfs had developed to date, in nearer 2, and then ford pinched it to make the ST and RS tick :roll:
The car is 50% Engine, make your own! :twisted:

And that is why i would buy a T5 over a ST..................(Dean sulks off :lol: )


D

User avatar
myglaren
Forum Admin Team
Posts: 17556
Joined: 02 Mar 2008, 14:30
x 846

Post by myglaren »

Volvo also said that they would never again be able to afford to develop a new engine and were right - unfortunately.

User avatar
CitroJim
A very naughty boy
Posts: 41632
Joined: 30 Apr 2005, 23:33
x 1079

Post by CitroJim »

Terrible day on Monday :cry: Sid the Squid and his dad came to see me about swapping the EPIC pump on his dad's 2.1TD (my old estate). Diagnostics showed the pump was at fault with a problem of faulty timing due to the pump not being able to respond properly to ECU timing commands. Sid had located a replacement pump and we set about swapping it.

What a job! The EPIC lower flange nut is inaccessible by all normal standards and I hoped to gain access by removing the HP pump and alternator but although I could get the crescent spanner on the nut i could not swing it without hitting the pump cradle. I then though about removing the alternator and HP pump cradle casting but hit a snag in that the Allen bolts holding the cradle to the engine block were seized solid. I could feel one about to "go" and called a halt. I was in terrible danger of shearing one or more of these bolts and played safe. Sadly and regrettably, the job had to be abandoned :cry:

That was a very sad and devastating "first" for me; the first time I've ever had to abandon a job because I ran out of talent/facilities/tools to complete the job. Sid and Steve, I'm very sorry :oops: :cry:

Yesterday evening the lad down the end of the street called me. He'd just got hold of a very tidy 1991 Honda Civic, the sporty one with the 1.6 DOHC engine.

As he does, he was busy replacing the cam covers with highly polished examples and in doing so he dropped a nut into the depths of the cambelt. He had the sense to realise this might have fatal results if he ignored the lost nut and started up the engine. He'd tried to remove the cam covers to rescue the nut but was stumped. I went over and helped him by undoing the crank pulley (very tight) and removing all the covers. The nut was nowhere to be seen initially and then we found it resting, well hidden, in a valley in the engine mount. A flick and it fall out. Had he ignored it, it's almost certain it would, sooner or later, have got involved in the cambelt and caused considerable harm.

I've been fixing a blower speed controller module today and had another that was in very rough condition. It had been very wet. In playing with this module, I made two very interesting discoveries; the transistors can go open-circuit as well as going short-circuit as is their normal way of failure. If both go open circuit, as they had on this module, there is no blower at all. I'm now of the opinion, after doing more tests, that one transistor goes open-circuit and this causes the other to take all the blower current which overloads it and causes it to fail short-circuit and give rise to the uncontrollable blower fault.

I tried repairing this really rough module with some second-hand but good transistors I'd saved from many previous repairs. The two I chose were not a matched pair and although the module then worked it was quickly obvious that one transistor was working far harder than the other as evidenced by one being relatively cooler than the other. So, if you try repairing these modules be sure to replace both transistors with a matched pair. Match them by comparing batch numbers on them.

User avatar
CitroJim
A very naughty boy
Posts: 41632
Joined: 30 Apr 2005, 23:33
x 1079

Post by CitroJim »

It must be something to do with Mondays :roll:

Following a great day out at Spalding on Sunday, I planned yesterday to give Old V6 a check-over and service prior to her MOT later this month...

The service went OK but in checking I noted the HP pump was a bit weepy and making the alternator damp with LHM. Knowing that LHM and alternators don't mix I removed the pump and replaced all it's O rings. It appeared to have been weeping from the 6 piston PAS secton and removing the caps to replace the seals was a challange. Those caps are seriously tight.

I also removed the alternator so I could give it a good clean up.

It's an interesting job removing an alternator from a V6. I always wondered why it was relatively easy to remove the A/C Compressor. Now I knowe, it neds to be driopped out of the way to give the alternator sufficient space to be eased out.

In fact HP pump, alternator and A/C compressor removal is straightforward enough even if some of it is done by feel. A universal joint on a long socket extension is essdential for alterbnator removal...

MOT checks reveraled a couple of reasonably perished flexi-hoses to the front calipers. These have been replaced with the usual fight with the rigid pipe to flexi unions..

The old flexis were dated 05/97 so they were originals. Not bad...

I did not quite finish last evening to to the time and descending darkeness. This afternoon it should just be a matter of popping it all back together..