Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Ryan9153
Posts: 26
Joined: 13 Mar 2024, 21:07
x 1

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by Ryan9153 »

Making some headway think I have a couple of issues, but the first one to address now is voltage to the engine ecu, I have 8.2volts at the engine ecu, so time to get out the circuit diagrams and multimeter, the high pressure regulator when connected to a test light is glowing very very dimly. Will keep updating until I get to the bottom of this even if it’s a give up goodnight Vienna scenario.
Ryan9153
Posts: 26
Joined: 13 Mar 2024, 21:07
x 1

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by Ryan9153 »

Had fuse box under bonnet out found lots of water ingress and def some poor connections because as I cleaned up fuses etc things were energising and deenergising, so need to see if I’ve got poor relays etc due to water ingress but the van did nearly start on its own last night without starter pilot
Ryan9153
Posts: 26
Joined: 13 Mar 2024, 21:07
x 1

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by Ryan9153 »

Totally cleaned fuse box connectors, fuses and relays, sorted fuel pressure regulator continuously clicking and no more fuel cut off and immobiliser warning, so back to the original none start fault yay.
Ryan9153
Posts: 26
Joined: 13 Mar 2024, 21:07
x 1

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by Ryan9153 »

Checked for fuel coming out of the high pressure pipe and there is now, so I think the fault is the injectors are not opening up for whatever reason, BSI or engine ecu fault? More to look in to.
Ryan9153
Posts: 26
Joined: 13 Mar 2024, 21:07
x 1

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by Ryan9153 »

Hey guys good news at last sorry for delay only just got to looking at it again. Was sent a TSB from a Legend of a guy about the wiring on the loom to the engine ecu rubbing through, sure enough opened up the loom as described in the TSB found 5 rubbed through and broken wires. Repaired those, you have to remove the loom to get good access. But once repaired those 5 wires and put loom back fired and ran like a new car. So happy yippie kiy ey. 👍
PaulC5
Donor 2024
Posts: 355
Joined: 06 Jun 2023, 15:26
x 93

Re: Citroen Nemo 1.4hdi 2010 turns over but doesn’t start

Post by PaulC5 »

It is always nice to read good news, well done.