Weird noise and power loss after work done on my 1.6 hdi

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
MattBLancs
Donor 2024
Posts: 2810
Joined: 25 Apr 2022, 09:03
x 1496

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by MattBLancs »

Turbo won't really mind having unfiltered air (unless it manages to suck up something solid obviously) but outlet from air filter housing contains the mass air flow sensor - which will likely trigger a code if engine run with it unplugged (or plugged in but airflow not fed through it)

It's a real pain to access on the DV6, well buried.


Never worked on a Renault other than a Clio with failed wiper linkage= metal so soft it had just bent out the way!
I'm not too sure French cars are any better or worse than anything else** when a Bosch sensor fails in a German car, folks seem willing to shrug and say "well they do fail eventually" same Bosch made sensor on a French car seems to trigger "it's them bloody French electrics, always going wrong!"

** C5 X7 steering racks excepted, they are just unfathomably poor quality!
gaspaccio
Posts: 22
Joined: 27 Apr 2023, 21:44

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by gaspaccio »

Thanks MattBLancs. Yes all nowadays cars have their problems. Plus with planned obsolescence we are all in the same boat with these car makers.
Well noted, I guess I should put everything back in place before starting the engine then.
gaspaccio
Posts: 22
Joined: 27 Apr 2023, 21:44

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by gaspaccio »

I have another question if you don't mind. I think I put back the injectors at their original place, but I still have a doubt...
Is it possible to program them with diagbox so it kinda reset everything, just in case they were not in the right order?
User avatar
MattBLancs
Donor 2024
Posts: 2810
Joined: 25 Apr 2022, 09:03
x 1496

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by MattBLancs »

gaspaccio wrote: 29 Apr 2023, 23:18 I have another question if you don't mind. I think I put back the injectors at their original place, but I still have a doubt...
Is it possible to program them with diagbox so it kinda reset everything, just in case they were not in the right order?
Sorry, I don't know, am no expert with Diagbox, just fumble about really!!

Am sure someone else will know
User avatar
Paul-R
Donor 2023
Posts: 7082
Joined: 07 May 2009, 16:24
x 1403

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by Paul-R »

I don't know in your case for sure but, based on my experience with our 1.6 BlueHdi, I strongly suspect yes, they are coded in. I think that you have to interrogate the Engine ECU to find the codes. In my case the case the code is written on the top of the (Bosch) injectors and, wherever it is, you can compare them with what's written into the ECU.

Yes, you can change codes around to suit the position of the injector and don't forget that No1 cylinder is at the gearbox end.
As I get older I think a lot about the hereafter - I go into a room and then wonder what I'm here after.

Inside every old person is a young person wondering what the hell happened.

"Trying is the first step towards failure" ~ Homer J Simpson​
gaspaccio
Posts: 22
Joined: 27 Apr 2023, 21:44

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by gaspaccio »

I've checked with diagbox there is a section where you can see the injector's ref and the cylinder number they are on. I inverted 2 injectors... My bad. Anyway I put them back in the right order but I still have the same rattling noise.
I also did the test for the injectors' leak return (sorry if this is not the right translation). Here is a pic of my result, I don't think the difference between them is very important and could cause the problem. They seem ok-ish.
I will remove the EGR blanking plate now and see.
Image
ImNoExpert
Donor 2023
Posts: 106
Joined: 04 Aug 2022, 09:24
x 1

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by ImNoExpert »

Considering the work you have done I suspect Injector issue. Looking forward to hearing how you fixed it. I keep messing things up with my own vehicles; fix one problem create another and go round in circles for months. :D
gaspaccio
Posts: 22
Joined: 27 Apr 2023, 21:44

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by gaspaccio »

I removed the egr blanking plate, the noise is still there as before.
Here is a recording of the noise it seems there is not only a rattling?
https://voca.ro/1excxa17HSFp
User avatar
Paul-R
Donor 2023
Posts: 7082
Joined: 07 May 2009, 16:24
x 1403

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by Paul-R »

I think I can hear a chuffing noise in the background which might be an injector not sealing properly or an exhaust manifold leak. The foreground noise is quite loud and maybe it's a tensioner on the auxiliary belt on its way out. The simple way to test for that is to temporarily remove the auxiliary belt and see what changes.
As I get older I think a lot about the hereafter - I go into a room and then wonder what I'm here after.

Inside every old person is a young person wondering what the hell happened.

"Trying is the first step towards failure" ~ Homer J Simpson​
gaspaccio
Posts: 22
Joined: 27 Apr 2023, 21:44

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by gaspaccio »

Paul-R thanks for your help. Yes there is a chuffing noise on the background, I would have a leak if an injector was not correctly sealed? I have no leak that's strange. And I didnt touch the exhaust manifold that's even stranger :)
I will try what you told me about the aux belt, let me first see how to do this...
This stuff is p*ssing me off, I just wanted to clean my engine at the first place so it can breathe better and I got these problems, jeeezzzz if only I didnt touch it.
manyk
(Donor 2021)
Posts: 1
Joined: 31 Aug 2021, 15:16

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by manyk »

@gaspaccio have you solved the chaffing noise?
User avatar
Doo
(Donor 2022)
Posts: 461
Joined: 09 Sep 2019, 16:53
x 116

Re: Weird noise and power loss after work done on my 1.6 hdi

Post by Doo »

I had a good listen and I could swear the chuffing is the crank pulley as they are a known weak point on most dual mass wheels... The rattle can combine with a sort of chuffing as the rubber between the metals wears, sometimes unevenly. It would also account for a metallic clatter. However, with the mass move to plastic coated bearings, there is a possibility that any roller or tensioner pullet could be at fault!
Has anyone seen the plot? :?