Heating not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Dormouse
Donor 2021
Posts: 210
Joined: 15 Apr 2021, 14:32
x 43

Re: Heating not working

Post by Dormouse »

Remember to flush out the radiator and header tank as much as you can. Ideally off the car but as thoroughly as possible. If reaching for the heater hoses is difficult then I would use an infrared spot temperature gun - like the airport temperature readings for covid shown on the telly. These are very localised and accurate. I bought mine to thermal map our house to plan insulation but I have used it on radiators and water pipes. They read the surface temperature of the spot they are aimed at and are not influenced by air temp or other sources of heat
Attachments
1620026464747.jpg
1620026464750.jpg

Dormouse
Donor 2021
Posts: 210
Joined: 15 Apr 2021, 14:32
x 43

Re: Heating not working

Post by Dormouse »

I am partly mindful that others may read this for future use so apologies if some things sound a bit detached from your immediate problems.

DanCD
Donor 2021
Posts: 15
Joined: 15 Dec 2019, 15:15

Re: Heating not working

Post by DanCD »

GiveMeABreak wrote:
02 May 2021, 20:05
DanCD wrote:
02 May 2021, 17:00
Hi,

Could anyone give me the part number for the heater matrix of my car? CITROËN C4 II Hatchback 1.6 VTi 120, 2011 reg.

Cheers,
Dan
Hi Dan

Part for the Heater Matrix on your C4 is 6448W8. Item (1). It is priced today at £226.21 inc. VAT from Citroen and includes all the items highlighted.

Image
Thanks!

DanCD
Donor 2021
Posts: 15
Joined: 15 Dec 2019, 15:15

Re: Heating not working

Post by DanCD »

Dormouse wrote:
03 May 2021, 08:33
I am partly mindful that others may read this for future use so apologies if some things sound a bit detached from your immediate problems.
No worries, it's good to get decent advice.

I've been out to have a look again this morning, and took a look at the heater matrix itself. Both pipes to the heater matrix are stone cold even after leaving the car running for a while. Does this point to something else being the issue?

Dormouse
Donor 2021
Posts: 210
Joined: 15 Apr 2021, 14:32
x 43

Re: Heating not working

Post by Dormouse »

yes. The heater hot feed will come initially from the Thermostat area. Now, I don't have enough experience with the heater plumbing on these models but you should be able to track the hot inlet pipe from the engine to the heater, or at least the bulkhead, and feel the heat build up in the pipes. Now, disconnect the return pipe and leave off. Start the engine for a short spell. If the matrix is fully blocked, there will be no flow. If it is restricted, the flow will obviously be low. Next, reconnect the return pipe and disconnect the feed pipe at the bulkhead. Start the engine for a brief spell. There should be obvious full flow or else the restriction is between the engine/thermostat and the heater matrix. IF YOU THINK WATER WILL GET OVER IMPORTANT ELECTRICS/ELECTRONICS extend the open hose end with a piece of hose long enough to clear the engine bay.

Dormouse
Donor 2021
Posts: 210
Joined: 15 Apr 2021, 14:32
x 43

Re: Heating not working

Post by Dormouse »

During and after this, top up the coolant level and carry out any bleeding procedures. If your were able to get a flow through the heater matrix with a hose then the engine should be able to pump coolant through the matrix and deliver some hot water from the engine. If the pipes are not heating up there is no flow. I don't have enough knowledge of this model to say what the heater circuit consists of and what may be upstream from the matrix in and around the thermostat and coolant circuit.