Forum scheduled maintenance 17/07/2020 - 31/07/2020 - Completed

Forum News, Announcements and any issues you're having with the forum

Moderator: myglaren

User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I believe that I have fixed the image quoting issue. It was a very subtle coding error, which has been there for a while, but only exposed by another change that I made recently.
User avatar
myglaren
Forum Admin Team
Posts: 20425
Joined: 02 Mar 2008, 14:30
x 1718

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by myglaren »

I did notice it a week or so ago but presumed it was deliberate and to save bandwidth. Some forums do this intentionally.
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

With the help of browser caching, a quoted image doesn't add any server load or bandwidth, but you do have to have the correct URL :roll:

Image links are handled in several different ways, depending on where they are hosted, whether we have a local copy of the image and whether the link is http:// or https://. The problem was just that one of the tests for how to treat the image link was subtly wrong, causing an invalid link to be generated for local attached images which were quoted.
User avatar
bobins
Donor 2021
Posts: 4169
Joined: 05 Jul 2012, 18:07
x 1337

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

Whatever witchcraft you practice to keep the forum functioning, please keep on doing it. It's much appreciated :)
User avatar
bobins
Donor 2021
Posts: 4169
Joined: 05 Jul 2012, 18:07
x 1337

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

I've noticed a change in behaviour of PM's today. I get an email notification including PM content to my email address, but it doesn't flag under 'Private Messages' on the forum page, nor is the PM (or content) shown in my Inbox on the forum.
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

bobins wrote:
25 Jul 2020, 13:02
I've noticed a change in behaviour of PM's today. I get an email notification including PM content to my email address, but it doesn't flag under 'Private Messages' on the forum page, nor is the PM (or content) shown in my Inbox on the forum.
Are you saying that the PM does not exist at all on the forum? Maybe someone sent you a PM and then deleted it before you looked, although in that case, there should be a notice in your PM inbox about a deleted PM.

Can you forward one of the emails to admins@frenchcarforum.co.uk?
User avatar
bobins
Donor 2021
Posts: 4169
Joined: 05 Jul 2012, 18:07
x 1337

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

Yes. There's no trace on the PM on the forum in my 'Private Messages' section.
My previous experiences of how it works is that I get an email notification to my own email address, and the PM would exist in the PM section of the forum. What has happened today is that I've got an email to my own email address from 'FCF Admin Team' that includes the full content of the PM, but absolutely no notification on the forum software (i.e. no flag under PMs), and no PM in my Inbox on the forum.
I've forwarded the email to you as requested.
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I have emailed you a more detailed reply, but the relevant information is:

The email that you forwarded was not a PM notification, as they always have the subject "New private message has arrived" and the contents starts with
Hello XXXX,

You have received a new private message from "ZZZZ" to your account
on "The French Car Forum" with the following subject:
It was an email sent via the forum (the sender does not get access to your email address). The option to do this is next to the PM button when you click a user contact link on a forum page.

So in this case there appears to be no problem with the forum.
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

Someone has asked whether it is possible to stop people sending me emails via the forum.

The answer is yes, there is a setting on your user profile page: ucp.php?i=174
User avatar
bobins
Donor 2021
Posts: 4169
Joined: 05 Jul 2012, 18:07
x 1337

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

The 'Login' issues have returned for me this morning. 'Index' and each section show me as logged out, but individual threads show me as logged in.
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

Are you still seeing this behaviour? I looked in the logs and it looked as if a change I made earlier had not taken effect, but it seems (as far as I can see here) to have fixed itself.
User avatar
bobins
Donor 2021
Posts: 4169
Joined: 05 Jul 2012, 18:07
x 1337

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

I was on W10 / Firefox earlier when I reported it, I'm now on Android / Chrome and it seems fine, so it looks likely all is good now.
User avatar
NewcastleFalcon
Posts: 17250
Joined: 25 Feb 2009, 11:40
x 1876

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

Yesterday from time to time later on the navigation bit through clicking on page numbers would always return page 1.

I had to try quite a few times to read Simon's new post on the electric vehicles spotting thread because clicking on any of the usual methods to read it always returned to page 1 of the thread. Being logged out just viewing, I tried logging in, and couldnt be sure, but when I was logged in functionality of normal page navigation returned can't remember if it was immediate or after a few tries.

This is the post here.....its in the normal public-viewable part of the forum in the Off-topic Lounge as opposed to being in the logged-in only viewing of Blogs and galleries etc. Don't think the problem was unique to that thread.

viewtopic.php?p=652192#p652192

REgards Neil
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I have updated a few settings today which would have affected logged-out users, let me know if you see any issues from now .
User avatar
NewcastleFalcon
Posts: 17250
Joined: 25 Feb 2009, 11:40
x 1876

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

Thanks, so far so good I'll let you know if that little anomaly returns

Regards Neil