C5 2.0HDI Power steering faulty!

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

JamesHDI
Posts: 8
Joined: 29 Jun 2020, 21:00
x 2

Re: C5 2.0HDI Power steering faulty!

Post by JamesHDI »

I got some more LDS fluid today and topped up the level,I checked terminals 1and 2 on the main connector and I have permanent 12volts at the pump.
Does anyone know if these pumps are prone to failure? When I lost the power steering,it was intermittent and then finally failed so not sure if its the pump or some other associated component.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21550
Joined: 15 Sep 2015, 19:38
x 2159

Re: C5 2.0HDI Power steering faulty!

Post by GiveMeABreak »

You really need to get Diagbox on it to where the fault is. There is no known fault / problem I'm aware of regarding the electric power steering pumps on these. The Suspension pumps, yes, - they can become contaminated as spilled LDS fluid can run down and get into the pump casing and then start mixing with the carbon dust and cause them to short or burn out. But no issues with the electric power steering pump.

Getting the system diagnosed may give you some clues.

triumphtoledo
Posts: 128
Joined: 28 Apr 2006, 10:46
x 2

Re: C5 2.0HDI Power steering faulty!

Post by triumphtoledo »

On my C5, this has happened immediately following a cold start - I had the warning message and no PAS. I used to leave the engine running for 5 minutes, switch it off and then on again, PAS was restored. It was the battery.

I suggest you look at measuring your battery's State of Charge (volts) and State of Health (Amps) and see if it is kaput.

R

Robert Waller
Posts: 1
Joined: 25 Jul 2020, 13:46
x 1

Re: C5 2.0HDI Power steering faulty!

Post by Robert Waller »

Everytime my c5 had a power steering issue "twice in fact "it was a battery failure as the power steering is one of the first things to be sacrificed in the event of power loss the simplest of fixes a new battery was all that was needed what a relief!!

JamesHDI
Posts: 8
Joined: 29 Jun 2020, 21:00
x 2

Re: C5 2.0HDI Power steering faulty!

Post by JamesHDI »

At last!I've finally managed to fix the problem! Through trial and error it's finally working again.
Since I last posted I bought a Mk1 C5 2.2HDI saloon and the estate sat forlorn for a few months until I decided to have another go.
I bought a used replacement pump from ebay ,swapped it over but still the same,no power steering so that ruled out the pump being faulty.

After swapping the pumps made no difference,I paid more attention to the wiring from the pump sockets and noticed that the black wiring loom tape had unravelled about 3 inches from the pump socket which contained three very thin wires(not the two larger high current wires that power the pump).
The three wires were one red,one white and a green one.
I checked the wires by looking more closely, pulling them and dusting them off when the green wire just broke in my hands!
It appears to me that the copper core of the green wire broke/corroded inside the insulation but from the outside the wire appeared fine until I pulled it slightly and insulation just broke in two.
I quickly stripped each end of the green wires,put in a connector block and Woohoo! Power steering again!
I'd just like to say thanks to everyone on here for helping me with this and apologise for not getting back to the thread sooner with a conclusion,but now that I am running two C5s I may have some more questions.