berlingo van in eco mode

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

last throw of the dice. Thanks for all your help and comments.

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

I have now carried out the electrical tests and the results are as follows.
I set the multimeter upon the instructed setting and this was the reading before i started the continuity test
Attachments
20200421_142135.jpg

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

This is the reading with pins connected between the BSI and engine fusebox
Attachments
20200421_140916.jpg

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

The short to earth and short to + did not alter the original reading
Attachments
20200421_142135.jpg

wheeler
Posts: 4296
Joined: 21 Sep 2002, 19:07
x 152

Re: berlingo van in eco mode

Post by wheeler »

:-k Wiring looks OK then. I'll need to have a think about this one.

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

ive also taken the nearside front wing off and the wiper scuttle to expose more of the vans wiring to see if theres anything broken or corroded but all looks well. Beginning to think this vehicle is destined for the breakers yard which would be a shame but hey ho.

wheeler
Posts: 4296
Joined: 21 Sep 2002, 19:07
x 152

Re: berlingo van in eco mode

Post by wheeler »

Just to confirm, the battery light comes on when the ignition is switched on and stays on with the engine running? does the central display say ECO-MODE when the engine is running?
What exactly isn't working when the engine is running?

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

the van came as a non runner with an assumed electrical fault. the previous owner told me his troubles started when the glow plug light stopped working then this progressed to non start. when i got the van home i immediately removed the immobiliser module from the fuel pump and took out fuel control valve to allow a free flow of fuel. the van started first time but of course wouldnt stop when switched off due to no valve to halt the fuel flow. once running i noticed that only the fuel guage worked. no rev counter speedo or temp guage. the abs handbrake warning light and battery light were also on. switching on the radio activated the eco mode message on the central display. after a couple of minutes running the abs light went out and fuel guage dropped to zero. switching the ignition off then on again ( remember engine keeps running ) starts the whole process again. from memory the circuits that are out are dipped headlights wipers/washers the aforementioned guages eml / aibag and glow plug lights. every thing else including central locking and windows works on initial start up but i lose the windows when the fuel guage drops. a switch off and on restores the power to windows until the fuel guage drops again. glow plug circuit works to start from cold despite the lack of a glow plug lght on the dash. battery warning light is lit at all times after power up.

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

im now resigned to stripping this for parts and have already started taking bits off for other vehicles but it would be good to find the cause to put the few bits back or at least for future reference.

wheeler
Posts: 4296
Joined: 21 Sep 2002, 19:07
x 152

Re: berlingo van in eco mode

Post by wheeler »

If i was investigating this fault the next thing i would do is to scope the VAN & CAN wiring. There has to be some sort of communication fault.

P.S. i would say that it would have been relevant to mention that it had came to you as a non runner & that you had bypassed the stop solenoid to get it started when asked about a bit of background to the fault. I would have said that was quite significant 🙄

spannerman0785
Posts: 21
Joined: 04 Mar 2020, 08:13

Re: berlingo van in eco mode

Post by spannerman0785 »

i once again thank you for your assistance. i wont be spending any more time on this but its not been a total disaster as i have a bucket load of parts and a good engine and gearbox for use on other projects. will try to play safe and stick to mechanical projects LOL.