Diagnosing a fault

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: Diagnosing a fault

Post by RichardW »

Better to jack it under the front subframe - Xsara Pic sills are not exactly known for their strength and integrity!!

However the pic Marc posted shows it to be on the top of the bell housing.... so no jacking required.
ChangyUK
Posts: 12
Joined: 01 Feb 2020, 14:00

Re: Diagnosing a fault

Post by ChangyUK »

RichardW wrote:
05 Mar 2020, 12:39
Better to jack it under the front subframe - Xsara Pic sills are not exactly known for their strength and integrity!!

However the pic Marc posted shows it to be on the top of the bell housing.... so no jacking required.
Please, can you help a Citroen newbie and point me in the correct area? Perhaps a photo of the engine area?

I wish I had not got involved with this car, but they're my parents, so I cannot leave them permanently stranded

Thanks again and sorry for being a doughnut!

C
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: Diagnosing a fault

Post by RichardW »

I'll see if I can find a procedure later.
ChangyUK
Posts: 12
Joined: 01 Feb 2020, 14:00

Re: Diagnosing a fault

Post by ChangyUK »

RichardW wrote:
05 Mar 2020, 15:02
I'll see if I can find a procedure later.
I managed to find the sensor and fitted a new one. Sadly, the car still refuses to start! It makes a sound like it is going to fire into life, but it just sits there laughing at you!

The next thing I need to check is the continuity of the wiring. Is there a pinout for the ECU so I can check it? Trying to trace the wire was tricky, I think I need glasses!

I'm not sure what else I can do, the Lexia diagnostics showed the crank sensor.

I would welcome any ideas.

C
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26024
Joined: 15 Sep 2015, 19:38
x 2980

Re: Diagnosing a fault

Post by GiveMeABreak »

Here's the Ignition System for your Xsara Picasso 1.6i 16V Petrol TU5JP4.

The Engine Speed sensor you just replaced is 1313 on the diagram. Other codes can be found on our Wiki:

Engine Component Codes Link

Image