407 2.0hdi won’t start !

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
myglaren
Forum Admin Team
Posts: 17562
Joined: 02 Mar 2008, 14:30
x 849

Re: 407 2.0hdi won’t start !

Post by myglaren »

Oddly enough, it was -3°C here during the night. My car wasn't here, son was in work at 06:00 so he kept it at his.
He did say it started just as normal, no use of glow plugs.

He was miffed as he had removed all the cold weather hear - cloths and ice scrapers mainly - a month ago when he took it mountain biking, never put them back.

He uses the car more than I do these days.

moizeau
donor 2020
Posts: 926
Joined: 12 Jan 2015, 17:08
x 123

Re: 407 2.0hdi won’t start !

Post by moizeau »

Never used the glow plugs, It was -8 last winter and it just fired up. I wouldn't give yourself the grief until you've confirmed everything else.

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Well, egr has been playing up for some time. Any way of testing it or bypassing it ?

moizeau
donor 2020
Posts: 926
Joined: 12 Jan 2015, 17:08
x 123

Re: 407 2.0hdi won’t start !

Post by moizeau »

Diagbox will test it, with newer cars you need a little electronic gadget help.

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Looks like an expensive week after the £100 speeding fine then. Ok so what do I need to get n best place to get it. Just to mention, I need to program a new key for my 2001 2.0hdi Bingo as well, so may as well get something that will do that as well n save £50 !

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Just has a look at Easydiagnostics via link on this site. My only available laptop runs on XP so is the Bluetooth interface any use to me on my iPad ?

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Been out to try again this morning as temp up to 4C. After turning on 3 times and waiting for glow plug light to go out it actually fired up, but just juddered and shook for about 10 seconds like it trying to run then died. I might try getting a can of Easystart later n try that. I’m still thinking glow plugs, I’m sure I read somewhere you need them all the time on these engines not just below -5C

Hell Razor5543
NOT Alistair or Simon
Posts: 10234
Joined: 01 Apr 2012, 09:47
x 912

Re: 407 2.0hdi won’t start !

Post by Hell Razor5543 »

The HDi engines are very good at starting (assuming no problems) regardless of the temperature. Because of the pressures involved (200BAR on the fuel rail, if my memory is correct) means the glow plugs are hardly needed, even in cold conditions. My current car (and the last three) all had HDi engines, and even in very cold conditions the glow plug light was only on for a second, at most. Blink and you would miss it most of the time.

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Ok. The car has never let me down and always starts until now.
The symptoms are the same as my old Pug td when the glow plugs needed replacing.
It’s not the starter motor that I can tell.
And the egr valve had been playing up and was identified as a fault code by obd2.
I can buy a Digibox thing or Lexia or whatever, but which ?
Will the egr valve problem stop it from starting ?
How can I check the glow plugs ?
Can I bypass the egr or fool it in some way ?
Thanks

Hell Razor5543
NOT Alistair or Simon
Posts: 10234
Joined: 01 Apr 2012, 09:47
x 912

Re: 407 2.0hdi won’t start !

Post by Hell Razor5543 »

I would not worry about the glow plugs (unless the temperature drops like a stone!). You could buy a Lexia clone (but make certain you get one with the full chipset, as some of the cheaper units do not have a complete octo-coupler set, and probably would not work on your 407), but there are also forum members who have decent Lexia clones and are willing to help other forum members;

https://www.frenchcarforum.co.uk/forum/ ... 22#p509922

If you do decide to get your own Lexia clone system you will also need a laptop running a 32bit O/S (such as Windows XP or Windows 7). The Lexia equipment will come with the relevant software (DiagBox, which then calls up the relevant software depending on what the vehicle is). The Lexia application (used for earlier Citroens) is so old it needs a 16bit runtime environment to work, and a 64bit O/S cannot do this (unless you also install a Virtual Machine system with clean access to the USB systems).

electronmirror
donor 2020
Posts: 226
Joined: 27 Oct 2005, 20:42
x 16

Re: 407 2.0hdi won’t start !

Post by electronmirror »

Many of the non starting C5 2.0 HDI problems noted on this forum have turned out to be starter motor issues.

On the 8v HDI and possibly 16v HDI variant, the common rail requires a minimum 200 bar pressure for the engine ECU to allow a start. If the starter motor is slow the minimum pressure will not be achieved hence no start.

There's a chance that this may also apply to the Peugeot HDI engine.

Good luck.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1883

Re: 407 2.0hdi won’t start !

Post by GiveMeABreak »

Martinez wrote:
09 Nov 2019, 21:06
Just has a look at Easydiagnostics via link on this site. My only available laptop runs on XP so is the Bluetooth interface any use to me on my iPad ?
No! Apple products not supported / non-compatible software.

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Let’s put the starter to bed. If I go out now and turn ignition on it will fire right away but won’t run. It just tries to run n sounds really rough. I’ve had the car start on an almost flat battery in the past and as sooon as it fires once it’s fine n running well. I’ve tried it with 2 batteries fully charged and no better. The car was fine. The engine light came on the dash and it beeped n said ‘anti pollution fault’ then stalled when I stopped and it ran really rough when I tried to start it just like now but it did eventually start unlike now. When I drove it every time I put my foot on the gas it died, like a flat spot before it revved and drove off. It’s done this before but always clears again and has always started regardless. When I put OBD2 on it had 8 codes come up, most saying something about egr valve. I don’t see how it can be the starter motor, something went wrong or something has failed.

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

It’s now 7 dec C. Car started right up n ran for around 5 seconds then stopped as soon as I touched the accelerator pedal. It usually fires up n just ticks over. No codes showing on OBD2

Martinez
Posts: 63
Joined: 06 May 2019, 16:58
x 5

Re: 407 2.0hdi won’t start !

Post by Martinez »

Just to update the situation. It was the egr valve. Replaced and all working well