Where have all the xantia posts gone?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
xantia_v6
Forum Admin Team
Posts: 6734
Joined: 09 Nov 2005, 23:03
x 328

Re: Where have all the xantia posts gone?

Post by xantia_v6 » 09 Sep 2019, 11:23

Do you know if it is the ram itself leaking, or a spit pipe (due to the ram coming loose on its mounts)?

The Xantia V6 rack is unique and not used on any other Xantia, so (particularly in RHD) is fairly rare, but you might get lucky.

HunterSteel
Posts: 23
Joined: 28 Aug 2019, 09:02
x 3

Re: Where have all the xantia posts gone?

Post by HunterSteel » 09 Sep 2019, 12:48

xantia_v6 wrote:
09 Sep 2019, 11:23
Do you know if it is the ram itself leaking, or a spit pipe (due to the ram coming loose on its mounts)?

The Xantia V6 rack is unique and not used on any other Xantia, so (particularly in RHD) is fairly rare, but you might get lucky.
Image

It looks like its a seal on one of the pipes that feeds that ram. My little brother was the one who took this picture. It's on the Driver's side of the car.

~Hunter

User avatar
Michel
Posts: 1619
Joined: 29 May 2017, 13:50
x 279

Re: Where have all the xantia posts gone?

Post by Michel » 09 Sep 2019, 14:28

Saw loads in France a couple of weeks ago out around Verdon Gorge and Regusse!

User avatar
xantia_v6
Forum Admin Team
Posts: 6734
Joined: 09 Nov 2005, 23:03
x 328

Re: Where have all the xantia posts gone?

Post by xantia_v6 » 09 Sep 2019, 16:04

HunterSteel wrote:
09 Sep 2019, 12:48
xantia_v6 wrote:
09 Sep 2019, 11:23
Do you know if it is the ram itself leaking, or a spit pipe (due to the ram coming loose on its mounts)?

The Xantia V6 rack is unique and not used on any other Xantia, so (particularly in RHD) is fairly rare, but you might get lucky.
Image

It looks like its a seal on one of the pipes that feeds that ram. My little brother was the one who took this picture. It's on the Driver's side of the car.

~Hunter
In that case, it is unlikely to be the rack itself, and you really need to see exactly where the LHM is escaping.

User avatar
white exec
Moderating Team
Posts: 4704
Joined: 21 Dec 2015, 13:46
x 631

Re: Where have all the xantia posts gone?

Post by white exec » 09 Sep 2019, 17:39

Does look like that union to the left of the shaft, that has been washed clean by the leaking fluid.
You might be lucky and just be able to renew the rubber sleeve in the joint.
Worth a try.

Worryingly rusty under there, and in real need of some protective wax.

HunterSteel
Posts: 23
Joined: 28 Aug 2019, 09:02
x 3

Re: Where have all the xantia posts gone?

Post by HunterSteel » 09 Sep 2019, 22:12

white exec wrote:
09 Sep 2019, 17:39
Does look like that union to the left of the shaft, that has been washed clean by the leaking fluid.
You might be lucky and just be able to renew the rubber sleeve in the joint.
Worth a try.

Worryingly rusty under there, and in real need of some protective wax.
Luckily for us it really is only a rubber seal that got old.
Also, that's not rust. That's dust and soot that collected under there from when my Dad used the car in Zambia to drive him to work at the mine. (He was the Project Manager and the office was always through dirt roads so it picked up this dust and soot.)

~Hunter

User avatar
xantia_v6
Forum Admin Team
Posts: 6734
Joined: 09 Nov 2005, 23:03
x 328

Re: Where have all the xantia posts gone?

Post by xantia_v6 » 09 Sep 2019, 22:29

It might be a steel cone joint, not a rubber seal, I am not sure, but I have a feeling...

User avatar
van ordinaire
donor 2017
Posts: 2416
Joined: 23 Jun 2015, 14:45
x 219

Re: Where have all the xantia posts gone?

Post by van ordinaire » 09 Sep 2019, 23:33

Well my Xantia's still serving well as a family hack - & I keep getting told how impressed everyone who's ridden in it is with how comfortable it is. I think I've only driven once since getting back from Maastricht in January. Then again, I've not had to do much except an oil & filter change - although I suspect another is due. Must do something with the brakes too as they were an advisory on last MoT, so it may figure more here than it has thus far.

jauv
Posts: 3
Joined: 11 Sep 2019, 15:16
x 5

Re: Where have all the xantia posts gone?

Post by jauv » 11 Sep 2019, 15:41

Joined the forum to read up on tomorrow's plan - going to check out a 97 Xantia which looks to be in decent shape with ~135 000km in odometer. Though it has sat in storage for 10 years until recently, so I'm not expecting much. Hopefully it's as good as it seems, would certainly lead to more Xantia content. :P

User avatar
daviemck2006
Donor 2016
Posts: 4791
Joined: 04 Dec 2010, 19:45
x 283

Re: Where have all the xantia posts gone?

Post by daviemck2006 » 12 Sep 2019, 20:48

My Xantia is out of MOT, been sitting at the side of the house for more than a year. I am unable to now try to fix it and needs too much things done to make it economical to sort. Anyone who would want to save her, come get her.her

User avatar
Skull
donor 2017
Posts: 593
Joined: 02 Aug 2013, 13:35
x 29

Re: Where have all the xantia posts gone?

Post by Skull » 12 Sep 2019, 21:12

Davie I was at Dornoch a few weeks ago and would have taken a runner off you #-o

admiral51
donor 2019
Posts: 1639
Joined: 24 May 2007, 10:11
x 95

Re: Where have all the xantia posts gone?

Post by admiral51 » 12 Sep 2019, 21:20

oh no another temptation :(

User avatar
Skull
donor 2017
Posts: 593
Joined: 02 Aug 2013, 13:35
x 29

Re: Where have all the xantia posts gone?

Post by Skull » 12 Sep 2019, 21:29

They're everywhere at the moment [-X :lol:

jauv
Posts: 3
Joined: 11 Sep 2019, 15:16
x 5

Re: Where have all the xantia posts gone?

Post by jauv » 13 Sep 2019, 04:09

jauv wrote:
11 Sep 2019, 15:41
Joined the forum to read up on tomorrow's plan - going to check out a 97 Xantia which looks to be in decent shape with ~135 000km in odometer. Though it has sat in storage for 10 years until recently, so I'm not expecting much. Hopefully it's as good as it seems, would certainly lead to more Xantia content. :P
What have I done :lol:
Image

User avatar
white exec
Moderating Team
Posts: 4704
Joined: 21 Dec 2015, 13:46
x 631

Re: Where have all the xantia posts gone?

Post by white exec » 13 Sep 2019, 06:38

\:D/ \:D/ \:D/ \:D/ \:D/
Well done, you!