Citroen Xsara - Heater Blower NOT WORKING

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
GiveMeABreak
Forum Admin Team
Posts: 28952
Joined: 15 Sep 2015, 19:38
x 3595

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by GiveMeABreak »

With ECUs involved (A/C ECU 8080 on the diagram) and the BSI and the Engine and Passenger Fuse boxes and their integrated relays it makes it a little more involved to pin the problem down. That ignition wire issue could be because of the BSI involvement from the ignition switch. There are differences of course between the electrical systems and multiplexing used on your car and the Xsara Picasso - depending on model and year.

According to my info, the wires in the 4 pin blower control module connector are represented as:

Wire 1 (Pin 1): multifunction motor ECU + battery F1 output
Wire 4 (Pin 2): multifunction motor ECU F5-1 power relay output
Wire 2 (Pin3): multifunction motor ECU F1 main relay output
Wire 3 (Pin 4): multifunction motor ECU F21 main relay output
c0nn3ct
Posts: 11
Joined: 12 Jun 2019, 20:54

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by c0nn3ct »

Hi Marc,

Thanks for the information. I am going to try and test the blower (motor and resistor) outside of the car - just using power from the battery only.

Thanks

Mike
c0nn3ct
Posts: 11
Joined: 12 Jun 2019, 20:54

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by c0nn3ct »

The three potential faults I have identified (hopefully) are:
1. Ignition Switch Cable (Common fault with the Picasso not sure about the Xsara)
2. Fan Resistor (I changed this 3 years ago - as the fan was stuck on max)
3. Blower motor

I have just retested the 4 pins as per the previous tests I carried out earlier today. It looks like the results were incorrect (not sure why) the red cable is 0V when the ignition is off and 12-14V when the ignition is on.

I used this red wire to connect the 4 pin connector directly to the red pin on the back of the fan and the black to black, the fan kicked in following this circuit - this is confusing as I used the 12V directly from the battery earlier today, therefore the 4 pin connect should be ok and the ignition switch cable should be ok too.

I plugged the 4 pin connector into the unit and the fan now works!!!!

I have stripped the car down to get access and I don't want to put it all back together for this to happen again.

I have taken photos of the inside of the resistor and blower unit below:
IMG_20190614_203122.jpg
IMG_20190614_202904.jpg
Could the resistor be damaged? The blower on the right of the second photo looks like there is corrosion (water damage?) to the bottom left?

As it stands, the fan now works and it doesn't like the issue is the wiring further than the 4 pin connector?

Any advice would be much appreciated.

Thanks

Mike
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28952
Joined: 15 Sep 2015, 19:38
x 3595

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by GiveMeABreak »

I do know that there was an issue with the blower motor bearings; where water gets into the bearings and they can start to seize up. When this happens on models with climate control, the blower motor starts off on low and gradually powers up to the required speed as needed depending on the actual temperature and requested temperature.

In this scenario, there is insufficient power to start the motor on the lower speed. Others here have bypassed the ECU and wired it directly to the mains as it were in order to provide full power on start up temporarily to get it going again.

So if there are signs of water getting into the unit it’s possible that it may have gotten inside. Worth a look while you have it out the vehicle. It still doesn’t explain the ignition key wiggling, and that may also need attention. That issue can be caused by having multiple keys, key rings and other junk on the ignition key ring. This additional weight is exacerbated with the motion of the vehicle and ultimately weakens the internals of the barrel, causing intermittent issues. I never have any more than an additional key and leather fob on mine for this reason.
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

citroen xsara picasso hdi 2002. heater blower stopped after sounding rough. removed and replaced fan unit and resistor with new unit. still no good. old unit had almost seized. replaced ignition switch module/cables. heater blower still not working. all controls work / light up etc but not blower. no lose ignition barrel. any ideas?
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

fuse is ok
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28952
Joined: 15 Sep 2015, 19:38
x 3595

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by GiveMeABreak »

Which fuse did you check and did you check the Maxi Fuse?
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

checked the 40amp fuse were all the fuses are, right of driver position. I'm unfamiliar with the Maxi fuse.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28952
Joined: 15 Sep 2015, 19:38
x 3595

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by GiveMeABreak »

Pop up your IN and i'll take a look at the circuit diagram.
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

sure, what is an IN?
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

are the Maxi fuses under the bonnet?
Hell Razor5543
Donor 2021
Posts: 12582
Joined: 01 Apr 2012, 09:47
x 1726

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by Hell Razor5543 »

I think Marc had a typo. He meant VIN (which, for security reasons, will be obscured so only Moderators can read it). The Maxi fuses are normally under the bonnet, but also underneath (normally) the usual fuse box area.
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

thanks, I'll have a look. Am I just looking for signs of 'blown' fuses etc?
xsara2002hdi
Posts: 14
Joined: 16 Aug 2019, 17:05

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by xsara2002hdi »

the fuses under the bonnet are all ok
Hell Razor5543
Donor 2021
Posts: 12582
Joined: 01 Apr 2012, 09:47
x 1726

Re: Citroen Xsara - Heater Blower NOT WORKING

Post by Hell Razor5543 »

It is not unusual for there to be a hidden fuse box in the engine bay that contains the MAXI fuses. As these carry far more amperage than the normal fuses they are considered to be authorised personnel serviceable only.