Xantia 2.0 HDI late model with AC - radiator fans

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
white exec
Moderating Team
Posts: 7329
Joined: 21 Dec 2015, 13:46
x 1431

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by white exec »

Assume similar to XM (put me right if this isn't so)...

Two radiator fans.
Should operate in series (for slow/1st speed)
Should operate in parallel (for fast/2nd speed)
Series-parallel operation is done by the three interconnected relays up front.
Switching on AC will automatically turn fans on to slow speed (to cool AC rad).

Fans should never operate one at a time; if they do, there is either a fan fault, or a relay fault.
Fans are usually separately fused: two Maxi fuses near the battery.

Pulling the connector for the temp sensor will do as described: very brief slow speed, followed immediately by fast speed*. IIRC, reconnecting doesn't stop the fans - you need to switch off IGN and back on again to revert to normal operation. *A safety feature in case of sensor failure.

Correct circuit diag for the car will confirm.
User avatar
myglaren
Forum Admin Team
Posts: 20320
Joined: 02 Mar 2008, 14:30
x 1688

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by myglaren »

Or a sticking/seized fan motor.
Poke it with a stick - don't put your fingers anywhere near them as they can start up without warning.
User avatar
white exec
Moderating Team
Posts: 7329
Joined: 21 Dec 2015, 13:46
x 1431

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by white exec »

A seized fan will either be a short circuit
- this will cause the other fan to run at fast speed on its own, when both should be running at slow speed
- this should blow its maxi fuse, if it gets asked to run at fast speed

or open circuit
- slow speed will not happen
- in absence of this, engine will run hot until fast speed is called for
- then the working fan will run fast
User avatar
Pshemsky
Donor 2020
Posts: 43
Joined: 04 Nov 2015, 17:26
x 11

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by Pshemsky »

admiral51 wrote:
09 Dec 2018, 17:57
According to the info in the post i linked to both should spin full speed when that sensor plug is removed.
I would be inclined to remove the fan that does not work and apply 12v directly to it, that will determine if the fan itself is at fault and as you have spares it should only cost time and effort, be aware that 12v will set it on full speed so keep fingers well away from the blades.
Can i ask if your aircon is working, does the compressor kick in and if so do you get both fans spinning at slow speed.?
I am used to the MK1 Xantia fan problem so as i now have a MK2 with issues i am keeping a close eye on this thread

Right. So with cold engine direction set on screen and A/C button pressed I've noticed that AC compressor not kicking in. After a minute or two one fan (drivers side) goes with full speed for about 10-15 sec and then goes off. Situation repeats every few minutes.
PS: AC system got a pressure to operate, so not sure why it won't start.
myglaren wrote:
09 Dec 2018, 18:07
Or a sticking/seized fan motor.
Poke it with a stick - don't put your fingers anywhere near them as they can start up without warning.

Tried that already - spins freely but no reaction. I had seized motor in m XM few years back, so that was a first thing which I did to this Xantia :wink:
Last edited by Pshemsky on 09 Dec 2018, 18:26, edited 1 time in total.
admiral51
Donor 2021
Posts: 2354
Joined: 24 May 2007, 10:11
x 299

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by admiral51 »

Not sure on the above, MK1 Xantia yes, MK2 replaced the Bitron and fan activation/speed is activated by an ECU.
Info is contained Here
admiral51
Donor 2021
Posts: 2354
Joined: 24 May 2007, 10:11
x 299

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by admiral51 »

Sorry was replying to posts earlier :(
User avatar
white exec
Moderating Team
Posts: 7329
Joined: 21 Dec 2015, 13:46
x 1431

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by white exec »

What I described above was the classic arrangement with two fans and three relays, which were triggered by Bitron/ECU on later models, rather than the old-style 'thermo-switch' of BX and CX.

Might be a good idea, Prem, to post your VIN, so we can check RP and an exact circuit diagram, to avoid mis-diagnosis.

No shortage of advice on this pre-Christmas Sunday!
User avatar
Pshemsky
Donor 2020
Posts: 43
Joined: 04 Nov 2015, 17:26
x 11

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by Pshemsky »

white exec wrote:
09 Dec 2018, 18:34
No shortage of advice on this pre-Christmas Sunday!

I'm really impressed !! =D>

VIN VF7**************[VIN obfuscated, can be read by forum staff]
Thanks Chris

PS: It's bit too dark now and I'm on my way to work, but tomorrow I'll check A/C fuse and one of fan's fuses for start.
User avatar
KennyW
Donor 2020
Posts: 2170
Joined: 17 Jan 2006, 22:22
x 65

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by KennyW »

If you have disconnected the temp sensor and only 1 fan spins, have a look at the relays between the fans in a black triangle plastic box.

Make sure they are clean and have not suffered from overloading and melted plastic holders.

If this is the case you will have to check the continuity through the system.

On my Xantia it was broken wire in the harness.

I remember much cursing when I was testing the wiring

If you search on the forum there are plenty of threads on the subject look in the a/c section.

Kenny
admiral51
Donor 2021
Posts: 2354
Joined: 24 May 2007, 10:11
x 299

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by admiral51 »

Does anyone have a link to which 2 wires need to be bridged to activate the aircon clutch and the other 2 to set the fans to full speed.
Distant memory says there are 2 thick and 2 thinner wires on the plug to the air dryer but having had a quick look on my MK2 Xantia the wires are not as identifiable as i remember :)
User avatar
white exec
Moderating Team
Posts: 7329
Joined: 21 Dec 2015, 13:46
x 1431

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by white exec »

Can we pull up a cooling fan circuit for Prem's VIN? I don't have one here.
User avatar
KennyW
Donor 2020
Posts: 2170
Joined: 17 Jan 2006, 22:22
x 65

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by KennyW »

Have a read of my post from 2006 below which details a similar problem

https://www.frenchcarforum.co.uk/forum/ ... 12&t=19296

Kenny

Sorry it's a bit of read :-D
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25505
Joined: 15 Sep 2015, 19:38
x 2855

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by GiveMeABreak »

I’ll have a look at the circuit if it is there shortly.
admiral51
Donor 2021
Posts: 2354
Joined: 24 May 2007, 10:11
x 299

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by admiral51 »

Just a thought, this forum is awesome :)
admiral51
Donor 2021
Posts: 2354
Joined: 24 May 2007, 10:11
x 299

Re: Xantia 2.0 HDI late model with AC - radiator fans

Post by admiral51 »

This is my Vin for a 2000 w plate 2.0 HDI if that helps
VF7**************[VIN obfuscated, can be read by forum staff]