RT4 Amplifier Issues

This unit is the RT4 and RT5 system and is made by Magneti Marelli
Main differences between RT4 & RT5 - RT5 has Bluetooth Hands Free, faster Navigation calculation and on C4 & C4 Picasso only, USB ports and a High-Res screen.

Moderator: RichardW

User avatar
GiveMeABreak
Forum Admin Team
Posts: 25134
Joined: 15 Sep 2015, 19:38
x 2774

Re: RT4 Amplifier Issues

Post by GiveMeABreak »

Because you've probably connected the positive 5V supply from the USB port of the RT4 down the A/C CAN wires - this has possibly led to some part of the BSI getting a 5V on the circuit and might have done something there.

There's nothing that can be done to reprogramme or reset the BSI using a clone or a dealer level tool. Downloading the BSI configuration file won't make any difference if some part of the BSI circuitry board has been affected by the voltage spike. That's why I suggested you check the A/C fuse 12 - but now I would check ALL the fuses on the BSI board in case it has blown one of those.

See my last diagram of the wiring for the A/C circuit. 2 wires are the compressor post and neg and teh other 2 are the CAN high and Low wires - that will carry the data around the car network and end up back at the BSI.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25134
Joined: 15 Sep 2015, 19:38
x 2774

Re: RT4 Amplifier Issues

Post by GiveMeABreak »

It is possible that you may have left one of the ECUs in an 'unstable' mode. his can happen if you have done the wiring without allowing the CAN network to close down the ECUs first. Disconnecting any CAN wiring without doing this can also have the same effect.

I suggest you do a full battery disconnect and restart following this procedure EXACTLY and don't skip any parts especially the timings. If your Battery is in the boot, just substitute that for the bonnet:

Battery Disconnect / Reconnect Procedure
JIITEE
Posts: 21
Joined: 13 Aug 2018, 01:08

Re: RT4 Amplifier Issues

Post by JIITEE »

Checked, fuses are ok, but ac control is dead, maybe time to buy new BSI
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25134
Joined: 15 Sep 2015, 19:38
x 2774

Re: RT4 Amplifier Issues

Post by GiveMeABreak »

BSI (ANC) without configuration, so will need coding to the car using your confidential code so it matches the Engine ECU and the Immobiler transponder chips in your key fobs.
Part number is : 657062, £397.45 new.
JIITEE
Posts: 21
Joined: 13 Aug 2018, 01:08

Re: RT4 Amplifier Issues

Post by JIITEE »

Well, looks like car electrical components are totally ok, except: webasto relays cold be someway burned, ralays wont work like should. When i connect those wires (red circles) direct ac and blower works fine?! Really weird thing??!! What could burn those relays while installing wires?!! I have not touched those wires??
DSC.JPG