xsara 1.4hdi engine - 206 1.4hdi engine swap

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

RichardW
Forum Treasurer
Posts: 8812
Joined: 07 Aug 2002, 17:12
x 303

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by RichardW » 14 Dec 2016, 18:01

Ah, it's not going to start at only 71 bar fuel pressure - it needs 150 + before it will fire the injectors. 190 rpm looks OK, should be enough to make it go. You could try a bit of Easy-start - sometimes this is just enough to up the cranking speed to build the fuel pressure to allow it to start.

Have you fitted a clean fuel filter? Can you change over the rail pressure sensor from the other engine?

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 14 Dec 2016, 18:38

Thanks again Richard. Yes , we have tried EASYSTART, but no go.

We will put contact cleaner on the rail pressure sensor and see what happens , then change the sensor.

Bit of a confession here - the wires to the rail pressure sensor were damaged and we had to solder them - we did a neat job and covered it in heat-shrink insulation, but it now worries us.

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 18 Dec 2016, 17:56

Hello again , cleaned all connections - again.

Tried Easystart - does not move from 71bar.

The thing is - the rail pressure sensor is 126euros and we only paid 100euros for the car !!!!!


Will go to the scrappie and see whats out there - will probably change the loom to the rail and glowplugs at the same time.

RichardW
Forum Treasurer
Posts: 8812
Joined: 07 Aug 2002, 17:12
x 303

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by RichardW » 19 Dec 2016, 13:06

Does it read 71 bar even when not cranking?

If so, then definitely something amiss with the sensor or the wiring....

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 19 Dec 2016, 13:13

Yes it does Richard , always 71bar.
In another topic, Wheeler said to disconnect the rail pressure sensor and the ecu will default to a value high enough to open the injectors - when we do that the sensor on the back of the injection pump buzzes continuously - a very bad noise.

We are going to try to get an undamaged glowplug/rai/injector loom today.

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 04 Jan 2017, 13:21

SHE LIVES :rofl2: :rofl2: :rofl2:

Hell Razor5543
NOT Alistair or Simon
Posts: 9312
Joined: 01 Apr 2012, 09:47
x 629

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by Hell Razor5543 » 04 Jan 2017, 14:50

Yay! What was the problem in the end, and how did you fix it?

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 04 Jan 2017, 15:23

We bought a secondhand wiring loom (for 15euros) for the injection side. It has the wiring for the 4 injectors, the common rail and the glowplugs.

Absolute pig to change it as on the 1.4hdi its down the back of the engine.

We have one of those charger/booster starters which we recently bought - its a fabby tool, Would highly recommend it because it allows you to turn a car engine over and over and over.

We connected a long wire to the solenoid on the starter, turned on the ignition, and standing in front of the car we touched our slave wire onto the battery while spraying easy-start into the intake. It fired and died , fired and died , turned over snd stuck but the booster had enough to force it to turn again - it fired and ran.

The little engine symbol on the dash is lit - but it was always lit on our 206hdi. Its normally the sensor in the water system over just above the gearbox - a little sod of a problem on the 1.4hdi.

Thanks to all who helped - we will keep everyone up to date when we start to drive it :) :) :)

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 24 Jan 2017, 19:47

Hello to all , have done a few hundred km and its good - very different from the 1.9 even though they both have 68bhp. Does not embarrass itself and much more lively than we expected for a 1.4 in a decent sized estate car. Passed its CT easily with a very clean report. No long trips or foot down open road stuff ....yet.

xsaras4ever
Donor 2016
Posts: 381
Joined: 07 Aug 2013, 13:43
x 39

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by xsaras4ever » 24 Aug 2017, 12:49

Hello again to all - just a report on this car.


Its easily the best xsara we have ever owned - and from memory its xsara number 9 for us.

We have had the 1.9d, 1.9td , 2.0hdi and now this 1.4hdi - all in estate format.

Its no slouch - way better that you would expect from a 1.4hdi.

Fuel economy is excellent.

It does use oil - just like our Pug 206 did with the 1.4hdi engine. We check our oil regularly in order to protect the turbo. We also change our oil every 10000km.

It does sometimes smell of bitumen - that's the heat-shield on the exhaust and turbo at the front of the engine - again our 206 was the same.

However, for some reason its faster and more responsive than our 206 - which makes no sense .
Its way better than the 1.9dw8 xsara, which has comparably bhp.

It feels closer to the 2.0hdi in normal driving.

Its a rare beast being a xsara estate 1.4hdi - but so far we have done 20000km in it and are very happy.

Big thank you to all who helped and showed an interest in this topic. :) :) :)

User avatar
myglaren
Forum Admin Team
Posts: 16082
Joined: 02 Mar 2008, 14:30
x 500

Re: xsara 1.4hdi engine - 206 1.4hdi engine swap

Post by myglaren » 24 Aug 2017, 17:17

Pleased to hear it is going well and exceeding your expectations :)