a new acquisition

Dedicated to owners of Citroen GS and GSA models.

Moderator: RichardW

sonoramicommando
Posts: 339
Joined: 07 Sep 2011, 11:03
x 4

Re: a new acquisition

Post by sonoramicommando »

Fiddled with the instrument panel and it does work when idling at rest. Maybe I'll go for a drive tomorrow and see what happens. Speedo cable, it feels like clicked in (tried it with the instrument panel out for comparison) - hopefully it'll work, fingers crossed.
Oh by the way the boot open light switch is a bit rubbish, isn't it? :(

User avatar
Stonehopper
Posts: 259
Joined: 24 Feb 2012, 17:10
x 30

Re: a new acquisition

Post by Stonehopper »

Most likely a disturbed poor connection on the electrics. And if the boot light switch is anything like mine - rubbish. It's a gravity actuated little cylinder attached to the boot lid which tips as the lid is lifted, causing a weight within to slide to one end thereby making a bridge across two contacts. Replaced with new and still rubbish.

sonoramicommando
Posts: 339
Joined: 07 Sep 2011, 11:03
x 4

Re: a new acquisition

Post by sonoramicommando »

Update: test drive was mostly successful. Speedo cable is properly hooked up and operational but electrics still dropped out a few times, although only momentarily. The only give away was the digital clock resetting itself to 10:00. I think it happened 3-4 times in 15km journey. The worst part of it is losing hazard light, surely it has to be on a separate circuit...

Gsbx1220
Posts: 20
Joined: 17 Oct 2016, 22:26
x 3

Re: a new acquisition

Post by Gsbx1220 »

I had similar with mine. No indicators or instruments. After some investigation, I found it was the ignition switch. A bit of a pig to change, but one changed all was well.

sonoramicommando
Posts: 339
Joined: 07 Sep 2011, 11:03
x 4

Re: RE: Re: a new acquisition

Post by sonoramicommando »

Gsbx1220 wrote:I had similar with mine. No indicators or instruments. After some investigation, I found it was the ignition switch. A bit of a pig to change, but one changed all was well.
Thanks - I did look at the ignition switch for a different reason (offset from the key hole) and it looked a bit awkward. I hope I won't have to change it, fingers crossed...

Sent from my GT-I9505 using Tapatalk