Xantia 99 1.9 TD immobiliser problem - lexia results help needed

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

ecohouse1
Posts: 283
Joined: 29 Aug 2011, 12:44
x 3

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by ecohouse1 »

Thanks Jim, is the double relay the "smaller black thing" in with the ECU? And can I ask what the green relay does in next to the ECU? Sorry for the all the questions!
Cheers
User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1784

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by CitroJim »

ecohouse1 wrote:Thanks Jim, is the double relay the "smaller black thing" in with the ECU?
yes, it is and the green relay is to do with the air conditioning Alan...

Sorry for the terse reply, very busy at the moment...
ecohouse1
Posts: 283
Joined: 29 Aug 2011, 12:44
x 3

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by ecohouse1 »

Cheers Jim. Much appreciated. Alan
ecohouse1
Posts: 283
Joined: 29 Aug 2011, 12:44
x 3

Xantia TD Wiring Diagram Fault Finding

Post by ecohouse1 »

Hi Folks
Shivered my A** off prodding around the Xantia Electrics trying to get to the bottom of the immobiliser light and beep on ignition on. Reached the following conclusions:

Ignition on and plug removed from main engine ECU, identified:

No Earth present on 18 but OK on all other earth pins
No 12V supply to Pin 16.
From looking at the circuit diagram it appears that Pin 16 is fed from wire 1210 from Pin 5 on the Double relay? 1304

What is component 1208 at the bottom right?http://s1038.photobucket.com/user/ecoho ... sort=3&o=0

Many thanks
User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1784

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by CitroJim »

When I'm home I'll be able to see, on Tapatalk on my phone at mo and can't see the diagram in any detail..
superloopy
Posts: 3303
Joined: 30 Mar 2005, 03:25

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by superloopy »

Haynes BOL identifies 1208 as 'Diesel fuel injection pump(advance corrector, electric cut-off, safety switch)' .... Jim'll have more to add soon :wink:
ecohouse1
Posts: 283
Joined: 29 Aug 2011, 12:44
x 3

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by ecohouse1 »

Mmm that's interesting - could that be connected to the immobiliser? Also does anyone know where MM01 earth point is? That's the wire M132B attaches to from the ECU pin 18.
On saturday I cleaned up all the inner wing earth points next to the battery, the main earth on the gearbox attached to the battery neg and also the 10 ml bolt head earth on the N/S Chassis leg just forward of the gearbox. Have I missed any other earth's?

When I pulled the corrugated plastic shielding off the ECU loom as it crosses the O/S engine mount, it all crumbled apart! Struggling to read the numbers on the thin wires!! Will need to resort to a magnifying glass.

If I was to run a temp bypass wire to earth on M132B, would I just bare a bit of insulation and attach a croc clip wire as access to the ecu plug itself is difficult?

Cheers
User avatar
KennyW
Donor 2020
Posts: 2171
Joined: 17 Jan 2006, 22:22
x 66

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by KennyW »

Alan,

I think it is located on the inner wing and you have said you have cleaned up the contact.

I had a similar problem on my TD a few years back and it was one of those pesty connecting blocks smply bypassed same and it ran with no problems.

I'll check through the old thread and check.

Kenny
ecohouse1
Posts: 283
Joined: 29 Aug 2011, 12:44
x 3

Re: Xantia 99 1.9 TD immobiliser problem - lexia results help needed

Post by ecohouse1 »

Thanks Kenny, can you remember the connector responsible. I can try that next!! Cheers