Fitting a virgin BSI to a C5 SORTED

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

wheeler
Posts: 5268
Joined: 21 Sep 2002, 19:07
x 316

Re: Fitting a virgin BSI to a C5 SORTED

Post by wheeler »

Stempy wrote:Not really that much of an expert, maybe a Lexia session would show something up. You could at least measure the signals from the sensors. It's possible that a replacement instrument cluster wont work without being matched to the vehicle.
No need for programming the instrument panel on a Picasso.
old-un77
Posts: 166
Joined: 25 Nov 2014, 20:58

Re: Fitting a virgin BSI to a C5 SORTED

Post by old-un77 »

the display unit IS compatible with the car, all else works........... the sensor change /diagnostic cost me over £130, and was suggested he could "put the problem right" for getting on for another £500.......................by swapping the bsi.....or maybe the ecu as well.......diags, just shows something like speed sensor fault.....
2nd opinion agrees that the sensor is not seen........but sensor wiring is ok

edit
the instrument/radio panels haven't been interfered with, no kiddie trouble, otherwise the car runs like a dream, obviously have no live consumption figures......just full-empty estimated Mpg, which isn't far out........
Stempy
Posts: 1626
Joined: 27 Feb 2004, 00:21

Re: Fitting a virgin BSI to a C5 SORTED

Post by Stempy »

As an update on previous questions and issues I have discovered that my C5 has variable PAS which uses a mechanical pump and is controlled within the BHI. I used the Lexia to test it today and it's working fine.

The fault on the front height corrector seems to have been a poor connection at the sensor. I unplugged it, cleaned the terminals and replugged. Cleared the fault on the ECU and it's been fine so far. The aircon is now fine bar the external mirror sensor which has been ordered, after clearing the blower fault it hasn't returned.

The only faults left now that I'm not sure about are on the instrument panel which tells me that engine speed, vehicle speed and coolant temp sensors have returned an incorrect value, and states 'fault caused by another ecu', and the alarm which says the ultrasonics are duff so I guess new transponders would sort that out.

Also, I wonder if anyone knows why the speed related volume adjustment doesn't work? It never has so maybe it's not an option, but it is in the radio menu and there are several 'laws' you can progamme it to in the Lexia. And the radio also shows a permanent fault at the aerial input, no idea what that's about as it works perfectly well.
Hell Razor5543
Donor 2021
Posts: 12008
Joined: 01 Apr 2012, 09:47
x 1512

Re: Fitting a virgin BSI to a C5 SORTED

Post by Hell Razor5543 »

I recall a post where somebody found that the soldering within the sensor was an issue, as the pins are square and the holes (on the circuit board) are round, and somewhat lacking in solder. I know that I mentioned it (and had a link) in trainman's thread.

I have the same issues with the instrument panel and the aerial (apparently water can get into the aerial base and cause some grief).

EDIT; Found the link. The photos aren't there any more, but the text explains it very well;

http://www.frenchcarforum.co.uk/forum/v ... 9&p=356736
Last edited by Hell Razor5543 on 23 Jan 2016, 20:08, edited 2 times in total.
Stempy
Posts: 1626
Joined: 27 Feb 2004, 00:21

Re: Fitting a virgin BSI to a C5 SORTED

Post by Stempy »

Do you know where the sensor is located? Is it a sensor that is just for the radio?
Hell Razor5543
Donor 2021
Posts: 12008
Joined: 01 Apr 2012, 09:47
x 1512

Re: Fitting a virgin BSI to a C5 SORTED

Post by Hell Razor5543 »

I was on about the height sensor. Sorry I didn't make that clearer.
Stempy
Posts: 1626
Joined: 27 Feb 2004, 00:21

Re: Fitting a virgin BSI to a C5 SORTED

Post by Stempy »

Damn, my extra sensory perception failed again.