C5 HDi 2005 Power Steering

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

birstall
Posts: 104
Joined: 07 Apr 2006, 19:20
x 1

Re: C5 HDi 2005 Power Steering

Post by birstall » 10 May 2015, 21:48

OK - new developments.

I reset all the error messages to start with as the mechanics didn't disconnect the battery negative lead before working on the car
Started the car stationary and bounced the front end up and down resulting in a lot of beeping and power steering faulty messages.
Then got the lexia back on it.
However, when turning the ignition key (but not starting the engine) the power steering pump came on. It doesn't normally come on until you actually start the engine.
Then got the following fault messages:

BSI
No communication with radio ECU - Not characterised.

Suspension
Permanent fault
No communication with the steering wheel angle sensor incorrect value received.

Power Steering
No dialogue with ECU during initialisation. Validate for new test or press return key.

Deflation Detection
No dialogue with ECU during initialisation. Validate for a new test or press return key.

I couldn't check the error messages on the power steering or deflation detection because there was no communication with the ECUs.

They were there when I checked the messages before but seem to have gone after the reset and the bouncing up and down of the car.

Has anyone got any idea what's going on?

birstall
Posts: 104
Joined: 07 Apr 2006, 19:20
x 1

Re: C5 HDi 2005 Power Steering

Post by birstall » 11 May 2015, 16:31

OK, the electrician is going to have another look at it tomorrow.
He thinks that it's the same pump controlling both the suspension and the power steering.
Obviously not checked the power steering pump or wiring then and not had the bumper off.
Disappointed.

birstall
Posts: 104
Joined: 07 Apr 2006, 19:20
x 1

Re: C5 HDi 2005 Power Steering

Post by birstall » 13 May 2015, 13:07

I've just had an idea.
I didn't have a problem with the power steering until the battery went flat when the EGR valve packed in.

When the car broke down, I let it roll backwards to get me onto the hard shoulder and I turned the starter motor to help me steer the car (I think that the pump kicked in when the engine turned over briefly or maybe it was running with the starter motor).

The fault only started to come up after the EGR valve was replaced and I got the car back from the mechanic.

So maybe the steering wheel angle sensor just needs re-calibrating? I'm not sure how to do this but saw a post somewhere explaining how to do it with a Lexia. Might as well try this next.

The auto-electrician has had another look at the car. He says he is 100% certain that it's the angle sensor that's the problem and suggests replacing the COM2000 unit.

birstall
Posts: 104
Joined: 07 Apr 2006, 19:20
x 1

Re: C5 HDi 2005 Power Steering

Post by birstall » 29 Jul 2015, 21:18

An update on this topic: the problem really was the COM2000 unit, except it was a COM2003 unit.
I got the serial number from the auto electrician and managed to buy a good second hand unit from France on ebay for £95.00 including postage.
The auto electrician fitted the unit. This involved deprogramming the old unit from the car and then reprogramming the new unit to the car.
He charged me £90 for the initial diagnosis and a further £100 for fitting the replacement.
So an expensive repair, but it works perfectly now.