C5 X7 2-in-1 navigation tutorial

This section is where Audio / Telematics Posts will be placed temporarily

Moderator: RichardW

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

I wouldn't know - it's a third party add-on fan - so probably taken feeds from the unit's live supply.

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

I couldn’t find a thing for the mounting of the fans. Therefore I need just one info. What has to be cooled, the unit or the display? If I will find out this info, I will mount directly a cpu fan for 12V and that’s it.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

The issues were to do with the RT6 unit not the display. The chips got a bit hot - the unit uses flash memory instead of a hard disk.

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

I have found an unit which is disassembled. And I see there a fan inside.

So you are sure that the cooling fans are for the unit and not for the display? I was thinking that those fans are creating an air flow for both.
Attachments
863BC77A-2211-4F07-94B4-08A81DA09377.jpeg

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

I've already said - that link is for the RT3 system (RT3 Navidrive - I used to have one). That fan unit was part of the system - it does not exist in the X7.

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

That’s bad, so bad. Now it’s clear, a fan is needed on the rear side of the unit. The display has no heater, therefore a fan will solve nothing.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

You have to remember Vlad that the article is about converting an RD4 to the RT3 Navidrive, so the parts relate to the RT3 not the RT6. There is no separate fan unit for the RT6 or the display - this is where other people are using a hybrid of information from different systems and it confuses people.

So the RT3 system did have a factory fit Fan - it was a different design remember, and in the C5 the Display was vertically on top of the dashboard - not in the centre of the console.
RT3.PNG

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

Very well explained. Indeed all this represents a hybrid of information which are most if them false and create confusion. And if a fan shall be present anywhere and it’s not, normally I shall have an error stored. Lexia or Diagbox should tell me. To avoid any risk, I will not use navigation until everything will be clarified, just music from USB or Bluetooth streaming and radio. I just hope that my Lexia will recognize RT6 to be able to write my VIN inside and avoid the beep beep.

One more thing, even if this article is referring to RT3, Vborovic is mentioning about a fan for RT6:

“The RT6 has an active cooling (fan), which makes some noise compared to the RNEG, but that isn't bothering me, at least I know it will be slightly cooler than the previous unit (which would heat the lower compartment a lot after 2+ hours of drive ...).”

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

Yes, the RT6 does have a fan, but it is already built into the unit as in your last picture. There is no separate fan part.

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

Here is the vin code from the seller. Can you please check if the wires are fine? Thank you.
Attachments
35A97450-41C7-4730-A4FE-3AA1B01087DD.jpeg

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

The same as before from what I can see.

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

Great thanks. I just find out that the connector of the unit does not have three pins for the display. I will add manually. Other thing is that on my unit there is not connector for USB, but I have usb anyway. And on Rt6 there is a connector for usb, dedicated, which will be left empty now. Will my usb work throug the big connector? Fakra C as in this article.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

Vlad, can you please clarify - I thought you said you had already received the kit (display and RT6 and cables)?

viewtopic.php?f=48&t=48421&start=285

What connector are you talking about now?

I'm going to have to look at your original wiring diagrams again and try and match off what you currently have and what I 'think' you are getting. The problem you have is that you have an independent telematic unit and hands free telephone kit in your car already. You also have the single USB port (there are about 6 options for this alone!), so trying to fit what you have into the RT6 that handles most of these functions itself is the difficulty. The added problem is that the independent telematic unit you already have connects a lot of the kit together - the VIN of the donor car does not have this, nor does it have a hands free kit, and probably has a different USB setup.

The best thing I can do to try and help you is to pull off your current wiring diagrams and try and match up where these might be on the newer kit - but you are the only one that can physically check these connections. Have you also considered the GPS antenna?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: C5 X7 2-in-1 navigation tutorial

Post by GiveMeABreak »

Vlad - This is going to be too big a job for me with my other commitments - so I am going to send you the Circuit diagrams of the AUDIO system for your current car and the donor car. Obviously, because your current car does not have Sat Nav, there is nothing to show. I will send you in addition the Telematics diagram for the RT6 Donor car - but as I mentioned, the wiring diagram may contain options not actually fitted - and therefore you'll have to try and work it out.

For the main equipment components, look here on our Wiki site, where I have put a list of many of the codes to help:
https://frenchcarforum.co.uk/wiki/Elect ... ring_Codes

vlad2004v
Posts: 82
Joined: 27 Sep 2017, 13:30

Re: C5 X7 2-in-1 navigation tutorial

Post by vlad2004v »

Hello Mark. I am sorry that I couldn’t answer you yesterday. I went out from the office very late and took the Rt6 system from the delivery company. Thank you very much for the diagrams, I will analyze them today.

What I did yesterday also was to unmount my system from the car and replace it with RT6. First I have removed the display and replace it with the new color display, then prepare the harness which went from display to the unit. Also I have mounted a separate GPS antenna. After that I have mounted everything back and plug in the battery.

After turning on the ignition, the navigation has started, It can see 6 satellites, the music is fine, radio also fine, but of course beep beep noise because of the ViN. For this I have to update my Lexia because mine has no RT6 included in the menu.

As first problems that I have seen:

1. Microphone not working (I have tried to make a call and I am not heard).
2. USB not working
3. Gray connector from the unit is free, I had not a connector like that on the car. Mine was coming with the usb wires directly in the big connector from the unit. I don’t know the exactly wires, probably part C.
I have the original connector from the doner but I don’t know if I shall link the wires with a USB port or something. Mine from the hand rest is not working anymore.
4. In the morning, today, I drove about 20 km and everything went fine, except the beep beep noise, but after I stopped the car and parked, I have turned off the ignition and remove the key. After that I have started the music, and in a few moments, on the screen the following message has appeared:

Due To a problem on the vehicle, the unit cannot work correctly.

And the navigation has stopped. After turning On the ignition and waiting 1 minute maximum, the navigation has started.

What do you think, is there a solution for every point mentioned above?

Thank you very much for your involvement!