V6 Xantia......... the beginning of another adventure

Tell us your ongoing tales and experiences with your French car here. Post pictures of your car here as well.

Moderators: RichardW, myglaren

KP
Posts: 3980
Joined: 10 Jul 2006, 12:11
x 7

Re: V6 Xantia......... the beginning of another adventure

Post by KP »

Don't worry, just whenever is best for you drop us a line and pickit up on the way over to save you storing it for ages as they are just in my garage waiting to head over to Paul's :)
Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: V6 Xantia......... the beginning of another adventure

Post by Trainman »

Here's a picture of the split pipe on the Cruise Control

Image
KP
Posts: 3980
Joined: 10 Jul 2006, 12:11
x 7

Re: V6 Xantia......... the beginning of another adventure

Post by KP »

That looks like it was in a lovely place to find :(

I can't understand why when the engine was ecu controlled and the gearbox to a certain extent why they didn't just use electrical input to control the cruise instead, good old french have to find the hardest way to so things sometimes!!!
Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: V6 Xantia......... the beginning of another adventure

Post by Trainman »

KP wrote:That looks like it was in a lovely place to find :(
Not the words either of us used............. :roll:
citroenxm
Posts: 7972
Joined: 31 Dec 2004, 00:10
x 49

Re: V6 Xantia......... the beginning of another adventure

Post by citroenxm »

Technology it was called Will..

As Bosch from Late 1999 had then incorporated Cruise Control INTO the cars ECU! So any Xantia hdi from W reg onwards has actually got the cruise built into the ECU, they just couldn't be bothered adding the 7 extra wires and the brake switch and clutch switch and enableing it in the ECU.

you can do it with Lexia, but you need to wire it all in, of which Ive done bit still not got a later ECU to try it.

This is why ALL later PSA HDi stuff is simple to add Cruise by simply fitting the cruise stalk. Very simmilar to the 2.5 TD XMs
KP
Posts: 3980
Joined: 10 Jul 2006, 12:11
x 7

Re: V6 Xantia......... the beginning of another adventure

Post by KP »

To be honest it was just lazy of them not to incorporate it from the start I guess as the 2.5's had it from their release date :)

I can see why they wouldn't have done the wiring as the xantia was soon to be retired and the hdi only put in it to help get the mpg up and co2 down and the cost of doing a new loom to incorporate it was just too much hassle :/
citroenxm
Posts: 7972
Joined: 31 Dec 2004, 00:10
x 49

Re: V6 Xantia......... the beginning of another adventure

Post by citroenxm »

Absolutley Will, thats what I was trying to say above. Too late in the Xantia Production to ADD an extra operation on creating the Harness from the ECU plug to the inside of the car on various parts! I know how that works - did harness for 16 years! Even a postion change or 2 wire addition meant S h i t loads of mods and time!
KP
Posts: 3980
Joined: 10 Jul 2006, 12:11
x 7

Re: V6 Xantia......... the beginning of another adventure

Post by KP »

Tis still a shame mind! Can see why some after market ones do well in other countries :)
Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: V6 Xantia......... the beginning of another adventure

Post by Trainman »

Well the Xantia has 'spit it's dummy again! Flaming thing wouldn't start this morning. Ignition on and absolutely nothing, all the dash light came on as per normal but no starting, hmmmm..... or words to that effect.....

Then I think to myself 'I wonder.......' so I tried moving the gear selector, took it down the gearbox and back into park. Then turned the ignition off and back on, and she fired first time. I'm now wondering if the longstanding intermittent fault is the gear selector switch.....

Thoughts?
KP
Posts: 3980
Joined: 10 Jul 2006, 12:11
x 7

Re: V6 Xantia......... the beginning of another adventure

Post by KP »

Only way to test really is get another one on there or have a lexia running at the same time to see what the switch is saying :( intermittent faults on anything are a big bear in my life so I feel your pain :)
Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: V6 Xantia......... the beginning of another adventure

Post by Trainman »

I think I have one the garage, courtesy of a certain gentleman from North Wales, I will have a look over the week and report back
citroenxm
Posts: 7972
Joined: 31 Dec 2004, 00:10
x 49

Re: V6 Xantia......... the beginning of another adventure

Post by citroenxm »

Steve.

If it happens again, Rather then scrolling right through all the gears and trying, try instead foot on brake, ignition on, enter code, then HOLD the key in the start position, then while you do that move the gear lever A LITTLE bit, like partly into R then back to P..

This could be a sign of slightly stretched OR out of adjustment selector cable. This telling the gearbox its still in R, there fore inhibiting the starter, that or a possibly bad connection on the starter relay.
User avatar
xantia_v6
Forum Admin Team
Posts: 7840
Joined: 09 Nov 2005, 23:03
x 501

Re: V6 Xantia......... the beginning of another adventure

Post by xantia_v6 »

The selector switches usually fail with shorts between the contacts or to ground, so maybe not related to your current problem.

It is worth checking the cable adjustment, note that on the V6 there is also a relay between the transmission switch and the starter solenoid.

Re the cruise control comments above, on a petrol engine, the cruise control has to move the throttle, which the ECU doesn't do on the Xantia.
citroenxm
Posts: 7972
Joined: 31 Dec 2004, 00:10
x 49

Re: V6 Xantia......... the beginning of another adventure

Post by citroenxm »

Re cruise. Yes on the vacuum systems it does ... but on the hdi and newer ones it's completely electronic and there is ZERO throttle movment
Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: V6 Xantia......... the beginning of another adventure

Post by Trainman »

citroenxm wrote:Steve.

If it happens again, Rather then scrolling right through all the gears and trying, try instead foot on brake, ignition on, enter code, then HOLD the key in the start position, then while you do that move the gear lever A LITTLE bit, like partly into R then back to P..

This could be a sign of slightly stretched OR out of adjustment selector cable. This telling the gearbox its still in R, there fore inhibiting the starter, that or a possibly bad connection on the starter relay.
Paul, this happened again and he I her day and I tried what you suggested....... nada, nothing, zilch :roll: I ended up moving the gear 'lever' up and down the box 3/4 time before it would start. I'm thinking it's got to be electrical.........

Yesterday, I swapped the bulbs back to the original ones as the Xenon's I had in I wasn't happy with, plus they started blowing, so now I'm considering what the best option is, I have to decide if I want to go down the HID route, which means fitting washers, from scratch or whether to do.some other mod like maybe upgrading to candles. The lights.on a series.one car are extremely poor, it has got me thinking if there could be an LED option......... time for fleabay.........