Pauls HDI Xantia Exclusive.

Tell us your ongoing tales and experiences with your French car here. Post pictures of your car here as well.

Moderators: RichardW, myglaren

User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1780

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by CitroJim »

Was the slave cylinder OK Paul?

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by citroenxm »

Yup.. perfectly fine..

User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1780

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by CitroJim »

citroenxm wrote:Yup.. perfectly fine..

You was lucky :-D

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by citroenxm »

STILL waiting for the clutch to arrive... :x :x :x

User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1780

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by CitroJim »

citroenxm wrote:STILL waiting for the clutch to arrive... :x :x :x
Coming from Mars is it Paul?

Well at least you've just answered the question I asked you over on the other forum!!!

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive......Finally has broken..

Post by citroenxm »

Im beginning to wonder Jim!

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by citroenxm »

Well, got me clutch in after having to buy a local one... however, got a FULL refund for the Valeo one..

Back together and all up and running.

The clutch supplied was a "National" type. Nice and light on the foot now...

So, off I trot, and then the Red Lights come on... I assumed low level from all the weight as I had put in Hydraflush..

Topped it up.. ok.. Then red lights again.. By now I had got to mums.

Anyway. Moral of the story, something has popped on the suspension curcuit by the hydractive block. Its either the electro valve or a pipe, but Im thinking pipe as last MOT my mot man said rusty pipe at the back, have it seen to, which I didn't.

So after only 30min drive she is laid up at mums.

Online
RichardW
Forum Treasurer
Posts: 9536
Joined: 07 Aug 2002, 17:12
x 456

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by RichardW »

Bad luck Paul :cry: Sometimes, one lot of attention is just not enough for them!!

Any tips on the clutch job? Did you drop the box right out? I'm wondering if I might be down the same road sooner rather than later. Pretty sure that biting point has come up significantly on mine in the last few k miles, and it feels a bit 'mushy' - difficult to describe, but I've definitely noticed a difference....

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by citroenxm »

I wouldn't wish a HDi 110 clutch job on anyone!!

The ML type box (Hydraulic clutch change box, I forget the code for them now) is a bigger box then the BE box in the XUD and HDi 90 cars, and same amount of engine bay space, and therefore makes VERY tight space, and vurtually NO space to work when the box is away from the engine.

My car was the First exclusive HDi Ive done, others have been LX and SX models, and so the front centre sphere and hydractive block DO get in the way of the box shuffle, and NEEDS to come away.

NO I do not drop the box out, its one heavy Mother F of a box to try and lift up again!!! I use a jack to help hold it up.

After a lot of shuffleing and farting around I could only JUST get the box away from the engine, but still had a squeeze to get the pressure plate out. However, if your release bearing is still attached to the pressure plate, then it be an even harder task, as the box wont come away far enough for the input shaft to come out of the release bearing. All the 110 HDi clutchs Ive done so far have all had failed release bearings, where the release bearing has stayed on the input shaft meaning the pressure plate just cleared the input shaft after undooing, after a bit of box shoving.

I really detest hdi 110 clutch changes, and didn't really want to do this one. But was forced to due to finanical reasons which have not eased at all..

Hell Razor5543
Donor 2021
Posts: 11682
Joined: 01 Apr 2012, 09:47
x 1398

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by Hell Razor5543 »

The 'box is an ML5T.

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by citroenxm »

Well im right then... and didnt look in a book or anything..

User avatar
CitroJim
A very naughty boy
Posts: 43889
Joined: 30 Apr 2005, 23:33
x 1780

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by CitroJim »

Oh Paul, I'm so sorry to hear this :( Bloody typical isn't it :twisted:

I've assisted in a couple of Activa and HDi110 clutch changes now and yes, they are a bit of fun.

Hope the leak is an easily solved problem...

citroenxm
Posts: 7955
Joined: 31 Dec 2004, 00:10
x 46

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by citroenxm »

Well, found a leak culprait today!

And I insist! I HATE s**t!

If it wasnt for hydractive she wouldn't of leaked! Simple as. It wasn't a pipe, it was the damm electro valve on the rear!

Yes you guessed, rotted through the hex section to the seal, just a tiny hole past the seal... bloody stupid s**t.

But there we are, sorted now. Another valve for Citrojim to repair!

Untill the next glitch now.............................................

Trainman
Donor 2018
Posts: 2583
Joined: 21 Aug 2009, 11:58
x 12

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by Trainman »

Good stuff Paul, back on the road again........

User avatar
Chris570
Donor 2020
Posts: 1454
Joined: 12 Dec 2009, 15:10
x 5

Re: Pauls HDI Xantia Exclusive.Finally has broken And still

Post by Chris570 »

citroenxm wrote:Well, found a leak culprait today!

And I insist! I HATE (-expletive removed-)!

If it wasnt for hydractive she wouldn't of leaked! Simple as. It wasn't a pipe, it was the damm electro valve on the rear!

Yes you guessed, rotted through the hex section to the seal, just a tiny hole past the seal... bloody stupid (-expletive removed-).

But there we are, sorted now. Another valve for Citrojim to repair!

Untill the next glitch now.............................................
I have the same leak!

at least it's sorted :)