My "love" of all things xantia...and Xm...and Cx..

Tell us your ongoing tales and experiences with your French car here. Post pictures of your car here as well.

Moderators: RichardW, myglaren

User avatar
DickieG
Monaco's youngest playboy
Posts: 4896
Joined: 25 Nov 2006, 10:15
x 15

Post by DickieG »

Koukku wrote:Looking good. That rear spoiler really makes a difference. :)

Any pics of the rear mudflaps? I don't think I've ever seen those fitted on a Xantia. I have extended front mudflaps on mine though, courtesy of the previous owner... not the pretties things, but I guess they help keep the paint on the sills intact.
These are genuine Citroën 'Contour' mudflaps which wrap around the car body
Image

Image

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Well recently i have as always been increasing the list of things to do to the car, but i need to be revising for uni too!

I have done the 6k oil change, i really should just as a treat buy a new o ring for it one day!

I ordered a new cheap dryer bottle as the cit dealers wanted 94 quid :o
i got mine for £36 and its so cheap they havnt even bothered to put a sight glass on it! I have also got a second hand compressor coming off of a 2001 c5, so when its done the air con WILL work!! :twisted:
I have also put my inline glow plug fuel heater on, just need to put a switch in the dash now, should increase the mpg a bit!

I have also bought 5l of lhm ready for a swapsy, i wont be hydroflushng it ill do that next time methinks.

I havnt managed to do any of this as my dads transit has been playing up so had to drop the tank on that and replace the fuel filter (it makes you appreciate how much room there is in the xantia engine bay!) and ive never seen such a worn drive belt as is on this van!
I then had to go over to where my bike is suposedly being fixed and fix one of the problems myself!

During my next post i hope to be very cold from sitting in my car at 4 degrees just to show the air con works!

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Well In my last post i said i would be sitting in my car with 4 degrees c air con. Sadly this is not the case!

However i have a new compressor for just £10 ( the one from the c5 was damaged apparently!) and have cleaned it up. With lots of advice from Jim at the excellent DSM rally i went fault hunting, then with some more advice from admiral51 i think i have it sussed! :D

I believe the hp/lp sensor is knackered, and that the compressor or a bearing within is going the same way!
So rather than replacing one component, i will replace the drier unit, the compressor and the switch! :o

Also looking under my car i have noticed a couple of seriously rusty hydraulic pipes!, however seen as the scrap yard i got the compressor from has an almost identical xantia, i think i might be whipping some pipes off of it! - if anyone can think of bits they need and will be attending ccc national, let me know! (so long as its will fit in my boot!).

The DSM rally was brilliant! Jim fell in love with tractions (even though we observed one break down repeatedly lol) whilst i fell in love with the finger eating DS!! one day.....

User avatar
CitroJim
A very naughty boy
Posts: 43864
Joined: 30 Apr 2005, 23:33
x 1709

Post by CitroJim »

Hi Dave,

What pipes did you find rusty? That's very unusual.. It' a result of how they went absolutely crazy with salt this winder; we should all submit claims on our councils for damage incurred :twisted:

That'll make sure the aircon is a good-un after all that work.

If the Xantia in the breakers is a VSX or Exclusive, I'd be keen to get hold of the front Hydractive sphere block :wink:

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Im not sure what one it was, definatly the pipes to the front brakes looked suspect, put fromt he front accumulator there is a high pressure rubber hose that then becomes a steel pipe, the pipe is very very rusty!

The car is a V reg silver 2.0hdi, so sadly not exclusive :( , any other bits let me know!

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Well today has been manic!

This morning i took the old compressor off and with some difficulty i put the new(ish) one on, i then replaced the drier bottle.

That was the easiest bit, the hardest bit was waiting at kwik-fit for it to be re-gassed. Eventually after many hours it was done! The temperarature was 10.8 degrees and condensation had formed on the pipe away from the compressor, so all good it seems!

I will be going back to the scrapyard to get another compressor in reservem as the one in the xantia looks almost new (and the old one is in the boot!) im getting that one for £25.

Hopefuly ill also get the belly pan, as mine is broken in many places!
I will also get the hydraulic pipe that has rusted on mine.
Sadly he only keeps cars a week before weighing them in, so i need to be quick!

red_dwarfers
Donor 2020
Posts: 2525
Joined: 29 May 2008, 15:59
x 19

Post by red_dwarfers »

Glad to hear the AirCon is working fine!
How much do QuackFlat charge for a leak test and regas?

Regarding those rusty pipes of yours Dave, whilst tinkering with the underbelly of the rear of my Xant this afternoon/evening I took a look at the pipes and couldn't see much wrong with them, all still nice and black with a touch of rust on the unions so I needant be that worried at the present :D

admiral51
Donor 2019
Posts: 2247
Joined: 24 May 2007, 10:11
x 250

Post by admiral51 »

Well done Dave :D :D :D

Does this mean i can abandon my crawl through the loft looking for the switch........couldnt find it yesterday and so it wasnt posted today :oops: :oops: :oops:

Mind i have found a n/s/f wing mk1 in light blue a few cooling fans a condensor and intercooler from a 1.9td .......... ill stop there and just shut the loft hatch :lol: :lol:

Colin

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Lol, sounds like you have some random stuff in your loft Colin, yeah looks the switch wont be needed after al thanks for the offer though :) l! Im sure in the future someone/you will need it though, thats what i say about all my horded parts.

Its mainly one pipe that looks really suspect, and id rather be safe than sorry (probably just being paranoid though!) :?

Crap fit (with Amazingly long waiting times- 4 hours today :evil: ) charge 45 quid, and if you watch them do it the machine tells you exactly how much was taken out and how much put back in!

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Ill certainly try mike!

red_dwarfers
Donor 2020
Posts: 2525
Joined: 29 May 2008, 15:59
x 19

Post by red_dwarfers »

admiral51 wrote: Mind i have found a n/s/f wing mk1 in light blue a few cooling fans a condensor and intercooler from a 1.9td .......... ill stop there and just shut the loft hatch :lol: :lol:

Colin
When I was digging out my camping gear for the DSM rally I realised just how much of a soft spot I have for 80s and 90s computing gear :oops:
It gets too much when you've got nearly three times your own height in 3 1/4" floppies and tapes laid flat :oops:

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Well i went to scrap yard, sorry mike didnt get any pipes off even the one i wanted! it was too hot and difficult!

I did get for 40 quid, another compressor, an airbag module, steering wheel (im sure someone wanted a mk2 wheel) indicatir and wiper stalks, driver airbag and ribbobn type thing that jim reckons might be whats wrong with mine. plus a valeo blower motor.

All to go to my spares box!

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

Well, Jim (and his lexia) is proved right again, i replaced the ribbon thing connected to the airbag, and finally the airbag light is off!!! Thanks Jim!! :P

Does anyone know if its possible to fix the old ribbon, or should i bin it instead of hording it?

I have also got round to fitting the new stainless steel strips to the door plastics, they look excellent however i have the sam niggle as kev in that the fornt and rear bumper bits look dull now! :?

My next project is to fit a 3rd 12v socket in the car!!

red_dwarfers
Donor 2020
Posts: 2525
Joined: 29 May 2008, 15:59
x 19

Post by red_dwarfers »

davetherave wrote: Does anyone know if its possible to fix the old ribbon, or should i bin it instead of hording it?
If the wire is broke, its not really worth fixing, though as its such a small unit its hardly worth chucking :lol:
davetherave wrote: I have also got round to fitting the new stainless steel strips to the door plastics, they look excellent however i have the sam niggle as kev in that the fornt and rear bumper bits look dull now! :?
Did you get an instruction sheet and pics Dave?

You've just reminded me that I've got to edit the bumper trim video :oops: Im caught up in a lot of things at the moment, have'nt even got around to sorting out the CD Changer cable yet :(

It SEEMS that the stealer stocks the other trims but it would be nice to get proper stainless steel ones.

davetherave
Posts: 880
Joined: 01 Apr 2009, 21:06
x 1

Post by davetherave »

I got an instruction sheet but not pictures, i will have a think about the front and rear, possibly plastichrome!