- DS4 heater not working

This is the Forum for all your DS Automobiles Technical Questions, Problems or Advice.

Moderator: RichardW

Ammental
Posts: 4
Joined: 20 Sep 2018, 14:00

Re: New - DS4 heater not working

Post by Ammental » 20 Sep 2018, 14:13

Hi thanks for accepting me ,not sure if this is the right place to post but....
Here's the problem my DS4 2013 plate heater is not working ,I have checked the fan motor that works fine( hooked direct to battery) ,replaced the speed controller resister ,and even replaced the main control panel .and still nothing.
I have read that on the C4 there is 2 wires In the fuse panel you can put an inline fuse in to bypass however I don't have these wire on the DS4 .
Can anybody help me as I'm getting it in the ear from my wonderful wife lol .

Ammental
Posts: 4
Joined: 20 Sep 2018, 14:00

- DS4 heater not working

Post by Ammental » 20 Sep 2018, 14:44

Hi thanks for the add,looks like I may get the help I need here.
So my problem is my heater is not working on my 2013 DS4 ,I have checked the fan motor (hooked up to a battery works fine ) changed the speed controller/resister and even changed the main control panel and still nothing .
I read on here that the C4 you could bridge the 2 wires at the fuse box ,but the DS4 doesn't have those wire ,or if they do I can't find them .
So if anyone could help or point me in what to try next id much appreciate it as I'm getting it in the ear from my lovely wife.
Thanks in advance guys/girls

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 15848
Joined: 15 Sep 2015, 19:38
x 1471

Re: - DS4 heater not working

Post by GiveMeABreak » 20 Sep 2018, 15:50

What exactly is the problem? Is it the fan blower motor that is not working? Don't get the air heating resistance unit mixed up with the blower control module, they are 2 separate devices.

What's your VIN number. I'll see what I have.
DS4 Heater.PNG
In the diagram above item [2] is the Blower Control Module - that controls the fan speed.
Item [1] Is the Air Heating Resistance and provides supplementary heating to the passenger cabin when requested and when the temperature / engine is cold.

Ammental
Posts: 4
Joined: 20 Sep 2018, 14:00

Re: - DS4 heater not working

Post by Ammental » 20 Sep 2018, 16:18

Hi thanks for the reply the fan won't kick in at all .all the lights come up on the dash but won't blow any air ,I have changed part no 2 blower control module in you diagram I have also tested the fan it's self and that works ,I also changed the actual control panel in the dash and still nothing , confused as to what number 1 dose .
My vin is VF7**************[VIN obfuscated, can be read by forum staff]
Any help would be fantastic thank you

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 15848
Joined: 15 Sep 2015, 19:38
x 1471

Re: - DS4 heater not working

Post by GiveMeABreak » 20 Sep 2018, 17:17

Number [1] is the heating resistance - I explained in my previous post - it is basically just heating elements to provide some warmth for the cabin until the engine warms up. It has nothing to do with the blower motor itself.

Where did you get the Blower Control Module from? Some cheap ones off the bay are notoriously poor quality and dead on arrival in many cases.

Compare with an original replacement - the correct part number for this module should be:
Part Number: 6441AF and is £127.69 inc. VAT from Citroen.

However, before replacing that again....
It may also be worth checking the fuse - it is in the Power Supply Protection and Management Box (BPGA) in the engine bay probably near the battery somewhere - but not the engine fuse box - that is the PSF1.

It is Fuse number 10, is 40 Amp and controls the Air Conditioning Blower and nothing else - so if this is at fault you won't get didly from the motor. As you know the motor is working via a bypass - this is your next likely culprit I suspect. Change the fuse anyway as a visual isn't really any good.
This is the Fuse Layout of the BPGA unit
DS4 Fuse.PNG
This is what it should look similar to:
Ds4 Fuse B.PNG
Ds4 Fuse C.PNG

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 12 Aug 2019, 12:39

Hi. It looks like I have the same problem as above (fan motor not running but display led's etc working. Re the BPGA box -- Is this the unit that is fixed to the battery itself, or the large fuse box on the N/S wing with miniature spade fuses and what looks like an ECU inside also? It's just that I can't see anything that resembles the diagram above.
Thanks.

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 15848
Joined: 15 Sep 2015, 19:38
x 1471

Re: - DS4 heater not working

Post by GiveMeABreak » 12 Aug 2019, 13:31

Is this for the DS4 too? Best pop your VIN up and I’ll check the location for your vehicle if relevant.

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 12 Aug 2019, 13:57

Hello. Thanks for your prompt reply. I'm not very savvy with P.C.'s and forums etc, so please bare with me. it is for a DS4, and I believe that is the unit on top of the battery. Manged to disconnect it ant the said fuse is on the underside. Checked continuity and that's ok. VIN is VF7**************[VIN obfuscated, can be read by forum staff]. This fault occurred on my way on hols for a week, so I have limited access and tools. Happy Days eh???
:lol: :lol:
Last edited by GiveMeABreak on 12 Aug 2019, 17:20, edited 1 time in total.
Reason: Corrected 'B' in VIN for an '8'

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 12 Aug 2019, 15:31

Is it now likely to be the blower control module? And if so, do you know where this is located on my vehicle?
Many Thanks,
John.

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 15848
Joined: 15 Sep 2015, 19:38
x 1471

Re: - DS4 heater not working

Post by GiveMeABreak » 12 Aug 2019, 17:51

Hi John, you have a different system to the previous DS4 poster (Ammental).

Your setup is below:
DS4 Heater Detail.PNG
Although the Blower Control Module (2) is the same - these will often default to all or nothing speeds when the resistor is shot. The giveaway is of the fan only works on full speed or nothing.

I have the following information concerning this system - so can you confirm if the temperature display in digits is stuck at the same setting regardless of increase or decrease?

At initialisation, if a permanent failure of a button has been recorded, the associated button is in down-grade mode and the confirmation time has lapsed, then provided the fault is still permanent, the button remains in down-grade mode - if not, it becomes operational again.

Function: "Driver’s side temperature"
In down-grade mode, the temperature reference value is fixed (and displayed) at the centred reference value.
A press on + or - for the blower has no effect.

Function: "Front passenger’s side temperature"
In down-grade mode, the temperature reference value is fixed (and displayed) at the driver’s reference value.
A press on + or - for the blower has no effect.

Function: "Blower"
In down-grade mode, the "blower" function is provided in automatic mode.
A press on + or - for the blower has no effect.

So check if the buttons are ok and not stuck (and that nobody has spilled their coffee). If after turning off the ignition and waiting some time, restarting and the situation is the same, then it has gone into a backup mode by sounds of it.

A diagnostic check with Diagbox may further help identify the problem

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 13 Aug 2019, 09:08

Thanks Marc,
I'll check today and get back to you later.
Regards,
John.

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 13 Aug 2019, 10:08

Hello Marc. Can't believe it. Got in car this morning and everything works fine now. Re your question --- Yesterday when it stopped working, the temperature dials on both sides increased and decreased temperature when dials rotated and displayed normal -- it was just blower motor would not operate, so I can't understand how it's just started working again. I guess at some point it will happen again and then Ill just have to get diagnostic performed on it. Many Thanks for your help.
regards,
John.

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 15848
Joined: 15 Sep 2015, 19:38
x 1471

Re: - DS4 heater not working

Post by GiveMeABreak » 13 Aug 2019, 11:55

Ok, that's good news. What can happen with these systems is that condensation can get into the blower motor bearings, causing them to start to seize over night or other periods of non-use. On vehicles with automatic climate control, the blower motor is started gradually from zero and then slowly increases to the required speed.

Sometimes, the slow start speed of the fan is not enough to get it going - hence no blower speed control. Others here have opted to temporarily shunt the power wire so that the motor is given full power at start an this can free them up again for a while. Obviously it's only a temporary fix and usually happens again - and it's not something you want to leave on - only to get the motor going.

Ultimately it may mean a motor replacement as the bearings on a lot of these blower motors are sealed.

if you raise the inside vehicle temperature for the last mile or so, it should warm up the pipes behind the dash, dry them up and reduce some of the condensation that can form once the engine is switched off.

Johnny C
Posts: 6
Joined: 12 Aug 2019, 12:23

Re: - DS4 heater not working

Post by Johnny C » 13 Aug 2019, 20:40

Thanks Marc. That's good to know.
John.