peugot 306 revving sometimes

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

mitch
Posts: 3
Joined: 22 Jul 2003, 01:19

peugot 306 revving sometimes

Post by mitch » 22 Jul 2003, 01:23

Having probs with my peugot 306xl L reg. When starting up sometimes revs constantly without feet being near the pedals, pulling away from junctions shudders and slows down as if there is not enough power. Garage had a look said it could be something to do with the automatic choke but not convinced can anyboby help.

Jon

Post by Jon » 22 Jul 2003, 13:47

Well it won't have an automatic hcoke as such, being fuel injected, but of course the injection system will make the car run a bit richer when its cold, like a choke would.
You don't say what size engine what you have in your 306 but on most models the problem you describe is usually caused by a sensor being faulty.
The likely candidate is the water temperature sensor which tells the ECU water (engine) temperature so that the ECU can richen the mixture for cold starting/runing. The other sensor which can also cause this erratic revving when cold is the MAP sensor.
If you can give some more details (engine size) and whether the car "clears itself" when its fully warmed up we may be able to help further. If the problem is still there with the engine hot, may be the stepper motor at fault.

mitch
Posts: 3
Joined: 22 Jul 2003, 01:19

Post by mitch » 23 Jul 2003, 00:41

Cheers jon. it's a 306 xl 1400cc and it doesn't clear itself every timeit hit or miss. drove back from Keswick at weekend and when we stopped at services (about 100 miles) it was doing it, can you tell me how much the sensors are if possible
cheers[xx(]

wheeler
Posts: 3766
Joined: 21 Sep 2002, 19:07
x 78

Post by wheeler » 23 Jul 2003, 01:30

my guess would be the stepper motor,provided of course you've ruled out a sticky throttle butterfly or cable.it may be worth removing & cleaning it first and the housing it sits in,dont move the little plunger in or out when cleaning as this will damage it.

mitch
Posts: 3
Joined: 22 Jul 2003, 01:19

Post by mitch » 25 Jul 2003, 01:43

'Aye' It's looking good for the stepper motor idea as it was revving up and down constantly when I had the bonnet open. The throttle cable wasn't moving at all, just sounds like someone is dabbing the throttle every second when the problem gets going
Cheers Craig