406 HDi STOP Warning when Air Cond selected

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

splaaat
Posts: 2
Joined: 01 Jun 2003, 05:05

406 HDi STOP Warning when Air Cond selected

Post by splaaat » 01 Jun 2003, 05:31

Hi Guys,
Hope one of you Pug Gurus can help.
I have a late 1999 406 2.0 HDi with Air Cond and ABS. Whenever I select the Air Cond I get a STOP warning on the dash and the multi display briefly shows an abnormal engine temp warning. As soon as I switch Air Cond off it all goes away. This happens whatever the engine temp is.
I took the car to a Pug dealer and they also informed me that the radiator fan isnt working either as it should automatically start when the Air Cond is switched on. They also said it could take up to a week to find the fault [:0] I've checked and the fan doesn't run when the engine is hot.
Looking at the schematics in the Haynes manual these systems come together in the 'Engine Multifunctional Relay' but it doesn't say where that is located, just that it has a Brown 15 way connector attatched.
My Questions are [?]
Has anyone had experience of this type of fault and what was the cure?
Does anyone know where the 'Engine Multifuntional Relay' is situated?
Does anyone know how to reset the maintenance indicator? (sorry just threw that one in, I'm doing my own servicing and it bugs me to see it there)
Any help would be greatly appreciated.[:)]
Thanks in anticipation.
Splaaat!

Homer
Posts: 1503
Joined: 26 Feb 2003, 11:52
x 14

406 HDi STOP Warning when Air Cond selected

Post by Homer » 01 Jun 2003, 09:45

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by splaaat</i>


Does anyone know how to reset the maintenance indicator? (sorry just threw that one in, I'm doing my own servicing and it bugs me to see it there)
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">
Sorry, can't help with the rest but if it is the same as the Citroens then try holding the trip recorder button in while turning the ignition on (not to start). The display will count up or down or like mine go 10 100 1000 10000
Then let go of the button. Then turn the ignition off and on.

wheeler
Posts: 3811
Joined: 21 Sep 2002, 19:07
x 81

406 HDi STOP Warning when Air Cond selected

Post by wheeler » 01 Jun 2003, 16:15

have you checked that you can turn the fan freely by hand ?,they sometimes tend to sieze up,the multi function relay is the double injection relay,not sure where it is on the 406 as im going by citroen info,it's possibly in beside the engine ECU or at the bulkhead somewhere,it will either be brown or black & is the size of 2 normal relays together,i wouldnt think the relay would cause the problem though.i may be able to help more if i could see the diagram.

splaaat
Posts: 2
Joined: 01 Jun 2003, 05:05

406 HDi STOP Warning when Air Cond selected

Post by splaaat » 02 Jun 2003, 00:57

Hi Guys,
Thanks for the suggestions.

I looked at the Haynes manual again and the relay is called the 'Engine Management Multifunctional Relay', sorry if I confused anyone.
Homer the tip with the trip recorder worked a treat, thanks. [:D]
Wheeler thanks for the pointers. I tried the fan and it turns quite freely so its not a seizure problem. Is there any way I can get a scan of the schematics to you so you can see?
There are so many relays in the cooling fan system I think the only way to find out which one is faulty is to replace them one by one starting with the most likely. I was hoping the dealer would at least been able to tell if a component was not working or the ECU wasnt getting a correct signal. [:(]
Thanks again for the tips, I wont start ripping things out until Saturday so hopefully I can narrow things down a bit by then [:)]
Regards.
Splaaat.

wheeler
Posts: 3811
Joined: 21 Sep 2002, 19:07
x 81

406 HDi STOP Warning when Air Cond selected

Post by wheeler » 02 Jun 2003, 05:00

you could send a scan to nth@bushinternet.com is it just a single fan ? does the fan come on at any speed when either the a/c is switched on or when the engine temp sensor is disconnected ? at the moment i'm thinking its a faulty fan motor but it would be best to check it a bit further first.

acataldo
Posts: 17
Joined: 09 Jun 2005, 16:25

406 HDi STOP Warning when Air Cond selected

Post by acataldo » 04 Sep 2005, 16:17

I own a 406 HDI on a 99' T plate and I am experiencing the same problem. My STOP light flickers and also it flashes up "ENGINE TEMP TOO HIGH" on LCD display. This occurs at any engine temperature but only when the AIRCON is on. Recently had it re-gassed and is working OK switch on and engine speed reacts to AC compressor clutch). The fans do not come on with AC on. If you pull the temperature sensor off on top of the fuel filter do the fans come. It's one of checking the motors are working? I'm still investigating the issues.

User avatar
fastandfurryous
Posts: 1384
Joined: 07 Jul 2004, 17:57
x 3

406 HDi STOP Warning when Air Cond selected

Post by fastandfurryous » 04 Sep 2005, 23:41

this sounds suspiciously like a dead "bitron" control unit. Do a search on this forum for the word bitron, and I'm sure it's been covered before.

haydnw
Posts: 8
Joined: 03 Mar 2002, 05:03

406 HDi STOP Warning when Air Cond selected

Post by haydnw » 11 Sep 2005, 02:39

I had this fault on my 2.0 Hdi.
It was fixed under warranty by an engine management system specialist.
His comment to me when I collected the car was that it was due to water in the bank of relays behind the radiator.
That was around 2 years ago - no problems since.

acataldo
Posts: 17
Joined: 09 Jun 2005, 16:25

406 HDi STOP Warning when Air Cond selected

Post by acataldo » 14 Sep 2005, 03:29

Cheers,
I'm going to get some new relays I think. I was quoted £17 + vat from Pug dealer. Don't think there is a Bitron module on vehicle. Coolant temp sensor output goes straight to ECU (according to Haynes manual).