306 turbocharger broken by garage?

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

will_j
Posts: 5
Joined: 19 Nov 2002, 20:59

306 turbocharger broken by garage?

Post by will_j » 19 Nov 2002, 21:20

Recently, my 96 TD-S sprung a radiator leak so I took it to a local garage and got them to change it and the glow-plugs at the same time.
After picking it up yesterday, I discovered that the turbo no longer works. Although the car seems to run normally, there's no boost at all and I'm lucky to get 80mph out of it. Of course, the garage denies that anything they did could have caused this, and although it's possible that it's just a coincidence, it's pretty suspicious in my opinion.
Has anyone got any ideas for how the garage could've done the damage or what might be wrong? My guesses are:
1) They've knocked something which has caused the wastegate to stay open
2) I think an air-intake cover has to be removed to change the radiator - they could've dropped something into it
3) They didn't sort out the oil-cooling part of the radiator and the turbo overheated, seizing the bearing
Of course, it'll be very difficult to prove it was their fault even when I find out for sure, but any ideas or advice will be very much appreciated.

will_j
Posts: 5
Joined: 19 Nov 2002, 20:59

Post by will_j » 19 Nov 2002, 22:27

Fixed it, many thanks to Michael Goodlad for the advice.
The idiot mechanic had accidentally pulled the pressure-sensing pipe off the intercooler whilst fitting the glow-plugs, and even after I'd shown him he still wouldn't believe that this would make the boost fail. I asked him if he knew a lot about turbos, he said "more than enough", so I asked him what that pipe did and he said "nothing"!
He pushed it back on, and it works perfectly again.