Xantia Cooling Fans

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

Spanner
Posts: 3
Joined: Sat Jul 27, 2002 1:16 am
Location: United Kingdom
My Cars:

Xantia Cooling Fans

Postby Spanner » Sat Jul 27, 2002 1:53 am

I have a 1998 Xantia 2.1TD Estate.
I discovered today that the cooling fans are not switching in, I have taken off the brown connector on the thermostat housing wiring and still the fans are not clicking in, any suggestions?
0 x

bob
Posts: 3
Joined: Wed Jul 17, 2002 5:09 pm
Location:
My Cars:

Postby bob » Mon Jul 29, 2002 2:48 pm

Try the thermo switch screwed into the radiator, right hand side looking from the front, plug has 3 connections +12, slow,fast. To test the fans connect the +12 to either of the other two connections. You will probably find that the fans are OK and the thermo switch in the radiator is duff (get one from andyspares about £12)
0 x

Spanner
Posts: 3
Joined: Sat Jul 27, 2002 1:16 am
Location: United Kingdom
My Cars:

Postby Spanner » Wed Aug 14, 2002 2:52 am

Thanks for the suggestion, but I think I have found the solution. I stripped the front end down to get to the area behind the headlamp to check the bitron unit, in doing so I disconnected a multi pin socket, cleaned it and sprayed it with WD40 and since then the fans are working fine. So I presume that was the fault.
0 x


Return to “Citroën”

Who is online

Users browsing this forum: GiveMeABreak, MSNbot Media, Yahoo [Bot] and 8 guests