ZX Alarm Module

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
VLL
Posts: 140
Joined: 23 Feb 2004, 01:55

ZX Alarm Module

Post by VLL » 09 Apr 2004, 21:30

The alarm control unit in my ZX was playing up the other month (indicators on one side of the car staying on when you locked the car).
Gave the control unit to a mate who does lots of electronics stuff. He couldnt find a replacement relay but did manage to find one similar, but all attemts to fit it have failed. Either the alarm doesnt work or all the indicators stay on [:0]
Just wondered if anyone here knows what it would cost to get a new one from Citroen, has one they could sell themselves or knows where i could get one at a reasonable price.
Thanks.

User avatar
VLL
Posts: 140
Joined: 23 Feb 2004, 01:55

ZX Alarm Module

Post by VLL » 10 Apr 2004, 04:37

Surely someone has some info on this???

User avatar
AndersDK
Posts: 6060
Joined: 21 Feb 2003, 05:56
x 1

ZX Alarm Module

Post by AndersDK » 10 Apr 2004, 04:46

Hmmm...
Could this be a simple problem that the module has lost it's charge from internal battery, or lost it's code, because of the removal for repair ?
Have your friend to check any battery found in the module. These are commonly NiCd (or NiMh, even a small LeadAcid gel cell) rechargeable batteries, with a limited service life.
Might even be that simple the battery must have some time to charge to quit the alarm.

DomF9
Posts: 80
Joined: 25 Mar 2004, 09:37

ZX Alarm Module

Post by DomF9 » 10 Apr 2004, 09:29

Re trying to get a new module from Citroen, I had a similar problem with my ZX when I first got it. Not indicators, but "bits" of the alarm dotted around the car, ie switches that lit up but did nothing and so on. Went to Citroen to get info on what did what etc, but they said there were so many variations of the alarm for the ZX it was impossible to know what parts it originally had, or even how to ascertain which alarm it had had in order to replace it.
Mine didn't have the keypad thing, being a Series 1, but it had switches and a permanently-lit LED on the dash, yet to module anywhere in the car, nor the keyswitch on the front slam panel.
If anyone out there has any info on what and why, I'd be interested to know.

User avatar
VLL
Posts: 140
Joined: 23 Feb 2004, 01:55

ZX Alarm Module

Post by VLL » 10 Apr 2004, 22:05

The only problem with mine was the relay on the circuit board thats flashed the indicators would stick and keep the indicators on one side of the car on permanently. If you tapped the relay the indicators would go off.
Its the small plastic box under the rear passenger side window on my 3Door.
Just need to find another.