Confused windscreen washer; front not working. [C5 Mk1)

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Spurious
Posts: 34
Joined: 02 Jan 2013, 15:03
x 1

Confused windscreen washer; front not working. [C5 Mk1)

Post by Spurious » 09 Jan 2018, 16:44

Hi all.

The continuing adventure of the new to me C5. Another niggly little fault!

The windscreen washer motor is deciding to wash the rear windscreen when pulling on the stalk to wash the front. Kinda annoying. So both switches for the washers only wash the rear. Not too good on the grimey roads out and about.

Motor seems to be working as it's washing the rear. There's plenty of water in the tank

So what I've know;
BSI reset; no change.
Clean out the pipes; the ones on the bonnet are clear. There's a joining plastic connection connecting this pipe and then descending down into the wing. I've tried to blow on it to force it back into the tank. It's not budging; it's like it's closed off.

Is there a valve that actuates where the water goes? Could that be stuck shut? Any other ideas?

Thanks all.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 10698
Joined: 15 Sep 2015, 19:38
x 890

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by GiveMeABreak » 09 Jan 2018, 17:01

Your washer pump might be washed out!
Here's a couple of diagrams for the front and the rear washing circuit / pipes etc.
Front
Spurious Washer A.PNG
Rear
Spurious Washer Rear.PNG
The pump is Part number: 6434 75 for your C5 Estate (item number 6 on the diagrams). Assuming it's not a kinked pipe anywhere - there could be some crud or scale in the pump, but at these prices it probably won't break the bank to replace it.

There's one on Amazon for £8 here:
https://www.amazon.co.uk/6434-75-Window ... B0114DFBHS
Or a Genuine Citroen one on the bay of evil for £10 here:
https://www.ebay.co.uk/itm/Citroen-Peug ... 2366735107

Hell Razor5543
NOT Alistair or Simon
Posts: 8275
Joined: 01 Apr 2012, 09:47
x 485

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Hell Razor5543 » 09 Jan 2018, 17:04

The reservoir is down in the offside bumper area. It is likely there is a valve in the line somewhere to make sure the water does not flow back down (so you will have water spraying when you require it NOW, not in a few seconds time). I have replaced the pump (you can get them from GSF for a few quid), and you could, once you get the pipes off the pump (don't get them the wrong way round), try blowing from that end, to see if there is a blockage (other than the valve).

Gibbo2286
Posts: 2913
Joined: 08 Jun 2011, 18:04
x 301

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Gibbo2286 » 09 Jan 2018, 17:32

I'm not sure but isn't part 19 in those diagrams the one way valve?

On my mk 2 the hose had a hole rubbed into it where it passes over the under wing protection and the water was just running out onto the floor

User avatar
GiveMeABreak
Forum Admin Team
Posts: 10698
Joined: 15 Sep 2015, 19:38
x 890

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by GiveMeABreak » 09 Jan 2018, 17:35

Part 19 just states Union Gibbo - and this model states 'sans clapet' for the pump (without valve) - It's correct for the VIN of this vehicle.

Hell Razor5543
NOT Alistair or Simon
Posts: 8275
Joined: 01 Apr 2012, 09:47
x 485

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Hell Razor5543 » 09 Jan 2018, 18:00

Part 18 might be the valve.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 10698
Joined: 15 Sep 2015, 19:38
x 890

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by GiveMeABreak » 09 Jan 2018, 18:22

18 is a 2-way union.

Spurious
Posts: 34
Joined: 02 Jan 2013, 15:03
x 1

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Spurious » 09 Jan 2018, 18:45

GiveMeABreak wrote:
09 Jan 2018, 18:22
18 is a 2-way union.


That's what it is. It's just plastic, there's no one-way valve in it. That's the one near the corner of the bonnet.

I'll have to trace it back to the pump and troubleshoot from there. Is it a faff getting it off? Could you get under it from the wheel cover?

Hell Razor5543
NOT Alistair or Simon
Posts: 8275
Joined: 01 Apr 2012, 09:47
x 485

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Hell Razor5543 » 09 Jan 2018, 18:46

You will have to remove the forward plastic cover. It is not too bad, just a bit cramped. I wonder if the nozzles have valves in them?

User avatar
old'uns
Posts: 380
Joined: 06 Mar 2010, 21:21
x 5

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by old'uns » 09 Jan 2018, 19:15

sure i had this on my mk1.....diaphragm on the pump had a hole in it?
TBH can't remember how i fixed it, a long time ago!

Spurious
Posts: 34
Joined: 02 Jan 2013, 15:03
x 1

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Spurious » 09 Jan 2018, 19:35

Hell Razor5543 wrote:
09 Jan 2018, 18:46
You will have to remove the forward plastic cover. It is not too bad, just a bit cramped. I wonder if the nozzles have valves in them?



They might do as the little plastic unions don't.

Thanks for all the ideas. I'll strip it back during the week at some point and see if I can figure out what's going on.

Is there a reason why the rear washer is working when the front is activated? Blockage diverting the pressure along to the back?

dnsey
Posts: 1541
Joined: 20 Oct 2004, 01:39
x 14

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by dnsey » 09 Jan 2018, 20:23

The washer pump uses a shuttle valve to direct the water to front or back, depending on which way the motor turns, which is of course decided by the switching system. The valve can stick and cause your symptoms, but it's not really worth trying to repair except for fun, as you can get a pattern replacement pump complete for under a tenner.

Hell Razor5543
NOT Alistair or Simon
Posts: 8275
Joined: 01 Apr 2012, 09:47
x 485

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Hell Razor5543 » 09 Jan 2018, 20:31

The pump is a motor that can run either way (depending on the polarity of the voltage). When it spins one way the front nozzles get the water, while spinning it the other way sprays the rear windscreen.

This is the pump I got from GSF;

https://www.gsfcarparts.com/catalogsear ... +wash+pump

User avatar
Fake Concern
Posts: 941
Joined: 27 Dec 2012, 11:41
x 36

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by Fake Concern » 09 Jan 2018, 20:37

dnsey wrote:
09 Jan 2018, 20:23
The washer pump uses a shuttle valve to direct the water to front or back, depending on which way the motor turns, which is of course decided by the switching system. The valve can stick and cause your symptoms, but it's not really worth trying to repair except for fun, as you can get a pattern replacement pump complete for under a tenner.

This is most likely your problem. I've fixed them, it's pretty easy I followed a youtube guide for my daughter's Clio, but the C4 was the same & I expect so is the C5.


dnsey
Posts: 1541
Joined: 20 Oct 2004, 01:39
x 14

Re: Confused windscreen washer; front not working. [C5 Mk1)

Post by dnsey » 09 Jan 2018, 20:54

Yes, it can certainly be done (I too have repaired them), but IME the valve body can become quite brittle, and break when removing it from the pump housing. You're then left with no washers until you can get a new pump!