C4 heater/air con not working

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

User avatar
petef
Posts: 68
Joined: 23 Jul 2006, 20:46
Location: Lochwinnoch,Scotland and Dordogne, France
My Cars: C5 x7 Tourer, C4 Coupe, 11B Normale, Xantia Activa
x 1

C4 heater/air con not working

Post by petef » 22 Dec 2016, 18:18

Evening all

The heater blower on my wife's 2007 c4 VTR coupe has suddenly stopped working. I thought a good clue was that the air con light and air reciirculation light (standard non auto system with rotary controls) also stopped coming on when the relevant button was pressed. ie no power would appear to be getting through which would seem to indicate a fuse. But under bonnet fuse 11 is fine - assuming this is the right one. Is there another fuse somewhere to check? The handbook shows a completely different under dash fusebox configuration to the one on the car so I have no idea what is what there. Or is there any history of the heater control panel failing in some way?

Worst day of the year so far to have no heater....rain, sleet, high winds, near freezing..........
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6665
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 457

Re: C4 heater/air con not working

Post by GiveMeABreak » 22 Dec 2016, 19:15

Aaarrrggghh - not another one of these - tis the season for heater blower failures! Add to that the known C4 fusebox issues - being different to the manuals! Can you post up your VIN and I'll take a look at the fuse layout as it says it is supposed to be.

Also, some here have had a similar issue - but unit returned to working later - seemed to either be water in the system playing up with the electrics and when dried out worked again. Advice seemed to be to ensure heater is on for a while to dry out any water before switching car off.
0x
Marc

User avatar
demag
Donor 2016
Posts: 1407
Joined: 18 Oct 2004, 05:03
Location: Black Country, aye it ar kid.
My Cars: "H" Citroen Bx Tgs Automatic.
2004 Citroen C5 Exclusive Estate 2.2 hdi Automatic.
x 69

Re: C4 heater/air con not working

Post by demag » 22 Dec 2016, 19:17

Does the fan work on the fastest speed?

Sent from my Nexus 7 using Tapatalk
0x
Dave

'04 C5 auto estate 2.2 hdi.
Bx 1.6 TGS Auto 50k A rare beast by all accounts. A bit tired but getting better by the day.
'96 XM 2.5TD VSX.......Sadly sold. What an idiot! I should have held on to that.

User avatar
petef
Posts: 68
Joined: 23 Jul 2006, 20:46
Location: Lochwinnoch,Scotland and Dordogne, France
My Cars: C5 x7 Tourer, C4 Coupe, 11B Normale, Xantia Activa
x 1

Re: C4 heater/air con not working

Post by petef » 22 Dec 2016, 19:35

Thanks Marc. Vin no VF7LANFUC74624183. Fan completely dead at any speed setting. Been reading about similar problems with first C4 Picasso being due to connections in the ignition switch - God forbid. thought this was the season of good cheer.......
0x

Capri1morris
New User
Posts: 1
Joined: 03 Jan 2017, 01:12
Location: Harlow
My Cars: Citroen 1.6 2005 C4 vtr+ 3 door coupe

Re: C4 heater/air con not working

Post by Capri1morris » 05 Jan 2017, 20:36

:( Hi
I'm having the same problem with my heater blower not working, I have a Citroen C4 2005 1.6 Vtr+ coupe, had it's M.O.T recently and to my surprise the heater blower didn't work
on any setting, Asked the garage if they had done anything accidently but no, due that I've had the car S/H since nearly new 8 months. The things I have checked or replaced the fuse F11, under bonnet, resistor pack, fan motor, the cable are saying there's power neg/positive. the only unit I haven't replaced or checked is the climate control fascia which indicates everything is running, can some HELP! It's really cold out there without it cheers :(
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6665
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 457

Re: C4 heater/air con not working

Post by GiveMeABreak » 06 Jan 2017, 00:00

Ok, chaps - Pete, this is for your specific car: This is the blower motor location - for a right hand drive, this should be under the passenger side'
C4 Blower Unit.PNG
Unlock and disconnect the connector "" (at "c").
Rotate and detach the blower control module (following the arrow "b").

Blower Control module
C4 Blower Motor.PNG
You do not have the required permissions to view the files attached to this post.
0x
Marc

Dudz101
New User
Posts: 1
Joined: 04 Oct 2017, 08:40
Location: Ng184nh
My Cars: Citroen c4 picasso

Re: C4 heater/air con not working

Post by Dudz101 » 04 Oct 2017, 08:44

Hi, I can't seem to view the photos. I'm having the same problem. Hope someone can help me
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6665
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 457

Re: C4 heater/air con not working

Post by GiveMeABreak » 04 Oct 2017, 09:45

Thanks for spotting the photo issue - give me a few minutes and I'll get the pictures replaced!
0x
Marc

Justin_Brown
Posts: 7
Joined: 08 Nov 2017, 17:34
Location: Roodepoort, Johannesburg
My Cars: 2006 Citroen c4 1.6 Hdi
2007 Peugeot 207cc 1.6 thp

Re: C4 heater/air con not working

Post by Justin_Brown » 08 Nov 2017, 19:01

Hi all,

I'm having the exact same problem as Pete. All the fuses are fine, there's 12 volts in the fuse box, the resistor is in working order,the wire harness going into the back of the manual fan/aircon control panel is also fine and the fan motor runs with 12v applied directly to it.
Was there a solution to Pete's original problem?
My logic would suggest that its the actual control panel, but is there a way I can test this theory before I go and order a new panel at the stealers?

Thanks,
Justin
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6665
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 457

Re: C4 heater/air con not working

Post by GiveMeABreak » 08 Nov 2017, 19:29

Depending on you actual car there is a Heater Motor Control Module and you MAY have a Heater Control Resistor - PM or post up your VIN and I can post you up a Diagram for your vehicle. It is dependent upon the type of system you have and whether it is with / without AC etc. as to what you should have.
0x
Marc

User avatar
petef
Posts: 68
Joined: 23 Jul 2006, 20:46
Location: Lochwinnoch,Scotland and Dordogne, France
My Cars: C5 x7 Tourer, C4 Coupe, 11B Normale, Xantia Activa
x 1

Re: C4 heater/air con not working

Post by petef » 08 Nov 2017, 23:44

Should have posted the solution at the time. For me this turned out to be replacing the under bonnet fusebox. One of the relays embedded in this had ceased to function. It can't be replaced by itself because it is literally sealed in place with a resin type material under the fuses. An auto electrician did by pass the relay and fitted an inline fuse for me to get things going again but I was not entirely happy with this because, dependent on setting, the fan could come on as soon as the ignition was switched on. Not good for the ignition switch long term I thought. A replacement fusebox was sourced s/h on eBay. Make sure you get the right one - there is a sticker with an abbreviated part number on a front corner of the box. I initially bought the wrong one - near identical but the wipers wouldn't turn off.............. Should cost around £30 and replacement is straightforward.
All has been fine since.
0x

Justin_Brown
Posts: 7
Joined: 08 Nov 2017, 17:34
Location: Roodepoort, Johannesburg
My Cars: 2006 Citroen c4 1.6 Hdi
2007 Peugeot 207cc 1.6 thp

Re: C4 heater/air con not working

Post by Justin_Brown » 09 Nov 2017, 13:29

Thank you both for your responses,

@GivemeABreak I don't believe it's the resistor as I tested this with a multi meter and all seemed in order. I will attempt to take 12 volts directly to the AC/Fan control panel in order to determine whether it is/isn't the actual fuse box which is causing the problems.

My VIN is however VF7LC9HYB74172271

Thanks,
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6665
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 457

Re: C4 heater/air con not working

Post by GiveMeABreak » 09 Nov 2017, 14:57

Ok Justin, you have the single Air Conditioning System, so in the diagram below, you will only have parts 1 and 3:
Parts 2, 4 & 5 are only for the Automatic A/C System.
(1) Heater Control Resistor
(3) Air Heating Resistance
Justin C4.PNG
You do not have the required permissions to view the files attached to this post.
0x
Marc

Justin_Brown
Posts: 7
Joined: 08 Nov 2017, 17:34
Location: Roodepoort, Johannesburg
My Cars: 2006 Citroen c4 1.6 Hdi
2007 Peugeot 207cc 1.6 thp

Re: C4 heater/air con not working

Post by Justin_Brown » 09 Nov 2017, 18:22

Thank you GiveMeABreak. Do you perhaps have a wiring diagram of the air conditioner/Blower, front control panel and how they're interconnected with the fuse boxes, as I'm completely stumped as to what's wrong.

I've confirmed the following;
-Resistance over the various coils on the resistor.(1 on your attached diagram)
-That the blower motor works by connecting it directly to the battery.
-There's 12v going into the fan/ac control panel.
-I've manually bridged the 12v connection/plug at the back of the control panel to simulate the adjusting of the fan speed dial. (Still no signs of life)

Is there something I'm missing or over looking?

Thank you again.
0x

User avatar
petef
Posts: 68
Joined: 23 Jul 2006, 20:46
Location: Lochwinnoch,Scotland and Dordogne, France
My Cars: C5 x7 Tourer, C4 Coupe, 11B Normale, Xantia Activa
x 1

Re: C4 heater/air con not working

Post by petef » 09 Nov 2017, 19:28

I too had 12v going into the panel and didn't see how it could be the fusebox..........but it was. Apparently the under bonnet fusebox - the BSM - is a well known problem. If you don't want to change it just bridge the two wires with an appropriately fused lead going into and out of the BSM to see if the fan and air con start to work. I am not at home at the moment and can't access Citroen Service to get the diagram of the BSM.
If someone can post this I can identify exactly the two wires to bridge, but, as I remember, it is the two stout wires that go into an oval connector in the middle of the top of the box.
0x