funny click

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

mipster
Posts: 113
Joined: 09 Jan 2003, 01:10

funny click

Post by mipster » 25 Sep 2003, 17:31

I fille dup by diesel Xantia last night, on the drive hokme a noticed a regular click coming from the instrument area of the dashboard. No other apparent problems turning lights, radio on/off didn't help.
After a while I realised that the intervals had stretched from around 1 second to about 3. When I got home the clicks faded to nothing.
I had a poke around and went back out for a drive, the faster I went the faster it clicked, continuing when the clutch was in and independant of revs.
It was only on my way back when I wondered how many miles I had done trying to find the problem when I realised that the tripometer was stuck between 111 and 000. I always reset it when filling up the car.
Well I thought it was funny,
mipzter

alexx
Posts: 462
Joined: 19 Nov 2002, 03:42

Post by alexx » 25 Sep 2003, 17:46

I had the very same 'problem' on Visa, a long time ago.

User avatar
rabenson
Posts: 328
Joined: 15 Jul 2002, 15:14

Post by rabenson » 25 Sep 2003, 18:21

I had the same on a Pug 205 - trip meter stopped working when milomemter got to 100k but would click now and then which stopped if you poked the reset button really hard a few times.....

BonceChops
Posts: 449
Joined: 28 Sep 2003, 11:08

Post by BonceChops » 28 Sep 2003, 11:36

Since i bought my Xantia TD I sometimes get a clicking from behind the dash, near the fusebox. It sounds like a relay energising on and off several times a second. The speed varies sometimes and after a while it usually stops. I cant find out which relay it is as it stops before I get chance to find it. Anyone any idea what it might be?

User avatar
AndersDK
Posts: 6060
Joined: 21 Feb 2003, 05:56
x 1

Post by AndersDK » 28 Sep 2003, 19:12

Some time ago I tried to advice on a similar problem - and learned from others that a small fan is located in the cabin air duct [:D]
This fan is to keep an air flow over the temp sensor - such that the cabin temperature constantly regulates correctly.
This fan can emit vague humming sound - as well as vague ticking.

BonceChops
Posts: 449
Joined: 28 Sep 2003, 11:08

Post by BonceChops » 29 Sep 2003, 14:07

Is the temp sensor on air-con models? Mine is an SX without air-con.

cheesey
Posts: 36
Joined: 12 Apr 2003, 01:58

Post by cheesey » 29 Sep 2003, 23:51

hi.
I had varible clicking from behind the dash too. It turned out to be a short in the column switch for the indicators. I think it caused the indicator relay to click on/off but it did not make the indicators light up. This can happen when the relay does not get enough power to pull down the contacts inside.
94 1.9 td sx

BonceChops
Posts: 449
Joined: 28 Sep 2003, 11:08

Post by BonceChops » 30 Sep 2003, 01:54

Can you give me an idea where the indicator relay is?

wrinklet1
Posts: 703
Joined: 23 Nov 2002, 20:15

Post by wrinklet1 » 30 Sep 2003, 13:57

Hi Mipster
I think you may find that the noise thats coming from your dashboard is nothing more than the trip meter. If you pressed the button to reset your trip meter when you filled up, it may not have reset properley. Make sure your stationary and reset it again. The noise should stop then.
Regards
Paul.[xx(]

mipster
Posts: 113
Joined: 09 Jan 2003, 01:10

Post by mipster » 30 Sep 2003, 18:09

<i>I think you may find that the noise thats coming from your dashboard is nothing more than the trip meter</i>
Well diagnosed, it was the trip meter, that's what was funny, I sapent ages trying to work it out[:)]
cheers
mipzter