XANTIA BLOWER WORKING INTERMITTENTLY

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

User avatar
falling-out-with-my-car
Posts: 1948
Joined: 06 Apr 2008, 15:26
Location: Northamptonshire
My Cars: 1987 Citroen 2cv6 restored 2011 (Now Sold for funds to buy an X7 Auto estate), 2007 Citroen C5 purchased 9/12/2016
x 16

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by falling-out-with-my-car » 09 Feb 2014, 15:53

it is possible to buy the fan control module complete from this website for £29.00 (made in Germany apparently)
http://www.worldcarparts.co.uk/Store/ta ... fault.aspx

regards
Nigel.
0x
Citroen Xantia S2 1.9 TD estate 189K soon to be broken for parts Jan 2017 headlamps & radiator fan assembly already spoken for & A 1987 Citroen 2CV6 special just for fun.
New addition Citroen C5 2.0 HDi Exclusive Hatch purchased 09/12/2016 with 83K on the clock.

User avatar
longgo
Posts: 40
Joined: 06 Jun 2013, 10:06
Location: Finland
My Cars: was Xantia I LPG
now - Xantia II
wish DS23

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by longgo » 09 Feb 2014, 16:54

Thanks for the website. Probably will be little cheap from Ebay.de to fins something.. but anyway - the fan work, and work on all 3 + auto position how it should work. Just the airflow provided trough the front holes is much stronger compared to the flow that can go to the windshield when i select the required position. In short - i suspect that the flap which change that position do not close enough when i need more to described position. Thanks again Nigel.
0x

User avatar
falling-out-with-my-car
Posts: 1948
Joined: 06 Apr 2008, 15:26
Location: Northamptonshire
My Cars: 1987 Citroen 2cv6 restored 2011 (Now Sold for funds to buy an X7 Auto estate), 2007 Citroen C5 purchased 9/12/2016
x 16

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by falling-out-with-my-car » 10 Feb 2014, 12:25

In my experience the Windscreen vents do not blow very well until heat is produced helping the air to rise.

regards
Nigel.
0x
Citroen Xantia S2 1.9 TD estate 189K soon to be broken for parts Jan 2017 headlamps & radiator fan assembly already spoken for & A 1987 Citroen 2CV6 special just for fun.
New addition Citroen C5 2.0 HDi Exclusive Hatch purchased 09/12/2016 with 83K on the clock.

Estately
Posts: 104
Joined: 02 Nov 2010, 21:50
Location: Stafford
My Cars: 00 Xantia 2.0 HDI 90 bhp Estate 237k Gone to New Home
07 C5 2.0 HDI 138 Exclusive Estate 198k.
10 C5 2.0 HDI 138 Auto Exclusive Estate. Px'd
13 C5 2.0 HDI 160 Manual Exclusive Tourer.

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by Estately » 05 Aug 2014, 15:56

Hi,
I wonder if anyone can help me out with a blower problem.

First thanks to the postings by Rory Perrett for the logical approach as to how to check and Citrojim for the wiring diagram that seems to cover our Dec 2000 2.0L HDi LX Estate with climate control.

Problem: Blower stopped working, replaced the control module and at the same time checked the connectors in the brown plug. I had previously soldered the crimping to try and improve the current flow and reduce the chance of the connectors heating.
Motor ran no problem, hot, cold all OK for a couple of days.

Then the blower motor stopped again and on investigation found that the power supply to the motor relay (above accelerator) was doing strange things.

It would show the full 12v on the tester but would neither operate the relay or light a test bulb, on further investigation the supply to the relay when tested again gave 7.5v and later began to pulse giving 1 or 2 volts up to about 7.5v.

As a temporary measure the climate control can be made to work, all fan speeds, air con compressor and both hot or cold as requested off the slider control, by feeding a 12 volt supply to the wire (yellow) supplying pin 1 of the relay with the relay plugged into its holder.

The green light on the air con button lights when operated and I think only glows dimly when the temporary supply is removed and of course the blower motor stops.

To get it going again I am not sure if I should run a supply with an additional in line fuse to pin 1 of the motor relay off the ignition switch (only live with the engine running) because it may risk causing damage to some other components.

Any ideas gratefully received.

Andy.
0x
If it can happen it will.

rory_perrett
Posts: 723
Joined: 05 Nov 2001, 20:18
Location: Leeds, Yorkshire
My Cars: Xantia Exclusive 110Hdi Estate 1999

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by rory_perrett » 05 Aug 2014, 16:36

I see no problem with that if it is ignition controlled and has an in line fuse for good measure. Do you have 12v at fuse 5? If so you could run a parallel wire from fuse 5 to terminal 1 on the relay.
0x

Estately
Posts: 104
Joined: 02 Nov 2010, 21:50
Location: Stafford
My Cars: 00 Xantia 2.0 HDI 90 bhp Estate 237k Gone to New Home
07 C5 2.0 HDI 138 Exclusive Estate 198k.
10 C5 2.0 HDI 138 Auto Exclusive Estate. Px'd
13 C5 2.0 HDI 160 Manual Exclusive Tourer.

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by Estately » 05 Aug 2014, 17:03

Thanks for the suggestion re - fuse 5, on our Xantia the hand book gives it as rear screen timer & switch, a relay for heated seats (if only) and surprisingly for the year of manufacture, a relay for daytime lamps (maybe for the Scandanavian market).
Whilst I have the fuse board lowered it is very tight to work with and the logic escapes me as to which (green?) wire relates to fuse 5.
0x
If it can happen it will.

rory_perrett
Posts: 723
Joined: 05 Nov 2001, 20:18
Location: Leeds, Yorkshire
My Cars: Xantia Exclusive 110Hdi Estate 1999

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by rory_perrett » 05 Aug 2014, 18:58

I guess its find an ignition switch 12v supply. Mine is 2000 model as well (not sure which month) although it dos have the heated seats. As you say, its very tight with all the wires behind the fues box and getting in to work is fun (not)
0x

sandysound
Posts: 31
Joined: 14 Jan 2015, 15:32
Location:
My Cars:

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by sandysound » 14 Jan 2015, 21:55

I have an issue with my fan;
It works when switched on max,

Image

but adjusting it to anything below full just drops it to a very slow constant rate - I think - it still keeps the car warm but not entirely sure the fan is running.

Image

Where should I begin with troubleshooting this?
Last edited by sandysound on 15 Jan 2015, 12:42, edited 1 time in total.
0x

rory_perrett
Posts: 723
Joined: 05 Nov 2001, 20:18
Location: Leeds, Yorkshire
My Cars: Xantia Exclusive 110Hdi Estate 1999

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by rory_perrett » 14 Jan 2015, 23:08

Probably the control module but as you can see from this thread the system can behave in some very strange ways.
0x

sandysound
Posts: 31
Joined: 14 Jan 2015, 15:32
Location:
My Cars:

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by sandysound » 14 Jan 2015, 23:42

Yes I picked up on the "strange" lol, my symptoms don't match with the others so not sure where to start...
0x

User avatar
falling-out-with-my-car
Posts: 1948
Joined: 06 Apr 2008, 15:26
Location: Northamptonshire
My Cars: 1987 Citroen 2cv6 restored 2011 (Now Sold for funds to buy an X7 Auto estate), 2007 Citroen C5 purchased 9/12/2016
x 16

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by falling-out-with-my-car » 15 Jan 2015, 11:45

I still have this problem with my 1998 Xantia 1.9 TD estate I know what it is now but its just the weather stopping me from fixing the issue, the thick red lead that goes up to the heater fan has the black death in the wire. after years of this lead heating up because of a loose spade connector on the fan motor end, it is time to replace about a foot of this lead.
0x
Citroen Xantia S2 1.9 TD estate 189K soon to be broken for parts Jan 2017 headlamps & radiator fan assembly already spoken for & A 1987 Citroen 2CV6 special just for fun.
New addition Citroen C5 2.0 HDi Exclusive Hatch purchased 09/12/2016 with 83K on the clock.

User avatar
Clogzz
Posts: 2062
Joined: 15 May 2005, 18:04
Location: Australia
My Cars:
x 8

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by Clogzz » 23 Jan 2015, 11:55

0x
2003 C5 2.0i AL4 183,000 km 76372389

Raul
Posts: 83
Joined: 05 May 2012, 05:37
Location: Estonia
My Cars:

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by Raul » 31 Mar 2015, 11:38

Just bought 2000 hdi 66kw without aircon and the blower does not work at all. Previous owner confirmed that the blower motor was changed a year ago. So do I have to remove the centre console to get an acess to the blower? I have a left hand steering wheel car.
0x
Citroen gsa 1299 , 1982
Citroen gs 1,2 pallas 1977
Citroen xantia 1,9 td estate 1996
Citroen Xantia 2.0 hdi 90 2000

User avatar
falling-out-with-my-car
Posts: 1948
Joined: 06 Apr 2008, 15:26
Location: Northamptonshire
My Cars: 1987 Citroen 2cv6 restored 2011 (Now Sold for funds to buy an X7 Auto estate), 2007 Citroen C5 purchased 9/12/2016
x 16

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by falling-out-with-my-car » 31 Mar 2015, 13:01

No remove the torx screws that hold up the passenger side cloth under the dashboard this will reveal the wiring loom and the heater Motor up in the right hand corner if it is the opposite way around to a right hand drive. the heater fan motor is secured by 3 x Philips screws you will need a very short screwdriver and you'll need to pinch the other half's makeup mirror and a torch, to locate the screws. shine the torch in the mirror and have a look at the underside of the fan motor there should be 3 screws one at the back and one each side of the motor, undo these and pull the motor down into the foot well.
make a note of where all the plugs go.

it could be like mine the red and black thick leads to the brown plug that connects to the heater fan had what we call the black death, bad corrosion. and the spade connectors inside the brown plug that goes to the heater fan were all loose the best thing to do was remove the brown plug completely replace the spade connectors with new wires attached fill the area around the spade connectors with clear epoxy glue and allow to dry this replaces the plug with a non-moving permanent insulated plug the new leads coming off this fixing can now be attached to the rest of the wiring loom with a chop-block connector with a 25 amp rating which allows removal of the fan unit at a later date. No more loose plug or loose spade connectors no more corrosion around the spade connectors as the air is excluded completely. don't forget to check the screw threads of the chop block before use as they have varying quality. first of all check the red and black wires to see if they are flexible if not then they probably have the black death.
0x
Citroen Xantia S2 1.9 TD estate 189K soon to be broken for parts Jan 2017 headlamps & radiator fan assembly already spoken for & A 1987 Citroen 2CV6 special just for fun.
New addition Citroen C5 2.0 HDi Exclusive Hatch purchased 09/12/2016 with 83K on the clock.

Raul
Posts: 83
Joined: 05 May 2012, 05:37
Location: Estonia
My Cars:

Re: XANTIA BLOWER WORKING INTERMITTENTLY

Post by Raul » 03 Apr 2015, 17:43

As I found out the blower motor of my car has no usual control unit. There is an oval element that has a brown plug with 5 wires attached to. Googled and it is called a resistor pack. One wire was broken inside that resistor pack and when I short circuited it I got a voltage on the wires that go directly to the blower motor. I have a scrapped zx and out of interest I checked its blower motor and took out the resistor pack. It was similar but unfortunately a little bit different in shape and does not fit to my xantia. I also noticed that the there is a resistor or something in the same wire that was broken in the resistor pack of the xantia. I made a bridge connection to that wire and then I measured voltage again on the wires that go into the blower motor and there were 14 volt . So I connected the wires to the blower but it did not start . I took off the blower and found out that the brushes are almost gone and sticked. So it seems that I need atleast a new blower motor and probably a new resistor pack as well. Does the resistor pack control the speed of the blower? When I checked the voltage on the wires that go to the blower I noticed that when the speed lever was at the minimum the voltage was 0 but as soon as I started to slide the lever the voltage jumped to 14. Also what do you think about changing the brushes of the blower motor.
0x
Citroen gsa 1299 , 1982
Citroen gs 1,2 pallas 1977
Citroen xantia 1,9 td estate 1996
Citroen Xantia 2.0 hdi 90 2000