Getting close

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

mezuk04
Posts: 1125
Joined: 03 Sep 2004, 19:15

Getting close

Post by mezuk04 » 27 Jan 2006, 15:09

Well just done the air filter but lost a screw and dont have any spares, Wilkobob is sure to have 1.

Fuel filter, drained the containter and replaced, bit of arsing about so i think i will just not bother draining anymore hehehe.

Ive replaced the washer jets to the new Xsara Mist Jets, not actually that difficult to do which is surprising if you take it that its me. Little electrical screwdriver used to pop 'big' clip down while rotating down and pulling (quite steardy little things to be honest), then eleccy driver to go underneath the pipe to lever off the water tight head, does a tiny bit of damage to the end of the pipe, but very minimul and its fine. Stick the news on and apply a bit of force reversing procedure and sorted...however the passenger side tends to spray the roof where the drivers side seems pretty much bang on...any ideas??

Wd-40'd the joint between the 'car' hehehe and the sphere so lets hope it helps....OH and the pollen filter!

citronut
Posts: 10939
Joined: 29 Apr 2005, 00:46
x 3

Post by citronut » 27 Jan 2006, 20:25

do mist jets adjust the same as normal ones,if so you just need a small safty pin place the pointed end into the center of the jet and rotate the ball in its socket till its aim is right,should not be any need to use the dreded WD40
regards malcolm

mezuk04
Posts: 1125
Joined: 03 Sep 2004, 19:15

Post by mezuk04 » 27 Jan 2006, 20:27

I was referring WD-40 to the spheres, are you?

The mist jets have a vertical rectangle on them where the water comes out of...not sure what is inside the rectangle though :shock:

citronut
Posts: 10939
Joined: 29 Apr 2005, 00:46
x 3

Post by citronut » 27 Jan 2006, 20:34

why didnt you say as i didnt notice the mention of spheres,it must have been the mist on my glasses,HE HE HE
regards malcolm

User avatar
np
Posts: 1296
Joined: 13 May 2004, 03:13

Post by np » 27 Jan 2006, 20:49

I tried to adjust the spay on mine,but buggerd it up.It came out like the old jet.Although a bit of poking around with the needle got it misting again.I just used a bit of super glue to hold them so they spray down a bit.When you`re driving along at speed,the wind force makes the spray hit the screen lower anyway. :)

davehughes
Posts: 76
Joined: 26 Dec 2005, 13:50

Post by davehughes » 27 Jan 2006, 20:58

So which ones do I need for my MK1 Xantia again, Xsara or Pug 407.
I've lost track :?

User avatar
np
Posts: 1296
Joined: 13 May 2004, 03:13

Post by np » 27 Jan 2006, 21:06

Pug 406 jets Dave, as fitted to mine.I posted the Pug part number here,
http://www.frenchcarforum.co.uk/forum/v ... 9&start=15

davehughes
Posts: 76
Joined: 26 Dec 2005, 13:50

Post by davehughes » 27 Jan 2006, 21:58

406? I saw 407 on a thread :? :?

User avatar
np
Posts: 1296
Joined: 13 May 2004, 03:13

Post by np » 28 Jan 2006, 01:41

I dont know where the 407 bit came from.I`ve always refered to them as 406 mist sprays.The Pug part number in link to the other topic is for mist jets from a 406,as fitted to my Xantia.
Weather or not the 407 jets are the same,i dont know.

mezuk04
Posts: 1125
Joined: 03 Sep 2004, 19:15

Post by mezuk04 » 28 Jan 2006, 15:44

That'll be because of me np......i wasnt sure by memory if it was 406 or 407 hehehehehe