Xsara Wiper Relay

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

mattpc
Posts: 198
Joined: 21 Oct 2004, 17:31

Xsara Wiper Relay

Post by mattpc » 14 May 2005, 19:59

Arrgh! The intermittent wiper feature is not working on the Missues Xsara VTR Coupe. Well actually it does work most of the time but the relay seems to be making nasty noises. I think it is sticking so want to change it. However, I cannot find any information regarding the whereabouts of the relay. I think it's probably in the fuse box but no relays are labelled in there. There is no information in the Haynes or in the citroen manual. Any got any experience of this problem?

wheeler
Posts: 3823
Joined: 21 Sep 2002, 19:07
x 84

Xsara Wiper Relay

Post by wheeler » 14 May 2005, 20:57

if your xsara is multiplexed (approximitley from RP 8500 onwards) then the wiper speeds are controled by the BSI which is quite expensive & needs to be coded to the car.if its not multiplexed cant you just trace the relay making the noise by touching them,it should be in the interior fusebox area & is usually blue.

Stuart McB
Posts: 1635
Joined: 03 Oct 2003, 00:50

Xsara Wiper Relay

Post by Stuart McB » 14 May 2005, 21:33

Hey mattpc. Sorry to hear you've got an problem with the old girl. There's some relays under the bonnet by the battery . Think there may be a block of about 4 or 5. Could be one of these. The Xsara ain't a multiplex model as it's an 98 VTR not late 99 onwards. There are, I think some relays beind the fuse box. Torch up behind the pedals. Again there's a block of 4 or 5 if memeory serves me well. Had one changed at the dealer on my first VTR and it cost only £20 but that was a bout 5 years back.

mattpc
Posts: 198
Joined: 21 Oct 2004, 17:31

Xsara Wiper Relay

Post by mattpc » 14 May 2005, 22:58

Also Stu, There appears to be a small leak at the top left of the sump. I notice in the history that the sump bolts have been tightened in the past. What's the crack? Doesn't seem to lose oil particularly so I'm not overly worried but your thoughts would of course be welcome.[:)]

Stuart McB
Posts: 1635
Joined: 03 Oct 2003, 00:50

Xsara Wiper Relay

Post by Stuart McB » 15 May 2005, 20:24

Had a new crank shaft oil seal fitted when the timming belt was done. Not a big job and seal from Citroen cost only £0.70p. The garage said that they had noticed the sump bolts were not torqued up to spec, so they re-torqued them. Thats as mush as I know mate. Never dropped any oil as far as me drive shows.

mattpc
Posts: 198
Joined: 21 Oct 2004, 17:31

Xsara Wiper Relay

Post by mattpc » 15 May 2005, 21:21

No worries. Car is running fine so am very happy with it. Cheers, Matt.