ZX Volcane Poor Idling

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Marly
Posts: 5
Joined: 26 Feb 2001, 19:02

ZX Volcane Poor Idling

Post by Marly » 03 Apr 2001, 18:27

My poor ZX (2.0 8V, 97K L plate) is not returning to idle properly, there is no misfiring when it does pickup and there is no loss of power at all. It just dies when I release the clutch at any speed.
Its serviced regularly (every 5-6k, by me) the plugs are good, new air filter etc
Whats gone wrong?
Help?

Jon

Post by Jon » 05 Apr 2001, 22:27

This problem is usually caused by a lazy idle speed correction valve,located on the inlt manifold. Replacement is the only option!!

Marly
Posts: 5
Joined: 26 Feb 2001, 19:02

Post by Marly » 06 Apr 2001, 19:05

Cheers Jon,
I'll give it a go and report back in a week or so!!
Marly

vonnig
Posts: 7
Joined: 14 Apr 2001, 21:37

Post by vonnig » 14 Apr 2001, 21:41

when u say idle speed correction valve... do u mean the throttle potentiometer?
coz i get something like that... most of the time it's ok... but sometimes after extensive use... the engine just dies on me while idling... or stopping at traffic lights...

kvseng
Posts: 3
Joined: 14 Mar 2001, 11:54

Post by kvseng » 17 Apr 2001, 15:45

I have this problem few years back, what I did was chage the throttle potentiometer.
I read from some other forum mention that it's possible to fix the potentiometer by open it up and change the resister inside. [:)]

vonnig
Posts: 7
Joined: 14 Apr 2001, 21:37

Post by vonnig » 17 Apr 2001, 19:03

i'm not too great with soldering, electronics and the likes of it... so i wouldn't dare to tamper with it lest i create more trouble in the car... but i'll give that a try... thanx