GSA MOT

Dedicated to owners of Citroen GS and GSA models.

Moderator: RichardW

User avatar
red_dwarfers
donor 2017
Posts: 2518
Joined: 29 May 2008, 15:59
x 17

GSA MOT

Post by red_dwarfers » 29 Jan 2015, 21:26

It's terrible really, I haven't quite got the balance right as I don't spend enough time on here posting!

Annabelle went for her annual routine checkup on Saturday just gone and failed. Only a couple silly things:

Rear fog light (corrosion on the fuse I reckon as the fog light lamp on the dash isn't playing either, its happened before)
Corrosion on the wheelarch underneath the battery tray
Windscreen washers (I cleaned these out the day before but it seems they blocked up again by the test.

Going to spend a weekend late March sorting these bits out as I'm now a good 30 miles away from the car. Hoping to get the XM on the road by April/May too.

User avatar
Citroenmad
Posts: 8106
Joined: 04 Dec 2008, 23:08
x 1

Re: GSA MOT

Post by Citroenmad » 29 Jan 2015, 22:16

All in a days work that Kev, and a short one at that!

I'm looking forward to this road salt disappearing and being able to use the Ami 8 8-)

citronut
Posts: 10939
Joined: 29 Apr 2005, 00:46
x 3

Re: GSA MOT

Post by citronut » 30 Jan 2015, 21:25

was the fog lamp tested/tried with the head lamps on dip beam, as they are powered from this circuit,

maybe the washers had frozen up in your part of the world :yikes: #-o :roll: :-D :wink:

User avatar
red_dwarfers
donor 2017
Posts: 2518
Joined: 29 May 2008, 15:59
x 17

Re: GSA MOT

Post by red_dwarfers » 03 Feb 2015, 16:17

Thats a good point Malc, seem to remember you telling me this last year!
I shall check next time I'm with the G.

Yeah, there is a bit of a crack. I'll take a photo in a couple of weeks.

That the trouble with being 40 odd miles away.