Lexia2 limitations

This is the place for posts that don't fit into any other category.

Moderator: RichardW

Sl4yer
Posts: 847
Joined: 12 Apr 2003, 04:29

Post by Sl4yer » 27 Apr 2010, 16:25

There's some Pug info here Mike, which may be similar. Of course, who's to say it's correct? :roll:

I checked the pins in my Chexia 3 the other night. All are connected except pin 4...

James

User avatar
MikeT
Posts: 4534
Joined: 11 Jun 2007, 16:17
x 150

Post by MikeT » 28 Apr 2010, 12:25

Hi James,

Thanks for the info. The Pug diagram adds weight to the suspicion that there could be more pins connected than I currently have. To confirm this, I've been searching for the wiring diagram which shows the 16-pin DLC but it's eluding me. Obviously it won't show the pinouts for the other end of my cable but it'll be a good starting point to nailing down my Lexia failures.

User avatar
MikeT
Posts: 4534
Joined: 11 Jun 2007, 16:17
x 150

Post by MikeT » 30 Apr 2010, 18:51

With kind thanks to citrojim in providing me with the missing pinouts, I'm very pleased to announce I can now get dialogue with all ECU's in my Xantia. :clap: \:D/

If you're reading this Toby, I'd appreciate the loan of your Coupe again sometime to check my "Diaxia" can now fully diagnose Pugs as well.

Toby_HDi
Posts: 1354
Joined: 05 Jan 2008, 22:31

Post by Toby_HDi » 30 Apr 2010, 22:14

Mike, great news.

I did post on t'other site but got no interest whatsoever.

Can pop over Sunday or Monday, whichever is easier. I also have your replacement tool.

citronut
Posts: 10939
Joined: 29 Apr 2005, 00:46
x 3

Post by citronut » 30 Apr 2010, 22:19

Mike i have sent you a PM regarding the pin outs you required, but see you are sortted now, but if you would like my version also just to confuse a bit more, send me your email address and i will forward it to you, as i have scanned it into my comp the nooooo

regards malcolm

Sl4yer
Posts: 847
Joined: 12 Apr 2003, 04:29

Post by Sl4yer » 30 Apr 2010, 22:34

Mike,

Any chance you can share the correct pinouts? My Chexia will do everything but the aircon. I've got another car in mind to test it on, in case my Activa is faulty, but I've got to psyche myself up to approaching a total stranger who probably won't know what I'm on about!

James

User avatar
MikeT
Posts: 4534
Joined: 11 Jun 2007, 16:17
x 150

Post by MikeT » 30 Apr 2010, 22:42

:oops: I should of course extend my thanks to citronut and superloopy1 for their kind assistance, time and patience as I know too well what a PITA it is to have to buzz out looms single-handedly. Even moreso if you got a digit missing :!:

Thanks also to Toby for letting me "experiment" on his pride and joy. Brave man! Oh, and don't worry about replacing the broken tool Toby, I know you wouldn't make me pay if I broke your car :P :wink: Toby, please call whenever's convenient for you. I'll be around all weekend.

Malcolm, PM replied and complied.

User avatar
MikeT
Posts: 4534
Joined: 11 Jun 2007, 16:17
x 150

Post by MikeT » 02 May 2010, 19:26

Sl4yer wrote:Mike,

Any chance you can share the correct pinouts?
Unfortunately, the Lexia3 and Lexia2 terminate in different connectors and I was given the pinouts from OBDII 16 pin to D-Sub 37-pin whereas I believe you have OBDII 16-pin to round 30-pin?

Sl4yer
Posts: 847
Joined: 12 Apr 2003, 04:29

Post by Sl4yer » 03 May 2010, 01:13

MikeT wrote:Unfortunately, the Lexia3 and Lexia2 terminate in different connectors and I was given the pinouts from OBDII 16 pin to D-Sub 37-pin whereas I believe you have OBDII 16-pin to round 30-pin?
That's correct Mike. Perhaps you could tell me (although I think I know the answer!) whether pin 4 on the OBD2 plug goes anywhere on the Lexia 2. I'm suspecting it does!

Thanks,

James

wheeler
Posts: 3624
Joined: 21 Sep 2002, 19:07
x 60

Post by wheeler » 03 May 2010, 10:42

Sl4yer wrote:Mike,

Any chance you can share the correct pinouts? My Chexia will do everything but the aircon. I've got another car in mind to test it on, in case my Activa is faulty, but I've got to psyche myself up to approaching a total stranger who probably won't know what I'm on about!

James
Have you tried to get dialogue with the enging running ?
Lexia tells you on some models that the engine needs to be running to get dialogue with AC.

citronut
Posts: 10939
Joined: 29 Apr 2005, 00:46
x 3

Post by citronut » 03 May 2010, 11:04

James wrote
"whether pin 4 on the OBD2 plug goes anywhere on the Lexia 2. I'm suspecting it does!"

on my 37 to 16/OBD lead for my DIS/LEXIA 2, pin 4 on th 16 pin OBD plug goes to pin's 3 and 21 on the 37 pin D plug,

regards malcolm

User avatar
xantia_v6
Forum Admin Team
Posts: 5694
Joined: 09 Nov 2005, 23:03
x 231

Post by xantia_v6 » 03 May 2010, 12:10

Sl4yer wrote: Perhaps you could tell me (although I think I know the answer!) whether pin 4 on the OBD2 plug goes anywhere on the Lexia 2. I'm suspecting it does!
On my chinese lexia 3, (which also refuses to talk to several ECUs), the conne ctions on that cable (round connector LH column, 20 pin connector on PCB center column, 16 pin connector RH column):

Code: Select all

1  14 1
2  9  12
3  2  5
4  17 5
5  19 9
6  1  16
7  7  13
8  10 3
10 16 -
11 6  7
12 11 10
13 15 -
14 5  14
15 14 -
16 13 -
21 4  8
24 12 2
25 18? 11
29 3  15
30 8  6
I think that pin 4 is deliberately not connected as it iand pin 5 are ground pins on the car, and a ground-loop could damage the lexia if both were connected.

The internal pin number with a question mark above is actually O/C in my cable, but I am fairly sure it connects to (at least) the A/C ECU.

Sl4yer
Posts: 847
Joined: 12 Apr 2003, 04:29

Post by Sl4yer » 03 May 2010, 15:58

xantia_v6 wrote: I think that pin 4 is deliberately not connected as it iand pin 5 are ground pins on the car, and a ground-loop could damage the lexia if both were connected.

The internal pin number with a question mark above is actually O/C in my cable, but I am fairly sure it connects to (at least) the A/C ECU.
Thanks for that Mike, and everyone else for the info. (I've got the same OBD2 to 30-pin connections as you). Mine will connect to everything except the aircon ECU (that is, engine, suspension, CPH, ABS all work fine). I think another car to try must be my next option.

Wheeler, I always Lexia with the engine running (usually exercising the suspension up and down), although I've tried it with the engine off too just in case!

Anyhow, I'm dragging this thread off-topic - apologies MikeT!

James