My first Activa

Contains the Activa Register, Buyers Guide and Activa "finds" on eBay and elseware. Post Activa-specific items there that do not fall naturally into the Citroen Forum.

Moderator: RichardW

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » 04 Jun 2019, 18:01

myglaren Fingers crossed that can't happen again ... ever :lol: Besides the pick up has to get through two 'teabag' type filters before getting to the fuel line ....

User avatar
myglaren
Forum Admin Team
Posts: 15509
Joined: 02 Mar 2008, 14:30
x 399

Re: My first Activa

Post by myglaren » 04 Jun 2019, 19:43

As said highly unlikely but demonstrates how the improbable can become reality and bite us in the bum.

I once was called out to an FTP - a friends Cortina got half a mile from home and died.
Spent ages buggering a bout with it. Asked if he could have run out of petrol.
No chance it was filled up the previous evening.

Problem was that someone had cut the fuel line during the night and stolen all his petrol, except that in the carb and filter.

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » 09 Jun 2019, 10:40

Skull wrote:
02 Jun 2019, 15:02

Had a play with the old pump (no flow rating marked) whilst I've got it out ran it in a bucket of water to see flow rate as Admiral51 suggested into a bucket - emptied 4 Litres out of the bucket in 1m40s....so over 120 Ltr/hr would seem sufficient (even though there is some internal leakage on the upper join of the pipe).

Image

XANTIA FUEL PUMP.JPG


The pump strips down OK apart from the green plastic corrugated pipe that appears a push fit but even after warming with a hair dryer seems reluctant to come off, so even if I did use the new motor the pipework would probably need replacing as well but having confirmed the flow rate looks ok on the old pump I'm inclined just to put it all back together (try to slow the internal leak with plastic tie wrap) and move to the next stage of elimination ......
Well I've had 2 test runs and there is some improvement :chin: just from fitting a plastic tie wrap to the upper join so I hope I've found the problem [-o< ....now to improve the solution ....

When I ran the flow test in a bucket of water there was some leakage from the upper join which was visible but when I think back to that test 2 things occurred to me:

1. The outlet was free flowing with no resistance in the pipe (simulating pressure with my thumb over the end of the pipe would probably make the internal leak increase).

2. The lower join could also be leaking but not apparent as it was submerged under the water level.

Whilst searching for replacement pumps I have noticed that some of these type of pumps have clamps on the internal hose joins but there wasn't any on mine and I also wonder whether these joints could have opened up due to the long term storage that this car has experienced.

So I will remove the pump again :roll: and measure up for some hose clamps for the internal green corrugated pipe, ideally without removing the pipe with these type
hose clamps.jpg
ebay hose clamps
or failing that replace the pipe with some suitable fuel line and clamps .....

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » 12 Jun 2019, 16:45

Herbie Clip HC-B 7.9 - 9.2 (eBay item number:142655726135)
£3.58 for 10 clips arrived and although they fit as pictured (black) I put 2 on each pipe end and they open up enough to slip on the pipe without removing an end so ideal as saves replacing the old pipe.

HC-BB 9.2 - 10.3 would be ideal I think allowing more teeth to engage securely.
Fuel line crimps (1).JPG
Herbie Clip
Fuel line crimps (2).JPG
Herbie Clip
Pump to re-fit and test drive .... [-o<

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » 16 Jun 2019, 20:47

Intermission break ...

Got a leaky T piece on the return line from front safety valve 5451210 NFP

Had a look online with no luck so far .... anyone got a spare one or two ?

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » Yesterday, 16:52

DSCF0006.JPG
Leaking T piece
Used the hose off the old front suspension leg leak off to make another T piece with an old windscreen washer T piece .... pictures best story ...
Parts.JPG
Parts
New T.JPG
New T piece
repaired.JPG
Repaired
Many Thanks for input on SALE/WANTED PAGE guys =D>

User avatar
Stickyfinger
Donor 2016
Posts: 9453
Joined: 28 Mar 2013, 22:05
x 614

Re: My first Activa

Post by Stickyfinger » Yesterday, 20:42

Looks like some pipes need a little protection in there mate....

User avatar
Skull
donor 2017
Posts: 494
Joined: 02 Aug 2013, 13:35
x 21

Re: My first Activa

Post by Skull » Yesterday, 23:02

Alasdair yes mate I've slapped some grease on them :oops: could probably do with something heavier on them as the grease does seem to disappear after a while.