Forum outage 05/07/2016

Forum News, Announcements and any issues you're having with the forum

Moderator: myglaren

User avatar
xantia_v6
Forum Admin Team
Posts: 4701
Joined: 09 Nov 2005, 23:03
Location: Christchurch, New Zealand
My Cars: -
1997 Citroen Xantia V6 (France)
1999 Citroen XM V6 ES9 (France)
2011 Peugeot 308 CC THP 155 (NZ)
1975 Jaguar XJ-S pre-HE (NZ)
x 136

Forum outage 05/07/2016

Post by xantia_v6 » 05 Jul 2016, 14:45

The forum has been down for a couple of hours due to a database cache file corruption.

I don't know what caused it, and I have only taken the minimal steps to rebuild the cache at this time.

If the problem recurs, I will need to do a more complete cleaning of the database itself, but would rather not do that today.
0x

User avatar
CitroJim
A very naughty boy
Posts: 39289
Joined: 30 Apr 2005, 23:33
Location: North Bucks
My Cars: An orange Skoda 120, a pretty blue Pug 207, Sally the white Saxo, a Giant TCR Bike and a Giant TCR Pro Bike.
x 731

Re: Forum outage 05/07/2015

Post by CitroJim » 05 Jul 2016, 15:05

Mike, a big thanks for all your hard work on this today, excellent work..

I guess I was very lucky when a similar problem happened yesterday afternoon and I was able to get away with just restarting the daemon!
0x
Jim

Please note I do not accept PMs...

User avatar
xantia_v6
Forum Admin Team
Posts: 4701
Joined: 09 Nov 2005, 23:03
Location: Christchurch, New Zealand
My Cars: -
1997 Citroen Xantia V6 (France)
1999 Citroen XM V6 ES9 (France)
2011 Peugeot 308 CC THP 155 (NZ)
1975 Jaguar XJ-S pre-HE (NZ)
x 136

Re: Forum outage 05/07/2015

Post by xantia_v6 » 05 Jul 2016, 17:03

I took the forum down again for some more maintenance. I have now 'cleaned' the database data files.

Lets see if it behaves itself.
0x

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6648
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 455

Re: Forum outage 05/07/2015

Post by GiveMeABreak » 05 Jul 2016, 17:04

xantia_v6 wrote:The forum has been down for a couple of hours due to a database cache file corruption.
I don't know what caused it, and I have only taken the minimal steps to rebuild the cache at this time.
If the problem recurs, I will need to do a more complete cleaning of the database itself, but would rather not do that today.


Aahh back up - ignore email Jim - just noted the Thread Title says 5/7/2015 Mike :-D
0x
Marc

User avatar
xantia_v6
Forum Admin Team
Posts: 4701
Joined: 09 Nov 2005, 23:03
Location: Christchurch, New Zealand
My Cars: -
1997 Citroen Xantia V6 (France)
1999 Citroen XM V6 ES9 (France)
2011 Peugeot 308 CC THP 155 (NZ)
1975 Jaguar XJ-S pre-HE (NZ)
x 136

Re: Forum outage 05/07/2016

Post by xantia_v6 » 05 Jul 2016, 17:07

I have not restored the wiki yet, as I have some other maintenance to do on that tomorrow (or Thursday).
0x

Online
Hell Razor5543
NOT Alistair or Simon
Posts: 7362
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 312

Re: Forum outage 05/07/2016

Post by Hell Razor5543 » 05 Jul 2016, 17:20

Erm, I lost access to the forum for about an hour just now.
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

User avatar
GiveMeABreak
Forum Admin Team
Posts: 6648
Joined: 15 Sep 2015, 19:38
Location: West Wales
My Cars: '09 C5 X7 2.0 HDi Exclusive Mativoire Beige (The Golden Hornet)
'07 C3 1.6 HDi Exclusive Aluminium Grey (The Silver Hornet)
Past:
'76 GS 1000 Cedreat Yellow (yuk)
'79 GS 1220 Geranium Red
'78 CX 2.4 Turbo Prestige C-Matic Nevada Beige
'84 CX 20 Polar White
'90 XM 2.0 SX Polar White
'93 XM 2.0 Turbo Prestige Polar White
'94 XM 2.0 Turbo Prestige Emerald Green Pearlescent
'98 C15 Romahome White
'99 Xantia 2.0 HDi SX Hermes Red
'01 C5 2.0 HDi SX Wicked Red
'05 C5 2.0 HDi Exclusive Obsidian Black
x 455

Re: Forum outage 05/07/2016

Post by GiveMeABreak » 05 Jul 2016, 17:21

xantia_v6 wrote:I have not restored the wiki yet, as I have some other maintenance to do on that tomorrow (or Thursday).

Wasn't being picky Mike re the 2015 in the thread - just went there to see if there were any issues and initially thought it was an older post until I saw Jim's post dated 5/7/16! :wink:
0x
Marc

User avatar
xantia_v6
Forum Admin Team
Posts: 4701
Joined: 09 Nov 2005, 23:03
Location: Christchurch, New Zealand
My Cars: -
1997 Citroen Xantia V6 (France)
1999 Citroen XM V6 ES9 (France)
2011 Peugeot 308 CC THP 155 (NZ)
1975 Jaguar XJ-S pre-HE (NZ)
x 136

Re: Forum outage 05/07/2016

Post by xantia_v6 » 07 Jul 2016, 14:05

The server was still having issues this morning, but I think I found a problem relating to a (semi-) automatic software upgrade of the database service that happened last week. I have reverted to the old version of that package, and crossed my fingers.
0x

User avatar
CitroJim
A very naughty boy
Posts: 39289
Joined: 30 Apr 2005, 23:33
Location: North Bucks
My Cars: An orange Skoda 120, a pretty blue Pug 207, Sally the white Saxo, a Giant TCR Bike and a Giant TCR Pro Bike.
x 731

Re: Forum outage 05/07/2016

Post by CitroJim » 07 Jul 2016, 14:15

Thanks Mike, excellent :D

xantia_v6 wrote:and crossed my fingers.


Mine are too, plus everything else!
0x
Jim

Please note I do not accept PMs...

Gibbo2286
Posts: 2156
Joined: 08 Jun 2011, 18:04
Location: GL15***
My Cars: 2004 C5 2.0 litre HDI
x 148

Re: Forum outage 05/07/2016

Post by Gibbo2286 » 07 Jul 2016, 14:52

I don't know if this helps but it's what came up this morning when I tried to log in.


General Error

SQL ERROR [ mysqli ]

Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111) [2002]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
0x

User avatar
xantia_v6
Forum Admin Team
Posts: 4701
Joined: 09 Nov 2005, 23:03
Location: Christchurch, New Zealand
My Cars: -
1997 Citroen Xantia V6 (France)
1999 Citroen XM V6 ES9 (France)
2011 Peugeot 308 CC THP 155 (NZ)
1975 Jaguar XJ-S pre-HE (NZ)
x 136

Re: Forum outage 05/07/2016

Post by xantia_v6 » 07 Jul 2016, 14:57

Yes, that was the symptom of the database service randomly crashing and restarting itself.
The version that was installed by the software updater last week was definitely wrong, so I hope that it will now be stable again.
0x

Online
Hell Razor5543
NOT Alistair or Simon
Posts: 7362
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 312

Re: Forum outage 05/07/2016

Post by Hell Razor5543 » 07 Jul 2016, 17:14

Obviously that database was a final product from the Rover factories, if it could crash by itself. I had that error a few times as well. If you have a Citroen version installed do make sure to leave one small problem in it, otherwise it will get confused with being fully functional and crash anyway. :-D
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

User avatar
CitroJim
A very naughty boy
Posts: 39289
Joined: 30 Apr 2005, 23:33
Location: North Bucks
My Cars: An orange Skoda 120, a pretty blue Pug 207, Sally the white Saxo, a Giant TCR Bike and a Giant TCR Pro Bike.
x 731

Re: Forum outage 05/07/2016

Post by CitroJim » 07 Jul 2016, 17:24

Hell Razor5543 wrote:Obviously that database was a final product from the Rover factories, if it could crash by itself. I had that error a few times as well. If you have a Citroen version installed do make sure to leave one small problem in it, otherwise it will get confused with being fully functional and crash anyway. :-D


:lol:

MySQL is definitey a Citroen database as when it works it is brilliant but when it doesn't it can be a bit or a ********* :wink:

Luckily the not working time is often very, very small. That differentiates it from a Rover... That's Microsoft SQL Server :twisted:

I know only too well - it's how I earn my money....
0x
Jim

Please note I do not accept PMs...