Xantia Air Conditioning

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Xantia Air Conditioning

Post by weety » 24 Oct 2004, 14:12

Hello there fellow citroen owning dudes
i have had citroens since year dot (my first car was the old 652 cc visa) and have finally got a xantia with air con......except as its a citroen it has the usual range of electrical problems.
now i have solved most of them but my air con well here goes...
the fan switches work very very intermitantly (of course they worked on the test drive but only rarely since then) when the fans are set to auto and they should be working sometimes you get a sort of ticking rattling noise from the middle panel (but no smoke or fire yet)
the actual fan unit itself looks to be newish (from the stickers on it 2000) and given a live feed it happily spins away to itself.
on a seperate (or maybe connected note) the temparature sensor doesnt seem to work- on its coldest setting it seems to run the cabin temparature to hot, on its hottest setting it alternates between chucking out hot air and freezing air (which methinks is probably not how citroen intended it to work)
so do i have one problem or two? and would changing the fan unit fix it (i have noticed they cosy about £100 and even scrapppies seem to want tons for them)
any help advice or steers in the right direction would be gratefully appreciated
0x

Richard Gallagher
Posts: 803
Joined: 31 Oct 2001, 03:36
Location: South Bucks
My Cars:

Post by Richard Gallagher » 25 Oct 2004, 01:14

The temperature sensor is fitted behind the alarm LED, air is drawn over it by way of a small fan which may be the noise you can hear in the 'middle panel'. Get this sorted out first, the small fan is well known for causing problems such as being noisy. If air is not being drawn over the sensor then the aircon cannot function reliably.
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 26 Oct 2004, 00:27

thanks i will get busy with my blunt screwdrivers tomorrow
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 26 Oct 2004, 17:13

well i ripped out (i mean carefully removed) the led unit (must remember to reset the clock now) and discovered a spinning fan (which i take it is good) it seems to spin all the time that the ignition is on and isnt noisy how do i check it is working ok??
0x

andycarter
Posts: 170
Joined: 01 Aug 2003, 03:49
Location: United Kingdom
My Cars:

Post by andycarter » 07 Nov 2004, 14:50

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">on a seperate (or maybe connected note) the temparature sensor doesnt seem to work- on its coldest setting it seems to run the cabin temparature to hot, on its hottest setting it alternates between chucking out hot air and freezing air<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">
In the owners handbook it says that the automatic temperature regulation doesn't work when the temp control is set to min or max, you have to specify a tempertature.
0x

ghostrider
Posts: 360
Joined: 05 Jan 2002, 02:10
Location: United Kingdom
My Cars:

Post by ghostrider » 07 Nov 2004, 19:46

Are you talking about the fan in the passenger comptartment or the cooling fans which run when the air con is engaged?
Pete
________
Motorcycle Tires
Last edited by ghostrider on 22 Feb 2011, 06:56, edited 1 time in total.
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 07 Nov 2004, 23:40

i meant the internal fan, the external fans seem to work properly (well they spin round anyway)
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 08 Nov 2004, 03:09

i will try setting it to a temperature somewhere in the middle-unfortuntaely didnt get owners guide when i got car (got a strange sticky mess under one of the seats though!)
0x

bernie
Posts: 882
Joined: 10 Apr 2001, 02:25
Location: Southampton United Kingdom
My Cars:

Post by bernie » 08 Nov 2004, 03:13

Do you want me to scan the A/c workings from my owner's guide and email to you?
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 08 Nov 2004, 03:22

that would be great if you could do that mate cheers
0x

bernie
Posts: 882
Joined: 10 Apr 2001, 02:25
Location: Southampton United Kingdom
My Cars:

Post by bernie » 08 Nov 2004, 03:30

Can you post your email address?
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 08 Nov 2004, 03:30

sure thing its
0x

bernie
Posts: 882
Joined: 10 Apr 2001, 02:25
Location: Southampton United Kingdom
My Cars:

Post by bernie » 08 Nov 2004, 03:35

I'll get it to you tomorrow, Peter
I've copied your address.
It's probably best to remove your address now before a spammer gets it
0x

weety
Posts: 528
Joined: 24 Oct 2004, 13:49
Location: United Kingdom
My Cars:

Post by weety » 08 Nov 2004, 03:44

thanks mate have a good week
peter
0x

bernie
Posts: 882
Joined: 10 Apr 2001, 02:25
Location: Southampton United Kingdom
My Cars:

Post by bernie » 08 Nov 2004, 22:25

Email sent
0x