Total heater control loss....

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

locostmike
Posts: 6
Joined: 31 Jul 2014, 21:47
Location:
My Cars:

Total heater control loss....

Post by locostmike » 31 Jul 2014, 22:18

Hi Folks,

I'm new to Citreons and the forum having just bought a 2001 Xantia estate that drives beautifully apart from that the heater/aircon doesn't work at all. In this hot weather, the car is BAKING HOT! I had it checked by my mechanic and he thinks it's the aircon module. Does anyone know if there's anything else we should check? Where is the unit located? Is there another fix?

many thanks

Mike
0x

User avatar
Xaccers
Posts: 7655
Joined: 08 Feb 2007, 00:46
Location: Milling around Milton Keynes
My Cars:
x 2

Re: Total heater control loss....

Post by Xaccers » 01 Aug 2014, 09:22

When you say heater/blower, are you able to get hot air on a cold day/night?
The hot/cold is controlled by a flap with a stepper motor that diverts air over the heater matrix or not.

Now if you've got blower action and it's blowing ambient air rather than cold a/c air, then check if the compressor clutch is engaging when the engine is on and the a/c is on. The end plate of it will be spinning rather than just the unner pulley where the belt sits. The rad fans should be spinning too.
If that's all working, then check the inspection window in the top of the dryer which is a black cannister. You should see lots of fluid/small bubbles flowing. If there's large bubbles or none you need a regas.
If the compressor isn't engaging, then you can short the two contacts on the pressure switch connector on the side of the dryer, just pull it off and use a paper clip or similar to make contact between them and the compressor should kick in.
If it doesn't then there's a bigger problem that will most likely need a specialist.
0x
1.9TD+ SX Xantia Estate (Cassy) running on 100% veg
1.9TD SX Xantia Hatchback (Jenny) running on 100% veg for sale
Laguna II 2.0dCi Privilege (Monty)

DIY sphere tool

locostmike
Posts: 6
Joined: 31 Jul 2014, 21:47
Location:
My Cars:

Re: Total heater control loss....

Post by locostmike » 01 Aug 2014, 14:27

Thanks for your reply Xac, neither the blower/temp. control or air con work at all :(
0x

Northern_Mike
x 48

Post by Northern_Mike » 01 Aug 2014, 14:44

Have any other electrical items like the heated rear window or electric seats (if it had them) stopped working?

Enviado desde mi GT-I9505 usando Tapatalk
0x

locostmike
Posts: 6
Joined: 31 Jul 2014, 21:47
Location:
My Cars:

Re: Total heater control loss....

Post by locostmike » 05 Aug 2014, 00:05

Nope, the rear window heater works fine. It has been mentioned that the control module needs replacing but when I remove the passenger footwell trim, it looks packed with stuff and access almost impossible. Are there any other cures?
0x