Xantia HDi 2.0 fans... in and out! FOUND IT! SEE TEXT!

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Xantia HDi 2.0 fans... in and out! FOUND IT! SEE TEXT!

Post by DeafOldFart » 27 Jul 2013, 23:16

One here for the puzzle enthusiasts...
No interior fan or engine cooling fans working. Battery removed to check everything behind it. Replaced battery, interior fan and aircon light on switch were working! Great! Turn key.. no starter.
A week later... discovered that the connector through the inner wing was not locked on, but locked out... reconnected, engine starts. Interior fan quit again... no light on aircon switch!!!!
Deep breath... check both cooling fans to earth, run fine. Where is the cooling fan control box located???
Before you ask... ignition switch works fine, interior fan motor fine, rear screen works.
I'm working through the cooling fan system now... might fix the internal issues when I find the external fault!
In the mean time - anyone else been here?

I'd love to find wiring and pics showing location of parts!!

Hope to hear from you all... Jim

STOP PRESS - found the snag... battery positive terminal, high resistance in one flylead to bus bar! Added more wires to carry current....
Last edited by DeafOldFart on 31 Jul 2013, 16:17, edited 2 times in total.
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting

Hell Razor5543
NOT Alistair or Simon
Posts: 7260
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 290

Re: Xantia HDi 2.0 fans... in and out!

Post by Hell Razor5543 » 28 Jul 2013, 00:14

This what you are looking for?

viewtopic.php?t=31403
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Re: Xantia Cooling Fans And AirCon Operation

Post by DeafOldFart » 28 Jul 2013, 07:17

Hi! That was quick! Thanks! I'm working my way through this exact info. right now... got as far as verifying supply, now seeking control system...half the battle is working out what the boxes do, and the other half finding them.. are there any pictures available showing the location and appearance?.
I saw a mention of the aircon going through a self test routine, before operation... surely the interior blower should work even if the A/C doesn't?

The little lead across the interior fan... when disconnected, fan sometimes started... also, fan sometimes ran at same speed whatever the controls were set to... not predictable!! Where are the earth and power feeds to the fan motor derived?

Kicking self for managing to disconnect multiway connector through inner wing and thus losing starter wire. Big waste of time... wiring schematic from some data system gave a schematic, no connector mentioned - thank you, very much..(!) The disappearing indicator light on the A/C button is a puzzle, supply goes when the rest of the car works okay! Is it an engineering joke?

Excuse the chaotic nature of the questions, I'm catching it from the car!

Thanks for the help! Jim
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Re: Xantia HDi 2.0 fans... in and out!

Post by DeafOldFart » 28 Jul 2013, 07:30

Hi, thanks for looking! I'm working on that info. already... and looking for details of the A/C and interior fan wiring. I've gone and posted a reply in the wrong place already, and left the site untidy... ooops.

I'll be back when I've checked out the cooling fans - if I can find the control system.

Thanks for your help so far! Much appreciated! Jim
Last edited by myglaren on 28 Jul 2013, 07:40, edited 1 time in total.
Reason: Post above moved/merged.
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting

Hell Razor5543
NOT Alistair or Simon
Posts: 7260
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 290

Re: Xantia HDi 2.0 fans... in and out!

Post by Hell Razor5543 » 28 Jul 2013, 09:05

There is also a known issue with the transistors on the blower fan control module. Replacing them normally sorts out the blower fan.

viewtopic.php?f=3&t=41428&hilit=xantia+blower+resistors
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Re: Xantia HDi 2.0 fans... in and out!

Post by DeafOldFart » 28 Jul 2013, 11:53

Hello Hell Razor... quick update, disconnecting blue temp sender makes both cooling fans run at high speed... no low speed period.
Where can I find the blower fan control module, and how can it be removed... my manual doesn't even mention its existence...
UPDATE - no light on A/C switch still.. seems to be a power supply issue from somewhere downstream of the ignition switch.
Thanks for your help! Jim
Last edited by DeafOldFart on 28 Jul 2013, 12:33, edited 1 time in total.
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting

Hell Razor5543
NOT Alistair or Simon
Posts: 7260
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 290

Re: Xantia HDi 2.0 fans... in and out!

Post by Hell Razor5543 » 28 Jul 2013, 12:16

I have not (yet) had either problem, and I hope that I never will. If you look on the third page of the second post I linked in, it indicated the module is on the blower fan motor. It also suggests that you use 30a transistors, as they can handle the load better (and try to get ones from the same production batch, for matching purposes).
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Re: Xantia HDi 2.0 fans... in and out!

Post by DeafOldFart » 28 Jul 2013, 12:40

Thanks for both links... I've found them useful in a sort of negative way!
Checked brown plug at motor, no volts... is this downstream of the module???
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting

Hell Razor5543
NOT Alistair or Simon
Posts: 7260
Joined: 01 Apr 2012, 09:47
Location: Reading
My Cars: C5 Mk1 VTR estate, Icelandic Grey (I think she is called "Bluebird")
x 290

Re: Xantia HDi 2.0 fans... in and out!

Post by Hell Razor5543 » 28 Jul 2013, 12:59

I am sorry, but all of my knowledge on the matter is from reading (and remembering) things on the forum.

It is possible that the light bulb in the a/c switch has failed. They do fail, but not very often (compared to the other bulbs).
0x
James
ex BX 1.9
ex Xantia 2.0HDi SX
ex Xantia 2.0HDi LX

C5 VTR HDi estate, 76518762
Out amongst the stars, looking for a world of my own!

DeafOldFart
Posts: 18
Joined: 18 Jul 2013, 08:38
Location:
My Cars:

Re: Xantia HDi 2.0 fans... in and out!

Post by DeafOldFart » 28 Jul 2013, 22:45

Thank you very much for your help so far! I have sort of redefined the problem now... no power is getting to the blower at all, and it is very probable that the aircon control derives its power from the same source. Verifying that will take a wiring diagram! Now, if I can find one of them...

Good luck with your silver Xantia!! Jim
0x
Just because you can't see it, don't mean it ain't there..... if it floats, flies or fornicates ,you are better off renting